Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 05:23
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Printer HP Deskjet D1460 doesn't work in Puppy Linux
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
martigej

Joined: 10 Jan 2013
Posts: 20

PostPosted: Thu 10 Jan 2013, 19:24    Post subject:  Printer HP Deskjet D1460 doesn't work in Puppy Linux
Subject description: Printer HP Deskjet D1460 doesn't work in Puppy Linux
 

Hi!
I'm trying to install a Printer HP Deskjet D1460 in a Puppy Linux version 5.3.3, but without success until now.
I have CUPS 1.4.6 installed, but the printer D1460 don't appear in the list of printers.
I'm not experienced in Linux, so please, I need help to put my Deskjet to work.
In CUPS, there is an option to include a PPD file, but I can't find a PPD file for D1460.
I appreciate any help.

Thank you.
Back to top
View user's profile Send private message 
martigej

Joined: 10 Jan 2013
Posts: 20

PostPosted: Thu 10 Jan 2013, 19:52    Post subject:  

Ok... My problem was solved.
I finally get the printer working.
The solution, was install the PET: hplip_print_legacy_cups_patch-1.3.11.pet, downloaded in http://www.murga-linux.com/puppy/viewtopic.php?t=59015.
I have seen this PET, but in description is write that this PET is "Only needed with old CUPS 1.3.11".
My version is CUPS 1.4.6, but was necessary this PET...
Just for clarify: Is this description wrong? Or I missed something else?

Thank you.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Thu 10 Jan 2013, 20:19    Post subject:  

Go to Menu > Setup > Set up Puppy > Puppy Package Manager.

Click on Uninstall.

What packages do you actually have installed? I suspect that you have hplip_print-3.12.10a.pet.
Back to top
View user's profile Send private message 
martigej

Joined: 10 Jan 2013
Posts: 20

PostPosted: Thu 10 Jan 2013, 20:31    Post subject:  

You are correct. The package is hplip_print-3.12.10a.pet.

But I notice another thing: the cups package is cups-1.3.11-i486, but in web browser, on http://localhost:631/, the version showed is CUPS 1.4.6.
Is this an error?

Thank you.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Thu 10 Jan 2013, 20:34    Post subject:  

martigej wrote:
But I notice another thing: the cups package is cups-1.3.11-i486.

Where are you seeing this package? Is this something that you installed on your own?
Back to top
View user's profile Send private message 
martigej

Joined: 10 Jan 2013
Posts: 20

PostPosted: Fri 11 Jan 2013, 17:23    Post subject:  

I'm seeing on PPM.
I'm not sure if was installed by me. I did a lot of trying for the printer works...
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0418s ][ Queries: 12 (0.0042s) ][ GZIP on ]