Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Sep 2014, 10:13
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Gtkdialog Development
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 48 of 55 Posts_count   Goto page: Previous 1, 2, 3, ..., 46, 47, 48, 49, 50, ..., 53, 54, 55 Next
Author Message
EDDIE_THE_HEAD


Joined: 02 Dec 2012
Posts: 15
Location: Córdoba, Argentina

PostPosted: Thu 13 Dec 2012, 18:32    Post_subject:  

@Thunor

Thanks for everything. I haven't tried that C code you posted 'cause I've been occupied with other things and had no time to fix some issues in the virtual machine where I'm running Ubuntu. I believe that (the fact that I'm running it in VirtualBox) is the only difference in my setup, so it could certainly be the source of the problem. In fact, I've encountered much more trouble than I ever had when Ubuntu was my host OS.

I'll get back to you as soon as I can run the tests you suggested.

Cheers.
Back to top
View user's profile Send_private_message 
thunor


Joined: 14 Oct 2010
Posts: 350
Location: Minas Tirith, in the Pelennor Fields fighting the Easterlings

PostPosted: Sun 06 Jan 2013, 12:57    Post_subject:  

Gtkdialog 0.8.3 Released

Changes:
* Solved the hidden widgets leaving artifacts at start-up problem.
* Added support for conditional actions with <action condition="type">.
* Added support for <variable export="false">VARNAME</variable>.
* Added button-press/release-event signals to comboboxentry's entry.
* Added support for break i.e. don't process any more actions.
* Connected-up the realize signal so that it can be used within actions.
* Refreshing markup in a text widget now works as expected.
* Added three new examples including the Pfeme emulator front-end.
* Fixed bashisms within examples where possible and made them portable.
* Fixed three examples.

http://code.google.com/p/gtkdialog/downloads/list

It's gone quiet so it must've matured by now Smile Thanks to everyone who assisted with testing.

If anyone's interested I've written an emulator front-end using gtkdialog called Pfeme. I actually used a very small piece of perl code to merge the times-played data into the games list and it's so fast! I really recommend taking a look at perl to manage the complex parts of your applications.

Regards,
Thunor
Back to top
View user's profile Send_private_message Visit_website 
frafa


Joined: 04 Aug 2011
Posts: 10
Location: MONTPELIER

PostPosted: Thu 10 Jan 2013, 13:23    Post_subject:  

Hi Thunor
HAPPY NEW YEAR 2013 :)
Thank you for this new version of gtkdialog,
I put the packages for Ubuntu/Debian Bits 32 and 64 provide a ...
It is here: http://liveusb.info/tmp/gtkdialog-0.8.3/

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
don570


Joined: 10 Mar 2010
Posts: 3289
Location: Ontario

PostPosted: Thu 10 Jan 2013, 21:11    Post_subject:  

I put the gtkdialog examples in an easy to install pet package

http://murga-linux.com/puppy/viewtopic.php?t=82059


__________________________________________________
Back to top
View user's profile Send_private_message 
SFR


Joined: 26 Oct 2011
Posts: 1068

PostPosted: Sun 03 Feb 2013, 09:08    Post_subject:  

Hey Thunor et al

There's ambiguous behaviour of <spinbutton> when floating point values are in use.

Example 1:
Code:
echo '<spinbutton range-step="0.01"></spinbutton>' | gtkdialog -s

works fine with English country settings (dot as a decimal separator), but fails with, eg. German (comma as separator).

Example 2:
Code:
echo '<spinbutton range-step="0,01"></spinbutton>' | gtkdialog -s

and the situation is opposite.

Ref:
http://murga-linux.com/puppy/viewtopic.php?p=681587#681587
http://murga-linux.com/puppy/viewtopic.php?p=682138#682138 (last sentence)

Is there anything what can be done about it, or the only way is to determine which type of decimal separator is in use (btw, what's the best way to do so?), before I export the GUI?

Thanks & Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send_private_message 
thunor


Joined: 14 Oct 2010
Posts: 350
Location: Minas Tirith, in the Pelennor Fields fighting the Easterlings

PostPosted: Mon 04 Feb 2013, 17:32    Post_subject:  

@SFR: Read from here onwards. Argolance (French user) I believe solves it 8 posts later.

Basically the decimal mark requires internationalising within your script.

Regards,
Thunor
Back to top
View user's profile Send_private_message Visit_website 
SFR


Joined: 26 Oct 2011
Posts: 1068

PostPosted: Mon 04 Feb 2013, 19:11    Post_subject:  

Thanks!

In the meantime I made up an alternative (not extensively tested), "dirty" method based on printf error:
Code:
[ "`printf %.1f 1.1 2> /dev/null`" = "1.1" ] && echo "DOT" || echo "COMMA"

however Argolance's looks more elegant. Smile

Thanks again & Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send_private_message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Fri 22 Feb 2013, 06:24    Post_subject:  

.
Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
thunor


Joined: 14 Oct 2010
Posts: 350
Location: Minas Tirith, in the Pelennor Fields fighting the Easterlings

PostPosted: Mon 25 Feb 2013, 08:18    Post_subject:  

simargl wrote:
Hello,
Are there plans for gtkdialog to support GTK3?
I want to use gtk3 (3.6) in next release of ArchPup http://www.murga-linux.com/puppy/viewtopic.php?t=84353 and currently
only 3 applications - gtkdialog, geany, firefox - require keeping GTK2.
Kind regard

This is on the to-do list but I'll need to install a GKT+ 3 distro and I've become accustomed to downloading a puppy ISO and extracting the few files necessary, so if it involves burning an oversized ISO image then I'll have to locate my sole CD-RW disc packed away in one of my boxes which likely won't be oversized enough anyway.

Maybe it's as simple as changing the gtk+ and gthread version numbers in configure.in and running ./autogen.sh? I doubt it but it's the first thing I would do.

Regards,
Thunor
Back to top
View user's profile Send_private_message Visit_website 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Mon 25 Feb 2013, 09:11    Post_subject:  

.
Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
thunor


Joined: 14 Oct 2010
Posts: 350
Location: Minas Tirith, in the Pelennor Fields fighting the Easterlings

PostPosted: Mon 25 Feb 2013, 10:57    Post_subject:  

I've found Mageia 2 which uses gtk+ 3.6.2 on a 671MB live CD so I'll dig out my CD-RW over the next few days and partition/install/set-up etc. I'm sure ArchPup is really nice but for me it makes sense to develop on a mainstream distro that is ready to go.

Leave it with me, it'll take some time to get just the development environment running but it might be pretty straightforward after that.

Regards,
Thunor
Back to top
View user's profile Send_private_message Visit_website 
scsijon

Joined: 23 May 2007
Posts: 1042
Location: the australian mallee

PostPosted: Sat 02 Mar 2013, 22:20    Post_subject:  

@thunor, there is a mage2 puppy in next to final beta out, I'm awaiting a few retro fixes by the mageia people before bringing the final beta out, if it's any help.

The link is below!

_________________
Puppy T290 - BarryK's Racy but with T2 Version 9.0 is under development.
http://www.murga-linux.com/puppy/viewtopic.php?t=94575

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
thunor


Joined: 14 Oct 2010
Posts: 350
Location: Minas Tirith, in the Pelennor Fields fighting the Easterlings

PostPosted: Sun 03 Mar 2013, 17:43    Post_subject:  

scsijon wrote:
@thunor, there is a mage2 puppy in next to final beta out, I'm awaiting a few retro fixes by the mageia people before bringing the final beta out, if it's any help.

There's a Puppy ISO and DEVX which includes gtk+ 3 and all dependencies ready to go? If so can I have a link please.

I haven't had any luck yet installing a gtk+ 3 distro because my CD-RW was too small and I got a boot loader up from my SD card + reader but it failed after that so I think it has to be a flash drive. I'm not familiar with installing from SD/flash so I don't know.

I shall have to create another gtkdialog branch because I'll have to purge the code of all the deprecated stuff and widgets (combobox, comboboxentry, list, table) so once I'm up and running it could take some time to complete.

Regards,
Thunor
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7802
Location: qld

PostPosted: Sun 03 Mar 2013, 20:09    Post_subject:  

Thunor,

I don't know what dev box you are using but Slacko-5.5 is ready very soon. It's based on slackware-14.0 bins like 5.4 but with many bugs fixed. Min system requirements are a P3 900 with 512 RAM, unless you want to do a full install then that can be cut down a bit.

I have just constructed an sfs of audacious which includes gtk+3-3.4.4-i486-1.txz and all development headers and libraries plus .pc files, docs and demos.

http://www.smokey01.com/01micko/sfs_xz/audacious-3.3.1-i486.sfs 12M

checksum <-- 1b5c7ad0fa837a7bea1071a2610fd012 audacious-3.3.1-i486.sfs

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Mon 04 Mar 2013, 04:09    Post_subject:  

.
Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 48 of 55 Posts_count   Goto page: Previous 1, 2, 3, ..., 46, 47, 48, 49, 50, ..., 53, 54, 55 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1030s ][ Queries: 13 (0.0172s) ][ GZIP on ]