Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Jul 2014, 05:04
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.4.12 with 3.4.2 kernel.
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 88 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 86, 87, 88, 89 Next
Author Message
anikin

Joined: 10 May 2012
Posts: 450

PostPosted: Wed 21 Nov 2012, 12:45    Post subject:  

edoc wrote:
Did you do this:

a) Because you could

b) To save resources

c) You prefer the look

d) All of the above

e) None of the above

Perhaps b) and c). Simplicity, that's what I'm striving for. Don't know exactly, but I believe the memory will be taxed less without icons in the menu. The already fast and snappy OS feels even more snappier. I forgot to pre-check the size of the usr/share/applications folder (that's where the cleansing occured), but at present it's 885 K. I went through every .desktop file in that folder deleting an icon reference - more than two hundred files in total! Some had empty lines, some localization entries - now they are smaller and cleaner. As a matter of fact this exercise is a first step towards remastering this beautiful pup. Some new menu entries will be added, some will have to go.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5680
Location: Kentucky

PostPosted: Mon 26 Nov 2012, 12:28    Post subject:  

Still running 5.X.3.4.12 on this old dual-core......... still working fine.

# report-video
Report Video 1.4 - Mon 26 Nov 2012 on Dpup Exprimo 5.X.3.4.12 - Linux 3.4.2-dpup i686

Chip description:
d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
oem: NVIDIA
product: MCP61 - mcp61-86 Chip Rev

X Server: Xorg Driver used: nv

X.Org version: 1.7.7
dimensions: 1440x900 pixels (402x251 millimeters)
depth of root window: 24 planes

...the above also recorded in /tmp/root/ as report-video,
and archived with xorg.conf and Xorg.0.log as report-video-full.gz
#
-Computer-
Processor : 2x AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
Memory : 3374MB (200MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Mon 26 Nov 2012 10:26:12 AM CST
-Display-
Resolution : 1440x900 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA NVidia
capture24152.png
 Description   
 Filesize   233.6 KB
 Viewed   1514 Time(s)

capture24152.png

Back to top
View user's profile Send private message 
anikin

Joined: 10 May 2012
Posts: 450

PostPosted: Tue 11 Dec 2012, 02:33    Post subject:  

Hi pemasu,
My xorg.log has this error message, and here's how it is explained in debian wiki:
http://wiki.debian.org/XF86DRTShoot
Quote:
If the X log contains something like this:

(EE) AIGLX error: dlopen of /usr/lib/dri/i915_dri.so failed (/usr/lib/dri/i915_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering
(II) AIGLX: Screen 0 is not DRI capable
(EE) AIGLX error: dlopen of /usr/lib/dri/swrast_dri.so failed (/usr/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
(EE) GLX: could not load software renderer
(II) GLX: no usable GL providers found for screen 0

make sure that the package libgl1-mesa-dri is installed.

"Intel 945GME Express Integrated Graphics Controller" - Any thoughts?
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 11 Dec 2012, 17:13    Post subject:  

Anikin. dri drivers you need to install yourself, as your message also suggests. There is xorg_high sfs and pet in the repository. The content of them is same as the suggested libgl1-mesa-dri deb package.

In fact you need only i915_dri.so driver from one of those packages.

I dont know what has eaten swrast_dri.so file in your puplet. It is included in the distro.
Back to top
View user's profile Send private message 
anikin

Joined: 10 May 2012
Posts: 450

PostPosted: Tue 11 Dec 2012, 22:37    Post subject:  

Thank you for your time, pemasu.
I was unaware that xorg-high is actually libgl1-mesa-dri.
AIGLX has been rectified, and this is what the log shows:
Code:
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_SGI_make_current_read
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
(II) AIGLX: Loaded and initialized /usr/lib/dri/i915_dri.so
(II) GLX: Initialized DRI2 GL provider for screen 0
(II) intel(0): Setting screen physical size to 270 x 158

A quick question: now, that i915_dri.so driver is in place, will it be safe to completely remove swrast_dri.so from the system?
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Tue 11 Dec 2012, 23:01    Post subject:
Subject description: apps refuse to go full screen
 

EDIT:

If I go to Laptop Tools and turn off LVDS1, the laptop display, then VGA1, the external display will open full screen.

Getting it to work reliably relies upon a clean start, nothing opened until the settings have been made.

It is odd that the drivers/app cannot discern between internal and external monitor settings but at least I now do not have to resize every single window all day long.

--------------------------------------------------------------------------------------------------------------------------------

Apps refuse to go full screen - from my Netbook to my just-acquired ViewSonic monitor - which means that I have to manually expand every window.

I have tried all of the resolution options offered - but none address the need effectively.

Samsung NB30 Netbook running Puppy Linux dpup Exprimo 5x15.
Chipset: Intel NM10
Graphics: Intel GMA3150 (integrated)
Maximum NB30 resolution:1024 x 600 @ 60

Any thoughts, please?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602

Last edited by edoc on Wed 26 Dec 2012, 19:45; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Fri 21 Dec 2012, 04:17    Post subject:  

I couldn't get jre-1.6.31-dpup.sfs to work for java files. The downloaded binaries work fine (presently version 1.7.0.10). I tested with "java -jar MyFile.jar"
Back to top
View user's profile Send private message 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Sun 23 Dec 2012, 02:39    Post subject:  

Running java apps from the jre binaries doesn't work very well in Exprimo. There seems to be some conflict that prevents keyboard entries. I tried several apps in addition to trying various focusing commands on some of my own, but couldn't get them to work. I ran lucid (three headed dog), and everything works. Switching to vesa didn't help.

Edit: The conflict is with JWM
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5680
Location: Kentucky

PostPosted: Wed 26 Dec 2012, 01:21    Post subject:  

Finally got around to upgrading this install up to 5.X.3.4.12....... still working good.
capture30699.png
 Description   
 Filesize   280.73 KB
 Viewed   1031 Time(s)

capture30699.png

Back to top
View user's profile Send private message 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Sun 30 Dec 2012, 15:56    Post subject:  

Working jre: (jre-1.6.31-dpup.sfs doesn't work on my computer). As previously noted, there's also a conflict with JWM when running desktop apps.

http://www.jpeters.net/apps/jre1.7.0_10_001.sfs.tar.gz

089198e11de93a189de0cb29bda666c2 jre1.7.0_10_001.sfs.tar.gz
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Mon 31 Dec 2012, 15:06    Post subject:  

I am having trouble getting a DVD to play on an old Gateway laptop with a Toshiba SD-R6112 DVD drive.

It handles a Puppy CD OK but mplayer crashes as soon as it tries to open the video file.

Is there any reason to believe that this pre-5x16 Exprimo might do better?

Or that gxine from Debian Main might?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Fri 11 Jan 2013, 16:35    Post subject:  

Any news re. the planned release of 5x16?

I have an external monitor on my 5x15 netbook.

I have observed that the Turbo setting in Laptop Tool is non-persistent boot to boot, is that expected or has it been resolved in a newer version of that app, please?

Also, I am just now testing qwatermark-0.2.1.pet It does not appear to be working correctly in 5x15.

When start from Menu-Utility or Console it opens but will not show images in the Source selection area as the window to specify the file type is greyed-out.

When I open from Console and look back there after trying to use qwatermark I observe this in Console:

Quote:
# qwatermark
QPainter::begin: Paint device returned engine == 0, type: 3


Thanks!

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 11 Jan 2013, 16:47    Post subject:  

Edoc. It is just question of my time for puplets. I have developed now Upup Precise for several reasons. One of them is that Barry Kauler has used a lot time and dedication for Precise Puppy and it behaves nicely enough for me. Also because of newer libs, gcc and other system-core files, there is not obstacles with compiling as dpup has started to show. Some newer application sources just does not compile with squeeze anymore.

But I have not abandoned dpup exprimo. I just atm dont know when I feel like starting the update cycle. I will be stuck several weeks for dpup then.

There is several puplets to update and only one me.

Also....I got news now about my job. I will have to do 2 persons workload and there is no quarantee when that will stop. This phase of my life starts next monday. The sugar in the cake was that my bosses sametime got breakthrough contract and the buyers explicitly wanted me to start to do the job they have in mind. They buy my time with fixed prize. So....I will be really stuck with my work.
At least I cant say that I am not wanted....lol.

About turbo.
Just edit /root/Startup/0acpid for you liking. Replace performance.sh word with turbo.sh and you have turbo speed ie full cpu performance when you are on ac/dc and with battery.

About that qwatermark pet. I dont recall it. I think it is not my compile. I dimly remember that Dingo compiled that named static qt app some time ago. If is his static qt app you are referring, then there is not much I can do. You cant much hack with statically compiled apps. They work or not.
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Sat 12 Jan 2013, 14:49    Post subject:  

Why continue with Exprimo?

What does it offer that Precise does not?

OK re. qwatermark, are you aware of any other watermark apps, perhaps an add-on for mtPaint?

Thanks re. the performance/turbo tweak method.

Congratulations on having earned that level of respect in your industry - it is not easy to come by - and is rarely recognized in such a direct way.

Thanks for all that you give to the Puppy community!

I break stuff, stretch the limits of applications, and promote Puppy everywhere I go. Rolling Eyes

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 3215
Location: Ontario

PostPosted: Mon 14 Jan 2013, 20:15    Post subject: gtkdialog 0.8.4  

gtkdialog 0.8.4

Here is newest gtkdialog. I noticed while putting together the package that
Exprimo does things differently thatn Barry Kauler. Barry makes
gtkdialog4 the application and gtkdialog the link, whereas
Exprimo does it in reverse.

gtkdialog-exprimo-0.8.4.pet
Description 
pet

 Download 
Filename  gtkdialog-exprimo-0.8.4.pet 
Filesize  104 KB 
Downloaded  269 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 88 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 86, 87, 88, 89 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1151s ][ Queries: 13 (0.0264s) ][ GZIP on ]