Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 01 Aug 2014, 04:04
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Printing from Slacko 5.4 to an Epson Artisan 725 over WIFI
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
SilverBrun

Joined: 17 Jan 2013
Posts: 12

PostPosted: Thu 17 Jan 2013, 16:51    Post subject:  Printing from Slacko 5.4 to an Epson Artisan 725 over WIFI  

I'm a newbie and need to add a printer to Puppy Linux. I'm using it from a USB stick and would like to print to an existing WIFI printer that works fine from the same laptop using Windows XP. Can someone help me set up this printer in Slacko 5.4?
Back to top
View user's profile Send private message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 785
Location: USA

PostPosted: Thu 17 Jan 2013, 16:57    Post subject:  

try plugging the printer in to your computer first, if it's recognized then normally it will work over wifi. If not, you either need a driver for it, or it simply isn't compatible. I remember though seeing a webpage (a long time ago) that has info about printer compatibility on linux. Anywise I have no clue either about how you configure a wifi printer. Some printers though need a windows computer that has the configuration tool to allow your machine to print from it.

Does that help at all?

_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 500GB WD HDD, Slackware 14.1
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8935
Location: Stratford, Ontario

PostPosted: Thu 17 Jan 2013, 17:36    Post subject:  

Have you read here yet? This is your source for information about Puppy printing. It contains a link to an Epson driver for your Artisan 725.

Once you have installed the driver, you must run the CUPS setup wizard. From your desktop, click on Setup > Hardware > Printer > Install.

In the CUPS wizard, select the Administration tab and Find New Printers. You may need to click it several times before your wifi printer is detected.

Follow the steps to install it. Please report back if you need more help.
Back to top
View user's profile Send private message 
SilverBrun

Joined: 17 Jan 2013
Posts: 12

PostPosted: Thu 17 Jan 2013, 17:53    Post subject:  

Yes plugging in the printer works and it prints fine, BUT I need to use the WIFI option because this printer is in another room. Does anybody know how to use it over WIFI?
Back to top
View user's profile Send private message 
SilverBrun

Joined: 17 Jan 2013
Posts: 12

PostPosted: Thu 17 Jan 2013, 18:02    Post subject:  

OK, CUPs won't find it and I don't know if the firewall is on or not. How/where do I find the firewall?
Back to top
View user's profile Send private message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 785
Location: USA

PostPosted: Thu 17 Jan 2013, 18:30    Post subject:  

well calm down first. Okay so we know puppy will work with the printer at all. On some printers though you may not be able to do everything possible with your printer on linux. (Ex: scanning, faxing,etc. sometimes don't work on linux with some printers). Now evalute whether you need windows to allow puppy to use your printer wireless OR if there is a tool available for linux to do the same task. Google is your friend.

EDIT: As a side note, Most printers I've seen can only be configured on Windows (well at least to allow wireless connections). Also do printers have firewalls? Good Luck!

EDIT2: Did the searching for you, and found that the website has no configuration tool you can use.

_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 500GB WD HDD, Slackware 14.1
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8935
Location: Stratford, Ontario

PostPosted: Thu 17 Jan 2013, 18:41    Post subject:  

SilverBrun wrote:
OK, CUPs won't find it and I don't know if the firewall is on or not. How/where do I find the firewall?

In CUPS, run Add Printer. One of the devices is AppSocket/HPJetdirect. Select this.

On the next screen, enter the device URI as
Code:
socket://aaa.bbb.ccc.ddd

using the IP address of the printer. Continue the setup procedure.
Back to top
View user's profile Send private message 
SilverBrun

Joined: 17 Jan 2013
Posts: 12

PostPosted: Thu 17 Jan 2013, 19:57    Post subject:  

Thanks. I've done all that and the printer shows up in "Printers" and when I send something to print it goes to that printer but doesn't print on the printer. It just sits there. Puppy is using the same WIFI to get to the Internet that the printer does but doesn't seem to recognize that the printer is to be connected via WIFI. How do I add that part?

And thanks for everything. It works as far as we've gone.
Back to top
View user's profile Send private message 
SilverBrun

Joined: 17 Jan 2013
Posts: 12

PostPosted: Thu 17 Jan 2013, 20:00    Post subject:  

Is there someplace to enter the printers pin code?
That's what I did in windows.
Back to top
View user's profile Send private message 
SilverBrun

Joined: 17 Jan 2013
Posts: 12

PostPosted: Thu 17 Jan 2013, 20:06    Post subject:  

I didn't add the printers IP address but I have found it now. Where do I add it?
Back to top
View user's profile Send private message 
SilverBrun

Joined: 17 Jan 2013
Posts: 12

PostPosted: Thu 17 Jan 2013, 20:31    Post subject:  

Sorry to be such a pain but I deleted the printer and put the IP address in where you said (numbers instead of letters) (I know I'm brain dead!) and it now works fine!!!!

Thanks a million for your help.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8935
Location: Stratford, Ontario

PostPosted: Thu 17 Jan 2013, 20:35    Post subject:  

Glad to help.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1117s ][ Queries: 12 (0.0576s) ][ GZIP on ]