Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 13:41
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
pMusic 4.2.8
Post new topic   Reply to topic View previous topic :: View next topic
Page 104 of 120 [1793 Posts]   Goto page: Previous 1, 2, 3, ..., 102, 103, 104, 105, 106, ..., 118, 119, 120 Next
Author Message
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10692
Location: Arizona USA

PostPosted: Thu 17 Jan 2013, 09:52    Post subject:  

Pmusic plays files with spaces in their names for me. What format are the songs that won't play for you? (What are the filename extensions?) Are they CAPITALIZED?
Back to top
View user's profile Send private message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 709
Location: USA

PostPosted: Thu 17 Jan 2013, 10:37    Post subject:  

they're .mp3 format. I am running Slacko 5.4 (firefox-4g) with this version of pmusic.

EDIT: I do have the listed requirements. Like I said the music works on GNOME-Mplayer, but not in pmusic.

EDIT2: No they're not CAPITALIZED

_________________
Desktop: Intel 945PSN Board, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 160GB WD HDD, Windows 7 and Slackware64 14.1
Netbook: Acer AOD257 with 2GB upgrade, NoOS
Back to top
View user's profile Send private message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 386
Location: Philadelphia, PA

PostPosted: Thu 17 Jan 2013, 11:52    Post subject:
Subject description: a filename with spaces
 

bark_bark_bark wrote:
they're .mp3 format. I am running Slacko 5.4 (firefox-4g) with this version of pmusic.

EDIT: I do have the listed requirements. Like I said the music works on GNOME-Mplayer, but not in pmusic.

When I do a ls -l in rxvt teminal, the tab key makes the command line something like
Quote:
ls -l 07\ -\ Jason\ Vieaux\ -\ Sor\ -\ 07\ -\ Op.\ 44\ -\ Andante.mp3


Maybe the software does something with the spaces so that they can be handled by pmusic etc

When I click on it in rox filer, pmusic plays it.

Lucid Puppy 5.2.8-005
Back to top
View user's profile Send private message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 709
Location: USA

PostPosted: Thu 17 Jan 2013, 12:46    Post subject:  

same error when clicking on it in rox.
_________________
Desktop: Intel 945PSN Board, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 160GB WD HDD, Windows 7 and Slackware64 14.1
Netbook: Acer AOD257 with 2GB upgrade, NoOS
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Thu 17 Jan 2013, 17:05    Post subject:  

bark_bark_bark
Will you please give us the terminal output when executing:
Code:
pmusic --debug "/path/Name of file.mp3"



Thank you
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 709
Location: USA

PostPosted: Thu 17 Jan 2013, 17:11    Post subject:  

will the debug option modify the .mp3 file?

here is what I got from typing the command and hitting enter:

Code:
# pmusic --debug "/root/Music/Smosh/Ultimate Assassin's Creed 3 Song [Explicit]/01 - Ultimate Assassin's Creed 3 Song [Explicit].mp3"
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]
find: `/root/.pmusic/pmu/': No such file or directory
/root/.pmusic/tmp/tmp_exec: line 4:  {print: command not found
/root/.pmusic/tmp/tmp_exec: line 8: __: command not found
/root/.pmusic/tmp/tmp_exec: line 6: __: command not found
#

_________________
Desktop: Intel 945PSN Board, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 160GB WD HDD, Windows 7 and Slackware64 14.1
Netbook: Acer AOD257 with 2GB upgrade, NoOS
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Thu 17 Jan 2013, 19:00    Post subject:  

bark_bark_bark
Ok, got it - Filename containing ] or [ fails.


Thank you
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 709
Location: USA

PostPosted: Thu 17 Jan 2013, 19:14    Post subject:  

is there a work around?
_________________
Desktop: Intel 945PSN Board, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 160GB WD HDD, Windows 7 and Slackware64 14.1
Netbook: Acer AOD257 with 2GB upgrade, NoOS
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Thu 17 Jan 2013, 19:22    Post subject: Re: play midi files  

charlie6

Playing midi now works.
But to officially support midi, it has to be fully included to the pMusic workflow. That means (in addition to actually play the file)
- update stream status (moving slider)
- export with convert options
- detect track info
- burn file to audio cd
- supported by the native playlist format (*.pmu)
- Error checking
- ...

Let's see what future brings..... Don't expect too much.
Youtube is also unofficially supported if movgrab is installed. You can add a URL like http://www.youtube.com/watch?v=lWA2pjMjpBs and pMusic connects and starts playing.


_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Sat 19 Jan 2013, 08:42    Post subject:  

Version 3.1.1
See main post

Changelog
- Bugfix: Title in Now Playing mode (thanks to Billtoo)
- Bugfix: Filename can't contain ] (thanks to bark_bark_bark)


Note to Charlie: This release will play midi files if timidity is present

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
vicmz

Joined: 15 Jan 2012
Posts: 1016

PostPosted: Sat 19 Jan 2013, 10:37    Post subject:  

Hello Zigbert Very Happy
I couldn't find any gtkdialog 0.8.3 pets in the forum or elsewhere, how can I get it for Pmusic to run in Precise?

_________________
OpenboxPlus|OB-Puppy|Puppy en español
Back to top
View user's profile Send private message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 386
Location: Philadelphia, PA

PostPosted: Sat 19 Jan 2013, 10:50    Post subject: gtkdialog  

vicmz wrote:
Hello Zigbert Very Happy
I couldn't find any gtkdialog 0.8.3 pets in the forum or elsewhere, how can I get it for Pmusic to run in Precise?

Maybe http://www.murga-linux.com/puppy/viewtopic.php?t=70855&start=2265
Back to top
View user's profile Send private message 
charlie6

Joined: 30 Jun 2008
Posts: 940
Location: South of Belgium

PostPosted: Sat 19 Jan 2013, 11:22    Post subject:  

Hi Sigmund ...et encore merci !!! Smile
zigbert wrote:
Version 3.1.1
...Note to Charlie: This release will play midi files if timidity is present


btw: i have Timidity running ...but can't get pMusic playing a midi file ---> are there specific settings to do to get pMusic playing midi files (for instance set Timidity as external program to start, or as plugin, or something else) ??
thanks for any answer !


This could be usefull for musicians who have to handle midi files among other mp3 ...etc.. files
charlie
Back to top
View user's profile Send private message 
vicmz

Joined: 15 Jan 2012
Posts: 1016

PostPosted: Sun 20 Jan 2013, 00:08    Post subject: Re: gtkdialog  

sheldonisaac wrote:
vicmz wrote:
Hello Zigbert Very Happy
I couldn't find any gtkdialog 0.8.3 pets in the forum or elsewhere, how can I get it for Pmusic to run in Precise?

Maybe http://www.murga-linux.com/puppy/viewtopic.php?t=70855&start=2265

Thank you, it works Very Happy

_________________
OpenboxPlus|OB-Puppy|Puppy en español
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Sun 20 Jan 2013, 06:30    Post subject:  

charlie6 wrote:
btw: i have Timidity running ...but can't get pMusic playing a midi file ---> are there specific settings to do to get pMusic playing midi files (for instance set Timidity as external program to start, or as plugin, or something else) ??
thanks for any answer !
Interesting Smile
The playing command is stored in /root/.pmusic/tmp/exec. Mine looks like this:
Code:
#!/bin/sh
LANG=C timidity -Ow -o - '/root/pMusic midi test file.mid' | ffmpeg -i pipe:0 -f au - 2>> /root/.pmusic/tmp/ffmpeg_output | aplay  2> /root/.pmusic/tmp/aplay_error
If you instead point errors to stdout and execute command in terminal you will hopefully get some errors. Something like this:
Code:
LANG=C timidity -Ow -o - '/path/file.mid' | ffmpeg -i pipe:0 -f au - | aplay



Thank you
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 104 of 120 [1793 Posts]   Goto page: Previous 1, 2, 3, ..., 102, 103, 104, 105, 106, ..., 118, 119, 120 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0956s ][ Queries: 13 (0.0293s) ][ GZIP on ]