Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 31 Jul 2014, 19:57
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
How to set up a Wacom Tablet
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 21 of 24 [349 Posts]   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23, 24 Next
Author Message
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Wed 16 Jan 2013, 18:21    Post subject:  

I edited xorg.conf either in Upup 5.4.x.7 and Upup Kernel 3.7.2.

Same configuration, no load of xf86 driver, I follow you suggestion.

But at the first (5.4.x.7) I inserted new driver and works OK.

The second (3.7.2) has original driver and NOT works.
Back to top
View user's profile Send private message 
charlie6

Joined: 30 Jun 2008
Posts: 995
Location: South of Belgium

PostPosted: Wed 16 Jan 2013, 23:25    Post subject:  

Fabio,
on 3.7.2 session, would you mind again posting what following command line returns:
Code:
# lsmod | grep wacom

if it returns "wacom"
then also
Code:
# xsetwacom --list
Back to top
View user's profile Send private message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Thu 17 Jan 2013, 05:20    Post subject:  

charlie6,

Those are my actions (step by step):

--------In Upup 3.7.2:--------------

I Modify Xorg.conf according with your suggest to add wacom sections (pen, stylus, touch, cursor, pad)

Restart X server.

I open a rxvt terminal and type:

#depmod

Cursor system waits 2-3 seconds and returns (flashing cursor).

#modprobe wacom

Cursor system returns immediatly

#xsetwacom --list

Cursor system return immediatly without message and no function of pen or touchscreen

-----------In Upup 54x7:---------------

I Modify Xorg.conf according with your suggest to add wacom sections (pen, stylus, touch, cursor, pad)

At first configuration I copy new driver wacom.ko in directory /lib/modules/3.2.29/kernel/input/tablet/

Restart X server (best to reboot).

Next I open a rxvt terminal and type:

#depmod

Cursor system waits 2-3 seconds and return flashing cursor.

#modprobe wacom

Cursor system returns immediatly

#xsetwacom --list

System returns immediatly with message:

stylus id: 9 type: STYLUS
eraser id: 10 type: ERASER
cursor id: 11 type: CURSOR
pad id: 12 type: PAD
touch id: 13 type: TOUCH

Difference from two systems is that in 5,4,X.7 I use new driver wacom.

Cheers,

Fabio
Back to top
View user's profile Send private message 
charlie6

Joined: 30 Jun 2008
Posts: 995
Location: South of Belgium

PostPosted: Thu 17 Jan 2013, 05:37    Post subject:  

Quote:
--------In Upup 3.7.2:--------------
I Modify Xorg.conf according with your suggest to add wacom sections (pen, stylus, touch, cursor, pad)

I open a rxvt terminal and type:
#depmod
Cursor system waits 2-3 seconds and returns (flashing cursor).
#modprobe wacom
Cursor system returns immediatly

1. here, if there were a problem with wacom.ko, you would have a error message returned.

2. Does «#lsmod | grep wacom» return «wacom»?

3.
Quote:
#xsetwacom --list
Cursor system return immediatly without message and no function of pen or touchscreen

here, as wacom_drv.so is present, you would have the list of devices returned. If not, the wacom tablet can't be used.

4.Also the syntax of xorg.conf must be correct. Would you mind post a copy of your xorg.conf (rename it xorg.conf.tar.gz and attach it to your post)

5. question: did you restart X after edition of xorg.conf? X needs to be restarted to activate the new xorg.conf.
Back to top
View user's profile Send private message 
charlie6

Joined: 30 Jun 2008
Posts: 995
Location: South of Belgium

PostPosted: Thu 17 Jan 2013, 06:18    Post subject: Fujitsu T902  

Fabio,
here a link to read that might interest you
http://old.nabble.com/Fujitsu-Lifebook-T902-convertible-tablet-is-not-recognized-td34620583.html
Back to top
View user's profile Send private message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Thu 17 Jan 2013, 07:13    Post subject:  Re: Fujitsu T902  

charlie6 wrote:
Fabio,
here a link to read that might interest you
http://old.nabble.com/Fujitsu-Lifebook-T902-convertible-tablet-is-not-recognized-td34620583.html


I've already read that thread, I had found driver wacom and xf86 driver up.to date but wacom won't compiles in Upup 3.7.2. (Makefile bug? Upup bug?)

For now I use pen with Upup 5.4.x.7 and feel good, cannot use fingers because they make disaster in my desktop Crying or Very sad

Thanks for all

Fabio
Back to top
View user's profile Send private message 
charlie6

Joined: 30 Jun 2008
Posts: 995
Location: South of Belgium

PostPosted: Thu 17 Jan 2013, 08:44    Post subject:  

Fabio,
Quote:
but wacom won't compiles in Upup 3.7.2. (Makefile bug? Upup bug?)

looking inside input-wacom-0.16.0.tar.bz2:
the directory named 3.7 has only one file called Makefile; there is not any wacom.h nor other C code file; whereas other 2.6.X directories are populated with such files ...
So not surprising that you got errors while compiling for ... there was nothing to compile in 3.7 directory ... !
hope this helps
charlie
Back to top
View user's profile Send private message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Thu 17 Jan 2013, 11:36    Post subject:  

HIP-HIP-HURRA'!!!

I've found a solution.

I've copied in directory 3.7 files come from directory 2.6.38.

But compilation aborted again.

I've looked at compilation messages and after a few attempts I've correct bug (n Kernel 3.7 syntax of some statements is slightly different).

So I repackaged files and upload packet to the forum to give you ability to test this.

To compile this is only necessary give command:

# ./configure

And compilation starts after reconfiguration.

Compilation gives only a warning.

Copy wacom.ko (or wacom_w8001.ko if you have a serial device) in the proper directory, modify xorg.conf. , give depmod, modprobe wacom, restart X system, reboot system and pen finally works!!!

Fingertouch sucks for now but so finally I am happy and can test whole capabilities of new kernel.

Give a try and tell me somewhat.

Fabio
CORRECT_input_wacom-0.16.0.tar.gz
Description  Version suitable to compile in 3.7.2 kernel
gz

 Download 
Filename  CORRECT_input_wacom-0.16.0.tar.gz 
Filesize  185.5 KB 
Downloaded  271 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 17 Jan 2013, 17:41    Post subject:  

Relating to the above post. Compiles ok. If this one is better version and it works with others as well, I will update my 3.7.2 kernel pet with this input wacom version.
Back to top
View user's profile Send private message 
charlie6

Joined: 30 Jun 2008
Posts: 995
Location: South of Belgium

PostPosted: Fri 18 Jan 2013, 04:17    Post subject:  

Hi pemasu,
Quote:
... Compiles ok. If this one is better version and it works...

version 0.16.0 is the latest version for the wacom kernel driver ... so it would be nice to have it in the distro ... (i do not know how to check the current version id .?)
thanks in advance
charlie
Back to top
View user's profile Send private message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Sat 19 Jan 2013, 04:13    Post subject:  

pemasu wrote:
Relating to the above post. Compiles ok. If this one is better version and it works with others as well, I will update my 3.7.2 kernel pet with this input wacom version.


Thank you Pemasu.
Back to top
View user's profile Send private message 
charlie6

Joined: 30 Jun 2008
Posts: 995
Location: South of Belgium

PostPosted: Sat 19 Jan 2013, 10:04    Post subject: Xorg wacom_drv version check  

Hi again,
charlie6 wrote:
... (i do not know how to check the current version id .?)

i got it ... Very Happy
1. this only for dPup-Exprimo-3.6.2 , uPup-54X7 (and earlier), uPup-3.7.2 (...and maybe other recent distros i am not yet aware of ...).
2. /etc/X11/xorg.conf MUST be edited by adding the wacom options (very classic --> see above in this thread); and aftrwds restart X;
3. read through /var/log/Xorg.0.log ---> look for
Quote:
...
(II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
(II) Module wacom: vendor="X.Org Foundation"
compiled for 1.7.7, module version = 0.17.0
...

the third line gives the X wacom driver version (here = 0.17.0)
4. currently:
dPup-Exprimo-3.6.2 has X wacom driver 0.10.5 in it;
uPup-3.7.2 has X wacom driver 0.14.0 in it;
latest X wacom driver is 0.19.0 as today;
(forget 0.18.0 which was buggy ... told linuxwacomproject repo).
hope this helps
charlie
Back to top
View user's profile Send private message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Sat 19 Jan 2013, 16:38    Post subject:  

Charlie6,

I've created a multidriver .PET for Upup 3.2.29 and Upup 3.7.2 but I can't upload it in the forum: (they are 2 files of 3585 Kbytes). What can I do to upload it in forum? Link "Allowed Extensions and Sizes" tell 0 bytes.....
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3221
Location: Ontario

PostPosted: Sat 19 Jan 2013, 17:23    Post subject:  

Try posting at

http://www.mydrive.ch/login

or

http://www.datafilehost.com

__________________________________
Back to top
View user's profile Send private message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Sat 19 Jan 2013, 19:01    Post subject:  

Thank You Don570.

Please read this thread I've opened:

http://murga-linux.com/puppy/viewtopic.php?p=679060#679060
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 21 of 24 [349 Posts]   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23, 24 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0950s ][ Queries: 13 (0.0111s) ][ GZIP on ]