Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 00:30
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
mplayer issues (ABANDONED) though ..
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
Mercedes350se

Joined: 16 Apr 2008
Posts: 635

PostPosted: Wed 23 Jan 2013, 02:22    Post_subject:  mplayer issues (ABANDONED) though ..
Sub_title: See mikeb's post for one that works in many versions
 

I downloaded/installed MPlayer-1.0rc2.pet from http://dotpups.de/puppy3/dotpups/Multimedia/
and all seemed to be well.

To complete the picture I am trying to get gsopcast running on a full HDD install of 3.01 - it didn't seem to want to work with xine!

The issues are:

1. If I click on mplayer in the menu two boxes appear, nothing in either and the machine freezes requiring a Ctrl-Alt-Backspace to get out.

2. If I start gsopcast and select a stream it plays with issues - that is the reason for 1# to try and configure mplayer.

Any ideas/suggestions?

Edited_times_total
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3972
Location: World_Hub

PostPosted: Wed 23 Jan 2013, 13:26    Post_subject:  

Mercedes- are you running Xvesa or Xorg?

Run this line in a shell: ldd /usr/bin/mplayer

Any not founds? Total *B* on this old, outdated dog.

Leave me an example site or show in particular that doesn't quite play..

You have the space for say, VLC?
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 635

PostPosted: Wed 23 Jan 2013, 20:41    Post_subject:  

I am running Xorg.

2 points regarding your ldd /usr/bin/mplayer command:

1. mplayer is installed in /usr/local/bin

2. the result of running ldd /usr/local/bin/mplayer showed nothing out of the ordinary i.e. no not founds.

Clicking on the mplayer icon in /usr/local/bin/mplayer does not seem to do anything!

If all else fails peruse the readme which says, in part, "To launch MPlayer with gui, run "gmplayer"."

Run gmplayer and I get the following:

# gmplayer
MPlayer 1.0rc2-3.4.4 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(TM) XP 1700+ (Family: 6, Model: 6, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Hmm!

What does "mplayer: could not connect to socket" mean?

However "mplayer: No such file or directory" is more interesting because, as stated above, there is an mplayer icon in /usr/local/bin/ albeit just a "gear wheel" if that gives a clue.

I am a gsopcast noob so at the moment I am only playing with the information that comes up when gsopcast starts - I have just tried the same place Test Channel Group>star and for the short duration it was playing smoothly.

I have previously tried to install VLC without success in Feb, 2010 and again in Mar, 2011. There are threads on this Forum relating to both these attempts.

Edit: After posting this I was closing the open windows and came across a pop up box that stated something like Mplayer crashed - this should not happen - it could be a problem with ....
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3972
Location: World_Hub

PostPosted: Thu 24 Jan 2013, 00:25    Post_subject:  

I recall you're working with older hw.. I'm feel'n a vibe here- it's 3.01 or bust, right? Any other players?
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 635

PostPosted: Thu 24 Jan 2013, 19:06    Post_subject:  

Hardware is as follows:

AMD XP1700+ i.e about 1466MHz
1 GB RAM
MB is Asus A7V333
HDD about 320GB

I built it originally about 10 years ago with different MB, HDD and optical drive. It still does everything I want ...

Yes 3.01 is definitely the Puppy of choice! I also have frugal installs of 4.1.2 and macpup 5.2.8 but they are very rarely used.

Back to the mplayer problem I tried the version in macpup a couple of days ago and it freezes the machine - I cannot remember whether the normal escape sequence worked or whether I had to reboot.

Thank you for the link. It makes very interesting reading.
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3972
Location: World_Hub

PostPosted: Thu 24 Jan 2013, 20:24    Post_subject:  

Tell me, outside of pets, what do you do use for installing software? tgz2pet? pkgtools?
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 635

PostPosted: Fri 25 Jan 2013, 04:45    Post_subject:  

The only other software I have installed were .tgz.

My use for the machine is basic with occasional bursts to try something ...
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3972
Location: World_Hub

PostPosted: Fri 25 Jan 2013, 09:29    Post_subject:  

Mercedes- I have VLC Smile running on my 3.01 frugal. Where'd you get the Sopcast pkg from?

Your video card vendor too if you would.. Intel? I'm guessing you've got OpenGL installed?

==
Quote:
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

*Solution >> nolirc=yes
==

I'm have'n my doubts. 3.01's antiquated. It may be time to step outta your comfort zone..

Abs, AntiX, Arch, #!, TC.. all excellent, current offerings. Bud, kiss those old libs adios..
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 635

PostPosted: Sun 27 Jan 2013, 00:02    Post_subject:  

Interesting that you have vlc running under 3.01 - where did you get it?

I am not sure where gsopcast came from but it would be something like http://www.murga-linux.com/puppy/viewtopic.php?p=327777

Video card is Radeon 7000 64M TVO.

OpenGL - if it does not come in 3.01 then no - I have not done a specific install.

I have tried, admittedly old versions of,

Zenwalk, nice but at the time did not have dial up support - not an issue now I am on broadband

"PCLinuxOS, no thanks

Zorin OS6, no thanks

Linux Mint, early versin was OKish

Ubuntu 6 something, OKish

#!, definitely the best of all the trial OSs. I cannot remember why I eventually deleted it.

There would have been others - I am a magazine cover disk junky, sorry was!

Semme wrote:
I'm have'n my doubts. 3.01's antiquated. It may be time to step outta your comfort zone..

I have VLC Smile running on my 3.01 frugal.


Hmm!

That link was interesting reading.
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3972
Location: World_Hub

PostPosted: Mon 28 Jan 2013, 05:29    Post_subject:  

PC, Zorin, Mint, Ubuntu.. all TOO heavy. Zenwalk's OK, but, for me- there was an odd lag during scrolls. I'd chalk up to graphics, but hey.. who knows? #! I liked, as I did AntiX (both w/access to Ubuntu repos) and Vector. Abs I like and still have installed. It lacks dependency checking and requires more hands-on than the others, but generally pretty solid. As a hd install, she's got more than enough speed.

==

Let's go back to gxine for the moment. Does: ldd /path/to/xine check out?

If yes, I'd go ahead and install xorg-OpenGL. it's in your pacman.

Reboot and see if that doesn't improve playback..

==

Ah, MPlayer *does* work! Rt-clk a video and hit "open with" >> gmplayer.. does it play?

It's in /usr/local/bin. You'll have to drag it into the open with, customize dialog.

In the meantime I'll consult the readme.. see what I can come up with..

==

And leave me a sop url I can test..
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 635

PostPosted: Tue 29 Jan 2013, 20:40    Post_subject:  

ldd /path to /xine/ gives no errors.

I am not having any success at all this morning. The streams seem to be OK but mplayer is not opening.

I have a short fuse with software that does not work so I am giving up!

Thank you Semme for the time taken to try to push me in the correct direction both with mplayer and change from the "old dog".
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11122
Location: Arizona USA

PostPosted: Tue 29 Jan 2013, 22:45    Post_subject:  

For whatever it's worth, Gxine seems to work better for me than any other media player in all the versions of Puppy that will run Gxine at all. (Which has been most of them.)
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 635

PostPosted: Wed 30 Jan 2013, 00:07    Post_subject:  

Interesting. In my case xine is the preferred player - gxine seems to have issues.

I have also installed:

xine-lib-1.1.14-i486, and

xine_extra_codecs-1

Not sure if they help but ...
Back to top
View user's profile Send_private_message 
darry1966

Joined: 26 Feb 2012
Posts: 481
Location: New Zealand

PostPosted: Tue 24 Sep 2013, 03:01    Post_subject: Re: mplayer issues (ABANDONED)
Sub_title: I have a short fuse with software that does not work!
 

Mercedes350se wrote:
I downloaded/installed MPlayer-1.0rc2.pet from http://dotpups.de/puppy3/dotpups/Multimedia/
and all seemed to be well.

To complete the picture I am trying to get gsopcast running on a full HDD install of 3.01 - it didn't seem to want to work with xine!

The issues are:

1. If I click on mplayer in the menu two boxes appear, nothing in either and the machine freezes requiring a Ctrl-Alt-Backspace to get out.

2. If I start gsopcast and select a stream it plays with issues - that is the reason for 1# to try and configure mplayer.

With other updates 3.01 is still a very useful Pup especially with Slackware compatability.

Any ideas/suggestions?


For those with a similar problem with good old 3.01 which by the way is my favourite Puppy Linux.

Try these Xine-lib 1.1.19Full p4 and ffmpeg20100408-09 from shinobar here http://101.141.96.168/puppy/pup4/opt/pets/
then install xine-ui from your package manager. Of course full screen playback will depend on your Xorg Server setup. Using this method I can playback mp4's etc.

So 3.01 is still a very useful Pup and with some other updates can still do a great job as an OS plus has Slackware compatability.
Back to top
View user's profile Send_private_message 
mikeb


Joined: 23 Nov 2006
Posts: 8368

PostPosted: Tue 24 Sep 2013, 07:46    Post_subject:  

Hmm there have been several mplayers around in various states of usability and demands so decided a while ago to have a go at building it myself.

The result was built from a 2009 snapshot (the nature of mplayer) which is compiled as a player only so no encoder deps, no freaking sambaclient, works well with any mp4 i throw at it. does NOT need windows codecs for real player stuff, ffmpeg is built in and runs happily on puppy 2.02 (and newer). I did include the mozilla plugin before but find it more trouble than its worth (ok perhaps pls to be more specific)...just associate media with yer favourite player instead.
Its small and light on ram..especially if used without the gui. Three nice skins are in there too for gmplayer. Idea was to have a relatively up to date player for us older puppy users... its older sfs so will load on any puppy 2/3/4 , or mount and copy over the files (not many).
http://dl.dropbox.com/u/110545536/Puppy/Mplayer-2009_uni.sfs under 4MB.

Thought I should throw it in there if useful to anyone.
Got a similar build player only build of vlc 0.8.6i with 'newer-than-original' ffmpeg but its not packaged if anyone wants it..

mike

edit don't yer just love the way this forum breaks urls Very Happy
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0876s ][ Queries: 12 (0.0062s) ][ GZIP on ]