Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Sep 2014, 18:22
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
5.4.3 Should sr0 appears upon startup? Mine missing
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
alexong2005

Joined: 23 Jan 2013
Posts: 3

PostPosted: Wed 23 Jan 2013, 08:36    Post subject:  5.4.3 Should sr0 appears upon startup? Mine missing
Subject description: Solved
 

Can somebody tell me should sr0 for the CDROM appears upon bootup? If it should then how do I make it appears. Thanks. My email is alexong2005@yahoo.com.sg
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11081
Location: Arizona USA

PostPosted: Wed 23 Jan 2013, 10:57    Post subject:  

Puppy only shows an icon on the desktop when it "sees" filesystems that it recognizes. If there is no disk in your CD drive when Puppy boots, there's no filesystem to detect and Puppy won't show an icon for the CD drive. For reasons I've never fully understood, Puppy also won't show an icon if there's a regular audio CD in the drive. Apparently the filesystem of an audio CD is so primitive that Puppy takes no notice of it. Laughing
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2879
Location: Everybody knows this is nowhere...

PostPosted: Wed 23 Jan 2013, 12:35    Post subject:  

My understanding is that audio CDs don't really have a filesystem any more than a cassette tape did. The reason that Windows (for example) will show a *.cda extension is that Windows doesn't really have a way of addressing something that isn't a discrete file fitting into the hierarchy. It's a limitation of how OSes do things. (I don't think Puppy does it differently, but I could be wrong -- an audio CD should still show up with files in it, if I'm right.)
_________________
Loving X-Slacko 2.1!
Custom Build: HP MOCA-AR + Core2Duo T7200 + 4gb RAM + 256gb SSD
...just needs a pretty case Wink
Back to top
View user's profile Send private message 
alexong2005

Joined: 23 Jan 2013
Posts: 3

PostPosted: Wed 23 Jan 2013, 15:10    Post subject:    

sr0 only shows up when there is data on the CD otherwise it isn't on the desktop. Wink
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9148
Location: Stratford, Ontario

PostPosted: Wed 23 Jan 2013, 17:39    Post subject:  

alexong2005 wrote:
sr0 only shows up when there is data on the CD otherwise it isn't on the desktop. Wink

You have found a bug.

In older Puppies, inserting an audio CD would cause an icon to appear on the desktop. And pmount would also see it. This is because probepart would detect it as having the iso9660 filesystem.

But in new Puppies like Precise and Slacko 5.4, probepart assigns it the filesystem "none". So the other programs ignore it.

The root problem is in the file /proc/partitions. Old Puppies do not list /dev/sr0, so probepart figures out that sr0 is an audio CD.

But new Puppies list /dev/sr0 in /proc/partitions. So probepart thinks that it is a regular partition and gets confused.
Back to top
View user's profile Send private message 
alexong2005

Joined: 23 Jan 2013
Posts: 3

PostPosted: Thu 24 Jan 2013, 07:05    Post subject:    

when i have 5.4.2 sr0 did appears even without cd in it.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7805
Location: qld

PostPosted: Thu 24 Jan 2013, 09:59    Post subject:  

Possible fix.

The following linked pet package replaces your /sbin/probepart, a critical system file, NO RESPONSIBILITY accepted for malfunctions.

Only suitable for puppies 5.4x and beyond (slacko, precise)

http://01micko.no-ip.org/testing/cd_player_rox_icon_fix-0.1.pet

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Mon 28 Jan 2013, 10:32    Post subject:  

Yes, as 01micko noted at my blog, changes in the 3.2 kernel have caused problems with probepart.

I have fixed it, including the audio-cd missing-icon problem:

http://bkhome.org/blog2/?viewDetailed=00094

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0629s ][ Queries: 12 (0.0115s) ][ GZIP on ]