Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 16 Apr 2014, 17:53
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
LMMS 0.4.13
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [35 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
backi

Joined: 27 Feb 2011
Posts: 430
Location: GERMANY

PostPosted: Fri 10 Aug 2012, 02:02    Post subject:
Subject description: LMMS
 

HI Oscar Talks !
Glad you found solution .
Want to report a strange effect i discovered .

I am using Umplayer .
After installing Lmms pet (which works ) i was not longer able to start Umplayer .
Tried to start umplayer from console
I got message " umplayer: symbol lookup error: /usr/lib/libQtNetwork.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv " .
So i looked into /usr/lib/libQtNetwork.so.4 and tried if this libary file does affect the Umplayer .
by moving libQtNetwork.so.4 to another place,(to test if this would change somehow the game .)
Did not expect some result.
But it did .
Umplayer worked again as usual and Lmms does not seemed negatively affected .
Everything seems working .
Maybe this /usr/lib/libQtNetwork.so.4 is not necessary and can cause trouble to other programms.
But i really dont know .
Just want to report this experience .
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 748
Location: London, England

PostPosted: Fri 10 Aug 2012, 07:28    Post subject:  

Hello Backi,

Thanks for the report.
I believe this may be one of the problems with including qt libs inside a .pet, you can sometimes get a clash with other qt programs and the libs that come with them.

The libQtNetwork.so.4 is not one that I included in the LMMS .pet
I only put in the ones that were needed ie QtGui, QtCore and QtXml.

I am not sure what to do about this. Maybe if I include all the qt libs together it would overwrite them all as a group and this would be OK, but that would be a case of testing and waiting for other reports. Not sure how much bigger it would make the LMMS .pet if I do this.

I guess the other way is to offer the LMMS .pet without qt libs and specify that qt is a dependency which the user needs to install separately.

_________________
Oscar in England

Back to top
View user's profile Send private message 
sheepy


Joined: 06 May 2011
Posts: 234
Location: GA

PostPosted: Fri 10 Aug 2012, 22:06    Post subject:  

It appears that for ZynAddSubFX to work, the separate app itself is required first. I have failed to bring it to Puppy though. Sad
Back to top
View user's profile Send private message Visit poster's website 
OscarTalks

Joined: 05 Feb 2012
Posts: 748
Location: London, England

PostPosted: Sat 11 Aug 2012, 06:26    Post subject:  

@ Sheepy,
You have to install at least some of the dependencies of ZynAddSubFX (FFTW) before compiling LMMS, but once compiled the ZynAddSubFX plugin within LMMS works without the need to install ZynAddSubFX itself.
However, I have produced .pet packages of ZynAddSubFX as a separate program in the other thread if you want to try them. I didn't do a Lucid version though.

@Backi,
I was unable to reproduce your problem. Booted live pfix=ram and installed UMplayer from PPM. This also installs qt-4.8.0-basic-with-qtwebkit-dpup.pet as a dependency. Starting UMplayer from console gives some debug messages and a couple of warnings but no errors and UMplayer starts (no LMMS yet). Then I installed my LMMS .pet and ran it a couple of times. Tried UMplayer again and it still starts from console with the same messages or from menu with no visible problem.
The qt libs in the LMMS .pet are the same as the ones in the qt-4.8.0 package that is installed with UMplayer. I wonder if you installed a UMplayer from somewhere else or have at some point installed a different qt or a package which has included a different set of qt libs and files.

_________________
Oscar in England

Back to top
View user's profile Send private message 
capicoso

Joined: 13 Jan 2012
Posts: 172
Location: Argentina

PostPosted: Thu 23 Aug 2012, 00:11    Post subject:  

OscarTalks wrote:
Hello Backi,

Thanks for the report.
I believe this may be one of the problems with including qt libs inside a .pet, you can sometimes get a clash with other qt programs and the libs that come with them.

The libQtNetwork.so.4 is not one that I included in the LMMS .pet
I only put in the ones that were needed ie QtGui, QtCore and QtXml.

I am not sure what to do about this. Maybe if I include all the qt libs together it would overwrite them all as a group and this would be OK, but that would be a case of testing and waiting for other reports. Not sure how much bigger it would make the LMMS .pet if I do this.

I guess the other way is to offer the LMMS .pet without qt libs and specify that qt is a dependency which the user needs to install separately.

i think a complete qt 4.8 is about 50~ mB installed. The problem is if you include the whole qt lib inside lmms.pet, when i uninstall lmms it'll also uninstall qt and half of my programs will stop working. You should make another pet for qt. But some people already made pets and sfs for qt 4.7 on slacko, so you could just post that one. These errors generally appears when mixing older/newer qt libs together.
Back to top
View user's profile Send private message 
sheepy


Joined: 06 May 2011
Posts: 234
Location: GA

PostPosted: Thu 23 Aug 2012, 16:17    Post subject:  

OscarTalks wrote:
@ Sheepy,
You have to install at least some of the dependencies of ZynAddSubFX (FFTW) before compiling LMMS, but once compiled the ZynAddSubFX plugin within LMMS works without the need to install ZynAddSubFX itself.
However, I have produced .pet packages of ZynAddSubFX as a separate program in the other thread if you want to try them. I didn't do a Lucid version though.

@Backi,
I was unable to reproduce your problem. Booted live pfix=ram and installed UMplayer from PPM. This also installs qt-4.8.0-basic-with-qtwebkit-dpup.pet as a dependency. Starting UMplayer from console gives some debug messages and a couple of warnings but no errors and UMplayer starts (no LMMS yet). Then I installed my LMMS .pet and ran it a couple of times. Tried UMplayer again and it still starts from console with the same messages or from menu with no visible problem.
The qt libs in the LMMS .pet are the same as the ones in the qt-4.8.0 package that is installed with UMplayer. I wonder if you installed a UMplayer from somewhere else or have at some point installed a different qt or a package which has included a different set of qt libs and files.

Shortly afterwards I figured out the correct dependencies to get this working on Lucid. I might make a pet later. Anyway, ZynAddSubFX is working and after upgrading LMMS to 0.4.13 it works there too, but somewhere along the line caused a conflicting symbol error with Skype. Working on having them coexist right now.
Back to top
View user's profile Send private message Visit poster's website 
OscarTalks

Joined: 05 Feb 2012
Posts: 748
Location: London, England

PostPosted: Thu 23 Aug 2012, 18:51    Post subject:  

@capicoso
Thanks for the feedback. You make a lot of sense. I've gone back to the original idea of posting the .pet packages without any qt libs. Installing qt can easily be done from PPM as you say.

@sheepy
Skype also depends on qt of course. Don't think it would be a problem if you use the static version but not certain about that. I believe that is the difference between the 28 Meg version and the 40 Meg version if you are talking about Skype 4. If you make a .pet of LMMS for Lucid hopefully you will post it up. I took it on as an exercise, a bit of homework because I am a student of compiling, but it has proved to be a bit heavy going so I'm hoping to be able to call a halt to my efforts with it, at least for the time being.

_________________
Oscar in England

Back to top
View user's profile Send private message 
sheepy


Joined: 06 May 2011
Posts: 234
Location: GA

PostPosted: Fri 24 Aug 2012, 16:15    Post subject:  

OscarTalks wrote:
@capicoso
Thanks for the feedback. You make a lot of sense. I've gone back to the original idea of posting the .pet packages without any qt libs. Installing qt can easily be done from PPM as you say.

@sheepy
Skype also depends on qt of course. Don't think it would be a problem if you use the static version but not certain about that. I believe that is the difference between the 28 Meg version and the 40 Meg version if you are talking about Skype 4. If you make a .pet of LMMS for Lucid hopefully you will post it up. I took it on as an exercise, a bit of homework because I am a student of compiling, but it has proved to be a bit heavy going so I'm hoping to be able to call a halt to my efforts with it, at least for the time being.

Indeed, it is Skype 4. :\ It's a libqtnetwork symbol error.
I got ZynAddSubFX working with 0.4.10, but I think yours handles VST's better. I'll work on bringing 0.4.13 to Lucid sometime.
Back to top
View user's profile Send private message Visit poster's website 
mini-jaguar

Joined: 13 Nov 2008
Posts: 457

PostPosted: Mon 28 Jan 2013, 05:45    Post subject:  

Which version of Exprimo did you compile it with? I tried several versions and the sound cuts off.

It does the same thing with Slacko 5.4.0, but works fine with Slacko 5.3.1 and 5.3.3.
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 430
Location: GERMANY

PostPosted: Mon 28 Jan 2013, 10:15    Post subject:  

HI mini-jaguar !

I am using LMMS 4.13 on Dpupexprimo ...works fine .....everything is included.
Zynnaddsub and sf2 player !
I think it works on Puppyprecise too ...not quite sure .
On Slacko idont know.

Maybe give it a try ...look for it here
http://smokey01.com/pemasu/pet_packages-exprimo/

It needs qt-4.8.0 libs .
Back to top
View user's profile Send private message 
mini-jaguar

Joined: 13 Nov 2008
Posts: 457

PostPosted: Mon 28 Jan 2013, 13:05    Post subject:  

WHICH Dpup Exprimo? Welche Version???!!!

Strangely enough, it worked on Precise for me too, but the menu entry didn't. Had to start from the console by typing "lmms", but no dropouts like on Exprimo (tried 5.X.3.6.2.1 , 5.X.3.4.12 , Wheezy, and I think two or three other dpups.)

The way to check if it drops out is to go to the short clips in the demos and choose that drum and bass demo. Either it'll sound normal, or the sound will cut off once in a while.
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 430
Location: GERMANY

PostPosted: Mon 28 Jan 2013, 14:36    Post subject:  

Hi mini-jaguar !

Using it on Dpupexprimo 5X3.6.2.1

install first qt-4.8.0 pet
Download it from link above .
I made an SFS file from it using SGF-combiner.
No problems for me .Works well .
Maybe depends on CPU or RAM ?
Dont know .
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 748
Location: London, England

PostPosted: Mon 28 Jan 2013, 15:06    Post subject:  

mini-jaguar wrote:
Which version of Exprimo did you compile it with?


This was compiled in the latest Exprimo at the time which would have been 5.X.3.4.2.9 or possibly one earlier or one later but I would expect it to run on any of the Exprimos. It was all very experimental at the time though and it is still an app that I am not very familiar with so it is difficult for me to advise.

I have Exprimo 5X15 installed on one of my machines so I might give that a try. I'll see if I can find the demo you are talking about and see if it plays.

LATER - OK I just tested it in 5X15 and it all plays fine BUT if you mean the DnB demo in "Shorties" I did notice that it runs the CPU much harder than all the other demos so it may be that you are running close to a threshold on your machine depending on which Puppy and what other tasks are running.

_________________
Oscar in England

Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 430
Location: GERMANY

PostPosted: Mon 28 Jan 2013, 16:30    Post subject:  

Hi !

Yes some songs are harder for my CPU too .

I think Programms is ok .
Back to top
View user's profile Send private message 
mini-jaguar

Joined: 13 Nov 2008
Posts: 457

PostPosted: Tue 29 Jan 2013, 03:33    Post subject:  

OscarTalks wrote:
LATER - OK I just tested it in 5X15 and it all plays fine BUT if you mean the DnB demo in "Shorties" I did notice that it runs the CPU much harder than all the other demos so it may be that you are running close to a threshold on your machine depending on which Puppy and what other tasks are running.
Yes, that's what I meant.

backi wrote:
Maybe depends on CPU or RAM ?
Dont know .
I have thought of it too. Indeed, I have tried it on a computer where every song is real slow.

But it is weird that on my main computer on some Puppies it sounds fine with no lag, with other Puppies it cuts off. Same CPU, RAM, etc.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [35 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0745s ][ Queries: 13 (0.0051s) ][ GZIP on ]