Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 25 Jul 2014, 14:19
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to increase CRT refresh rate in Puppy 5.10?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [19 Posts]   Goto page: 1, 2 Next
Author Message
wildirish

Joined: 18 Aug 2006
Posts: 36

PostPosted: Tue 08 Jan 2013, 21:07    Post subject:  How to increase CRT refresh rate in Puppy 5.10?  

My old CRT monitor gave up the ghost, so I can choose between a couple of "new" ones to put in its place.

One's a 17" CRT and the other (which I would rather use, due to lack of space) is a 15" CRT. The problem is, when I use Puppy 5.1, both will flicker and give me a massive headache, because I can't adjust the refresh rate any higher than 75 while using the Xorg wizard.

So I'm currently using Puppy 2.0, and the picture looks great--no discernable flicker. Its refresh rate is 98, I believe. The down side is that I'm using a very old Puppy now, and would prefer to use Puppy 5.1 again.

If it makes any difference, the monitor is a Gateway 15" VGA CRT, model EV530. The video card is SiS630 GUI Accelerator+3D.

My question: When manually tweaking the xorg.config file in Puppy 5.1, what part of the code do I need to change, in order to increase the refresh rate beyond 75? Because I can't find anything with that specific number in the xorg.config file.

Thanks.
Back to top
View user's profile Send private message 
Peterm321

Joined: 29 Jan 2009
Posts: 222

PostPosted: Tue 08 Jan 2013, 22:24    Post subject:  

This site, http://ubuntuforums.org/showthread.php?t=83973 although based on Ubuntu, gives some idea on ajusting refresh rates.

NB its not only the Monitor that determines what refresh rates you can have. If you are using Xvesa or the "vesa" driver with Xorg or perhaps a basic framebuffer driver you may be limited to specific refresh rates no matter what monitor/graphics cards combination you have.

I write only from experience of using a Nvidia Geforce4 graphics card and to get enhanced refresh rates I use either the Nvidia (not open source) official driver or the open source "nv" (2D only) driver. Newer Kernels may also offer the "nouveau" driver for Nvidia users. Typing, --

xrandr

At the command prompt will display the available refresh rates with an asterisk delineating the current default.

I would search the forums and the web more widely using your monitor model and/or graphics chip along with "xorg conf" and may hopefully show up example xorg.conf files that may be useful.
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10930
Location: Arizona USA

PostPosted: Tue 08 Jan 2013, 22:38    Post subject:  

Wildirish, did you see this thread about editing the xorg.conf file? I can't say it will solve your problem, but in the absence of anything else it's a good place to start.
Back to top
View user's profile Send private message 
Monsie


Joined: 01 Dec 2011
Posts: 633
Location: Kamloops BC Canada

PostPosted: Wed 09 Jan 2013, 05:29    Post subject: How to incrase CRT refresh rate in Puppy 5.10?  

wildirish,

I found the specs and other info for your 15 inch Gateway Monitor here. Here is an excerpt:
Quote:
Specifications

Specifications are subject to change without notice or obligation.

CRT

15.0 inches diagonal (13.8 inches viewable), anti-glare, 90° deflection, 0.28 mm dot pitch
Maximum resolution

1024 × 768 @ 60 Hz non-interlaced
Optimum resolution

800 × 600 @ 75 Hz non-interlaced
Display colors

Unlimited
Frequency range

Horizontal, 30-56 KHz
Vertical, 50-120 Hz
Power input

100-240 VAC
Certifications

UL, CSA, and FCC Class B
Power management

Meets International Energy Star requirements:

Active Off mode = less than or equal to 3 W
Environment

Operating temperature:
41° to 104°F (5° to 40°C)

Operating humidity: 5% to 90%


Note that while your Vertical Refresh range is 50-120 hz you also have to consider your Optimum and Maximum Resolution values. These latter values are recommended for your monitor, and you should note that using a higher Vertical Refresh rate can and likely will cause damage to your monitor.

The reason you are only getting a refresh rate of 75 hz is likely because Xorg gets its values from the Display Data Channel which is a protocol that your monitor and/or graphics card or chip would support in order to determine optimum values for your display. To check this at the terminal:
Code:
ddcprobe

or if you just want to filter out the extraneous info and get the horizontal sync and vertical refresh rates:
Code:
ddcprobe | grep monitorrange


That said, apparently you can disable the DDC protocol in your xorg.conf file, so that you can make a custom configuration. To do this, -->/etc/X11/xorg.conf & then open the file and find: Section "Device" add a line: Option "NoDDC" Find: Section "Monitor" Now uncomment the line below it that refers to DisplaySize Now scroll down a few lines and find the lines that say: HorizSync and VertRefresh and change those default values to the values indicated in your Monitor Specifications. Save your changes and restart Xserver. Be prepared that Xsever may not restart and you will end up with a black screen... You might first try a range of 50.0-100.0 or even 50.0-85.0 to see if any of those values will override those given by DDC. Note that I haven't tested this, so I do not know for sure if it will work for you. I do not even recommend doing this, because you will be pushing the limits of your hardware: monitor and graphics... and it's possible that you could cause some irreparable damage. Therefore: try this at your own risk etc.

Monsie

_________________
My username is pronounced: "mun-see". Derived from my surname, it was my nickname throughout high school.
Back to top
View user's profile Send private message 
Burn_IT


Joined: 12 Aug 2006
Posts: 958
Location: Tamworth UK

PostPosted: Wed 09 Jan 2013, 13:12    Post subject:  

If you can see flicker at a true 75Hz NON-INTERLACED there is something else wrong.
I suffer from bad migraines and need a higher refresh rate than most people, but I cannot see flicker over 70Hz.

_________________
I can't remember the last time I forgot something!
Back to top
View user's profile Send private message 
wildirish

Joined: 18 Aug 2006
Posts: 36

PostPosted: Wed 09 Jan 2013, 16:25    Post subject:  

Monsie, thanks for the info...I'll try it. I know for a fact that my monitor and graphics card can handle a refresh rate of 98, as that's what I'm doing now. (I took the advice upthread and did xrandr, to see what my refresh rate, etc., is while using Puppy 2.0.)

So am I right in thinking that, because these settings are doing no damage now, that it's likely they won't do damage in Puppy 5x?

Burn_IT wrote:
If you can see flicker at a true 75Hz NON-INTERLACED there is something else wrong.
I suffer from bad migraines and need a higher refresh rate than most people, but I cannot see flicker over 70Hz.

I don't have migraines, but I'm sorry to hear that you have them.

You're right, something else is wrong. I have chronic latent tetany caused by alkalosis, which is caused by my respiratory problems. It causes a lot of WEIRD neurological symptoms. One of these is that I can see flicker when other people can't. My tolerances for flickering screens vary, and at the moment I can't even tolerate TV. My doc is sending me to some specialists, but it will take months (if not a year or more) for me to get relief, because they have to find out what's making me breathe badly, then I'll need respiratory therapy.

Sorry to go off-topic, but I just wanted to say you were spot-on in your assessment. Smile

I'll post again later, with the results of trying Monsie's advice.
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10930
Location: Arizona USA

PostPosted: Wed 09 Jan 2013, 19:36    Post subject:  

Wildirish, you might consider replacing your CRTs with flat-screen LCD monitors and TVs. It could save enough on doctor bills to pay for the monitor. Flicker is generally not a problem with LCD panels. If an LCD does seem to flicker, it's because the backlight isn't well designed. If there's a store near you that sells LCD monitors, you can verify what I say.
Back to top
View user's profile Send private message 
postfs1


Joined: 27 Mar 2010
Posts: 831

PostPosted: Wed 09 Jan 2013, 20:44    Post subject: Re: How to increase CRT refresh rate in Puppy 5.10?  

wildirish wrote:

How to increase CRT refresh rate in Puppy 5.10?
...


Example of xorg.conf for Quirky Linux - 1.40 Arrow
http://www.murga-linux.com/puppy/viewtopic.php?p=586415#586415

_________________
  • I don't know why laboratories are named a hospitals.
  • The alive personage is like a tea bag with granules of unknown density inside, at that one the packet was made of organic material and was placed in the evaporated liquid or liquid.

Back to top
View user's profile Send private message 
Monsie


Joined: 01 Dec 2011
Posts: 633
Location: Kamloops BC Canada

PostPosted: Thu 10 Jan 2013, 01:46    Post subject: How to increase CRT refresh rate in Puppy 5/10?  

wildirish,

Good luck with your modifications to Xorg.conf I hope it works out for you... but in any event, thanks in advance for letting us know how you make out, because your feedback could prove to be useful in the future.

That said, I second the recommendation made by Flash... I believe getting an LCD monitor is the way to go. I have never seen screen flicker with an LCD display. If budget is a concern, you could look for a used monitor. Last year, I managed to find a second hand 15 inch ViewSonic LCD display at the local thrift store for only $15.00 Canadian. I use it for my Wary Puppy system.

Monsie

_________________
My username is pronounced: "mun-see". Derived from my surname, it was my nickname throughout high school.
Back to top
View user's profile Send private message 
wildirish

Joined: 18 Aug 2006
Posts: 36

PostPosted: Fri 11 Jan 2013, 04:38    Post subject:  

Flash wrote:
Wildirish, you might consider replacing your CRTs with flat-screen LCD monitors and TVs.

Thanks for the suggestion, but unfortunately, I can't tolerate LCD monitors at all. (Doing research on the internet, I've found a lot of people share the same problem). That's why people like me have been forced to stick with the clunky CRT's. My mother can't stand anything except CRT's either, and she doesn't have the medical issues that I have. And I have a friend who can't tolerate the newer TV's/monitors either, so he's just using an iPad now because the smaller screen doesn't bother him as much. I appreciate your suggestion, though!

Monsie (or anyone else interested), I just noticed something on the screencap I did, when I ran xrandr. 85 shows up as an option! (I've underlined the number) Yet when I try to change it to 85 while running Xorg, it acts as if it's accepting that setting...then changes back to 75, as you can see in the attached screencap. So if it's an available option, I don't see why Xorg keeps changing it to 75 when I select the 85 option that Xorg itself offers me.

Also, I've attached screencaps of the result of running xrandr in Puppy 5.1 and Puppy 2.0 (which I'm using right now). You can see that I'm using a refresh rate of 98 with no problem. It also seems to be showing more info about the size, compared to 0mm x 0mm which is in the Puppy 5.1 result.

I'm sorry if I sound stupid here, but I have very little experience with the command line. My health issues also make it somewhat hard for me to learn new things at the moment (it's a long story--suffice it to say that my brain is literally not getting as much oxygen as it needs because of my breathing). So your patience is appreciated!

Monsie, could you possibly answer my questions about the attached screencap, before I attempt to tweak anything as you suggested? I just want to be 100% sure there isn't a simple solution, before I do anything risky. Thanks!
Xrandr.png
 Description   
 Filesize   13.77 KB
 Viewed   370 Time(s)

Xrandr.png

Back to top
View user's profile Send private message 
Monsie


Joined: 01 Dec 2011
Posts: 633
Location: Kamloops BC Canada

PostPosted: Sat 12 Jan 2013, 05:05    Post subject: How to increase CRT refresh rate in Puppy 5.10?  

wildirish,

xrandr is used to configure a display "on the fly" without having to restart Xserver. Yes, it appears that your monitor will run @85hz at a resolution of 640x480 This configuration is temporary with xrandr. It lasts for your session only and then your display returns to default values upon re-boot. This kind of arrangement is useful for running games with strict graphics configuration, but it is also useful to test your system at the higher refresh rate. See this thread here for easy to follow instructions on how to use xrandr to do that.

The instructions that I gave you in my initial post are so that (hopefully) you can modify your xorg.conf file to make a permanent custom configuration and it's based on my premise that xorg creates a default configuration from the given values of the Display Data Channel protocol, and, that this protocol must first be disabled as suggested in the xorg manual before making a new configuration. A stumbling block might be that your graphics driver does not support the desired custom configuration, but since you can run your monitor at 98 hz in Puppy 2x I think you are probably okay. Again, and this relates to my remarks about DDC from my initial post, I believe the reason you can run your monitor at the higher refresh rate is (I suspect) that the Display Data Channel protocol (DDC) is not available or not being used in the older Puppy.

So... try a test configuration with xrandr, and if that appears to work, then see if you can disable DDC in xorg.conf and try to create a new and permanent custom configuration. I would hope that a refresh rate of 85 hz would meet with your comfort level. There is a better chance that your monitor would withstand prolonged use at this frequency than at the 98 hz vertical refresh rate that your are running now.

Hope this helps,
Monsie

_________________
My username is pronounced: "mun-see". Derived from my surname, it was my nickname throughout high school.
Back to top
View user's profile Send private message 
wildirish

Joined: 18 Aug 2006
Posts: 36

PostPosted: Tue 29 Jan 2013, 00:19    Post subject: Re: How to incrase CRT refresh rate in Puppy 5.10?  

I tried the Xrandr method, but 85 apparently is still too low for my eyes to tolerate, though it was only slightly better than 75. So I tried the permanent configuration, which failed (possibly due to user error??). Here's what happened.

Monsie wrote:
That said, apparently you can disable the DDC protocol in your xorg.conf file, so that you can make a custom configuration. To do this, -->/etc/X11/xorg.conf & then open the file and find: Section "Device" add a line: Option "NoDDC"

I did that, but in that file, there are other things at the end of each line. For example:
Code:
#Option     "MergedNonRectangular"    # [<bool>]
#Option     "MergedMouseRestriction"    # [<bool>]


So I put those items at the end of this new line as well:
Code:
#Option     "NoDDC"    # [<bool>]


Was that a mistake? Some of the other lines in that section ended with # <str> or # <i>. Please let me know how I should end the line with NoDDC, as perhaps that's where I went wrong.

Monsie wrote:
Find: Section "Monitor" Now uncomment the line below it that refers to DisplaySize

Unfortunately, there is no "DisplaySize" in my xorg.conf file:

Code:
Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
   HorizSync    30-56
   VertRefresh  50-120
   #UseModes     "Modes0" #monitor0usemodes
   Option      "PreferredMode" "640x480"
   EndSection


Monsie wrote:
Now scroll down a few lines and find the lines that say: HorizSync and VertRefresh and change those default values to the values indicated in your Monitor Specifications.

As you see above, I did that part. Smile

Monsie wrote:
Save your changes and restart Xserver.

I did, but then the refresh rate was changed back to 75, and Xrandr only gave me the option to increase it to 85...same as before.

Oddly enough, my customized menu also reverted to the default one that you get when you install Puppy. (All my tweaking gone...but I have my Puppy backed up, so that's not a big problem.)

Monsie (or anybody else), did I do something wrong? Is there something else I should also uncomment, since DisplaySize doesn't exist in my xorg.config file?

(P.S. -- Sorry for the late reply...I was out of town.)
Back to top
View user's profile Send private message 
Monsie


Joined: 01 Dec 2011
Posts: 633
Location: Kamloops BC Canada

PostPosted: Tue 29 Jan 2013, 04:14    Post subject: How to increase CRT refresh rate in Puppy 5.10?  

You're back... Smile

First of all, if there is no line referring to "DisplaySize" in the Section "Monitor" in your xorg.conf file, then you need not worry. If this line was there, I thought it might help in fine tuning your display --the monitor dpi setting (in conjunction with other changes in your display configuration). Anyway, I apologize for possibly leading you astray on this. The critical part of your xorg.conf adjustment concerns the Display Data Channel. In Puppy Linux, xorg probes the DDC to set a default configuration for your display. The idea is to turn this function off in order to set up (possibly) a custom configuration.

Note that any line which specifies a feature or value of some kind in xorg.conf must be uncommented -- the hash tag # must be removed in order to activate the particlular line. In addition, the Option "NoDDC" is a boolean value which must be defined, so it is either "yes" or "no", "on" or "off", "true" or "false". Therefore you want to add the following line to the Section "Device" part of xorg.conf where the driver options are specified.
Code:
Option     "NoDDC"     [<"True">]

Finish by adjusting your refresh rates to the maximum range for vertical and horizontal sync, then save your changes and try restarting X server. Hopefully, you will then be able to set your custom refresh rate to 98 hz as you were able to do in Puppy 2x

As I said in an earlier post, I don't know whether this will work for sure or not. While I have read about some success with this, it seems to vary with the kind of hardware and driver support one has. Also, some graphics card drivers use slightly different instructions and syntax, for instance, I found this info about ATI Radeon cards here.
Notice the options for the Radeon driver include:
Code:
Option "DDCMode" "on"

or
Code:
Option "DDCMode" "off"

While I realize you don't have a Radeon card, you might want to look at the specs for your particular video driver also to see if there is an option to toggle DDC support and how it's done. Beyond that, I can't think of any other details or adjustments that you need to be concerned with.

Hopefully this works for you... either way, I feel it is worth the effort.

Monsie

_________________
My username is pronounced: "mun-see". Derived from my surname, it was my nickname throughout high school.
Back to top
View user's profile Send private message 
wildirish

Joined: 18 Aug 2006
Posts: 36

PostPosted: Tue 29 Jan 2013, 21:24    Post subject:  

Monsie, I must be doing something wrong, as the same thing is happening, as what I described in my last post.

It's very hard for me to work on Puppy 5, as I have to wear dark sunglasses and turn the monitor brightness down as far as it will go, for me to just be able to work for about 5 minutes. It's really hurting my eyes, and I just can't handle the pain.

So I've uploaded my xorg.conf file as a text file. Could you possibly make the adjustments you're suggesting, then re-upload it as a text file for me to replace my xorg.conf with? (Of course, I'll remember to rename it .conf instead of .txt)

I'm sorry to bother you, but if you could do this, I would very much appreciate it. Smile
Back to top
View user's profile Send private message 
Monsie


Joined: 01 Dec 2011
Posts: 633
Location: Kamloops BC Canada

PostPosted: Wed 30 Jan 2013, 02:32    Post subject: How to increase CRT refresh rate in Puppy 5.10?  

wildirish wrote:
So I've uploaded my xorg.conf file as a text file. Could you possibly make the adjustments you're suggesting, then re-upload it as a text file for me to replace my xorg.conf with? (Of course, I'll remember to rename it .conf instead of .txt)

I'm sorry to bother you, but if you could do this, I would very much appreciate it. Smile


Where did you upload the file? If you send me a PM with your attached xorg.conf file, I will edit it for you and return it. Xorg.conf is a text file... so there is no need to change the file to the .txt extension, but note that you will have to archive your file in order to upload it as an attachment.

Monsie

_________________
My username is pronounced: "mun-see". Derived from my surname, it was my nickname throughout high school.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [19 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1317s ][ Queries: 13 (0.0084s) ][ GZIP on ]