Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 22:16
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
LMMS 0.4.13
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 3 of 3 Posts_count   Goto page: Previous 1, 2, 3
Author Message
backi

Joined: 27 Feb 2011
Posts: 448
Location: GERMANY

PostPosted: Tue 29 Jan 2013, 09:11    Post_subject:  

Hi everyone !
Beside the question of Ram or Cpu related situation

want to tell you how i handled possible conflicts with Qt libarys in case of lmms ,umplayer , vlc player ,skype or a few other programms which needs
qt 4.8 .
Did not install qt 4.8 as pet.(use instead the sfs file for only using it on demand )
Downloaded the programms above as pets ( or sfs file )....converted them to sfs-files (qt also ).
either you can start start them single way (without installing them ..execute them just on demand) using sfs-executer or sfs-loader ...

or using sfscombiner to make combipacks (for example - lmms sfs + qt4.8 sfs...or -umplayer-sfs+qt4.8sfs..-vlcplayer- sfs +qt 4.8 sfs ) execute them with sfsececuter or sfsloader only on demand.
Find it quite convenient.

Did a cut down remaster of dpup exprimo ,removed most programms and replaced them as far as possible with sfs files-modules version of this programms .Only load them on demand .
In case they need dependencies i combine them with sfscombiner to a single combipack sfs-file ...only start them on demand .so they need not be installed and can probably not so easyly conflict with other libs or depencies .....( i am just a newbee ).
So i have quite a bare-bone Dpupexprimo ...precise too (maybe 110 megs ).. and just a small savefile 124 megs for configuration and others .
Most of my programms and some libs and depencies i have externalized as sfsmodules ....only load them when needed....on demand..

maybe you can call it "ON Demand Puppy ....or Puppy on Demand or " Puppy on the fly " )"
I think it it possible can save some space in ram too.... ( not quite sur ) .
Like using " on the fly " sfs-files more then using pets . Want to go more "modular " like RSH has done in "Lazy Puppy " .
There a some interresting modular aspects in a little Slackware distro named "Porteus " (Distrowatch ) .
Back to top
View user's profile Send_private_message 
mini-jaguar

Joined: 13 Nov 2008
Posts: 462

PostPosted: Thu 31 Jan 2013, 10:16    Post_subject:  

OscarTalks wrote:
mini-jaguar wrote:
Which version of Exprimo did you compile it with?


This was compiled in the latest Exprimo at the time which would have been 5.X.3.4.2.9 or possibly one earlier or one later but I would expect it to run on any of the Exprimos. It was all very experimental at the time though and it is still an app that I am not very familiar with so it is difficult for me to advise.

I have Exprimo 5X15 installed on one of my machines so I might give that a try. I'll see if I can find the demo you are talking about and see if it plays.

LATER - OK I just tested it in 5X15 and it all plays fine BUT if you mean the DnB demo in "Shorties" I did notice that it runs the CPU much harder than all the other demos so it may be that you are running close to a threshold on your machine depending on which Puppy and what other tasks are running.
Yes, it runs well in 5X15, just tried it. No dropouts. I never had other tasks running while testing this.
Back to top
View user's profile Send_private_message 
paulski

Joined: 06 Oct 2006
Posts: 127
Location: Cologne, Germany &/or Perth, Australia

PostPosted: Sun 21 Apr 2013, 14:58    Post_subject: LMMS 0.4.13 in 64 Bit  

LMMS 0.4.13 in Fatdog has not been the dream I hoped for.
Up till now i was using a 0.4.9 LMMS I found somewhere in Fatdog 64 repositories -- possibly in the all in one audio sfs.
Problem is the almost essential zynaddsubfx synth doesn't work -- and nearly all the demo lmms projects out there use it.
All of the tips in this thread thus far didn't quite give me the answer I needed. But it helped me to work out where to look.
Thanks guys.

Stealing libs and bits from ubuntu deb files did no good -- so I tried to compile lmms again from source.

Kinda worked but zynaddsubfx always failed.
After about a day of frustration googling for tips and editing heaps of source code files to "fix" a bug -- I eventually stumbled on the problem and got a good build- yihoo! Smile

lmms-0.4.13-x86_64.pet
https://www.box.com/s/33qiec4xzvpy5apmfb6u

What was the problem? One of the dependencies fftw - that I got from the repository was compiled only for double floating point precision.
Lmms and zynaddsubfx and a few other plugins needed fftw3f that is the single floating point precision build
To configure to compile fftw from source i needed this line for a single precision version:
Code:
sh configure --prefix=/usr --enable-shared --enable-float


@ sheepy - perhaps this is what you needed for your lucid build mentioned on page one of this thread?

Here is a pet of my fftw build:
fftw-single-3.3.3-x86_64.pet
https://www.box.com/s/ux3g79bvmmhn2ii7e7lk

Then also the following dependencies to build
qt4 can't remember which version probably qt4.7
jack2-1.9.8.pet from the fatdog repository

Then also compiled from source:
fltk-1.3.2-x86_64.pet
https://www.box.com/s/bs02axetdaden9iw0vfg

fluidsynth-1.1.6-x86_64.pet
https://www.box.com/s/ak6ehb3qkyhbjjd1zosb

mxml-2.7-x86_64.pet
https://www.box.com/s/3jisfovvie2vmserta5c

fontconfig-2.10.92-x86_64.pet
https://www.box.com/s/1c4i0ki15fy996vy2zhi

At the unsure stage I even built zynaddsubfx stand alone. Lmms didn't need it but what the hey if anyone needs it:
ZynAddSubFX-2.4.3-x86_64.pet
https://www.box.com/s/elpju5678pracg36t392

Everything I've compiled was done in Fatdog 611.

Note: the lmms build above does not have vst support. That needs to work in harmony with wine development libraries.
I haven't got the wine dev business going yet in 64 bit. As wine has to be 32 bit its a bit tricky. the wine sfs I used from the fatdog repos does not have development stuff in it.
Back to top
View user's profile Send_private_message 
mini-jaguar

Joined: 13 Nov 2008
Posts: 462

PostPosted: Fri 12 Jul 2013, 05:00    Post_subject:  

That lmms also works in FatDog64 6.2.1. Pretty cool.

I had once installed an earlier lmms, 0.4.10, maybe .11 or .12, from a Slackware repository into Slacko, and it did pull lots of Wine script.
Back to top
View user's profile Send_private_message 
Pelo


Joined: 10 Sep 2011
Posts: 3221
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 04 Dec 2013, 01:11    Post_subject: Polarpup runs the Slacko lmms  

Polarpup runs the Slacko lmms
Without any addition
lmms.jpg
 Description   
 Filesize   73.68 KB
 Viewed   135 Time(s)

lmms.jpg

Back to top
View user's profile Send_private_message YIM 
Display_posts:   Sort by:   
Page 3 of 3 Posts_count   Goto page: Previous 1, 2, 3
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0642s ][ Queries: 13 (0.0066s) ][ GZIP on ]