Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 04:58
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
How to tell Puppy which sound card to use?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
maynard70

Joined: 04 Feb 2013
Posts: 1

PostPosted: Mon 04 Feb 2013, 14:29    Post_subject:  How to tell Puppy which sound card to use?
Sub_title: Once and for all
 

Hi All.

Fairly new to Linux and am Running the Puppy 0.52 USB Stick distro on a P4 Dell Optiplex. (Kernel 2.6.33.2) Works pretty well, and is plenty fast for what I need it for, just a simple internet audio player and server.

Strange probem, though... The machine came with two sound cards, one internal on the mobo and the other a PCI slot. Here's the issue - on an initial boot-up, the OS will not select one or the other card and stick with it.

To clarify... sometimes, on a boot, one card will load, and on another boot, the other will load. It's either one or the other that the OS selects - and no, both will not work at the same time. (I'm getting tired of having to switch out the audio jack!) I've tried removing the PCI slot card altogether, but when I do that, the internal mobo card won't load at all. Can't figure out why. However, once the OS finds a card and loads it, I can use the machine all day with no problems.

It's like I have to have both connected for either of them to work, and it's a crap-shoot on which one the OS will choose on every boot. I've played around with the system settings and the mixer settings, but nothing is working. I don't care which one is in use, the audio quality is the same for either one, I just need to figure out how to force the OS into finding ONE card, initializing/loading it, and staying with it, forever.

Any ideas? (Keep in mind I'm not a Linux expert, but I can follow instructions!)

Thanks... M.
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11083
Location: Arizona USA

PostPosted: Mon 04 Feb 2013, 15:22    Post_subject:  

Have you considered removing one of the sound cards?
Back to top
View user's profile Send_private_message 
OscarTalks

Joined: 05 Feb 2012
Posts: 884
Location: London, England

PostPosted: Mon 04 Feb 2013, 15:49    Post_subject:  

The solution to the "default soundcard = random" situation with 2 soundcards is to edit the file:-

/etc/modprobe.d/alsa-base.conf

adding 2 lines at the end thus:-

options snd-defaultmodule index=0
options snd-secondcardmodule index=1

A couple of examples which I have to do (the text I have to add to the file) are:-

Code:
options snd-hda-intel index=0
options snd-cmipci index=1


and on a different machine

Code:
options snd-intel8x0 index=0
options snd-ca0106 index=1


There should be a carriage return on the end so you have started a new blank line.

You need to figure out which your 2 driver modules are for your 2 soundcards and which one you want as the default and insert the names for your machine. The default card is defined as index=0 and the second card as index=1

Look in /proc/asound/modules to see the sound modules and hopefully it should be easy to figure out which is which.

_________________
Oscar in England

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0456s ][ Queries: 12 (0.0037s) ][ GZIP on ]