Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 08:18
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
sylpheed 3.2.0 in PRECISE 5.4.3 problems
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
hikohan

Joined: 29 Nov 2011
Posts: 17

PostPosted: Mon 04 Feb 2013, 03:22    Post subject:  sylpheed 3.2.0 in PRECISE 5.4.3 problems  

There are libraries but not available for PRECISE.

Thanks for your help and attention. Smile

Code:
# ldd sylpheed
./sylpheed: /usr/lib/i386-linux-gnu/libcrypto.so.1.0.0: no version information available (required by ./sylpheed)
./sylpheed: /usr/lib/i386-linux-gnu/libssl.so.1.0.0: no version information available (required by ./sylpheed)
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 4130
Location: World_Hub

PostPosted: Mon 04 Feb 2013, 03:51    Post subject:  

Are you installing with dependencies? You should.. Otherwise, you'll find those for Ubuntu 12.04.1 LTS here.

I now find they're in pacman as well- you've gotta looksee.. You may need libc-bin in order to run ldconfig.
Back to top
View user's profile Send private message 
hikohan

Joined: 29 Nov 2011
Posts: 17

PostPosted: Mon 04 Feb 2013, 04:16    Post subject: upgrade from RACY 5.3.90  

Sylpheed works correctly in WARY and RACY, but I don't know howto fix dependency in PRECISE.

In Puppy PRECISE PPM(package manager), sylpheed is not
avaliable.

Thanks you for helping me!! Smile
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 4130
Location: World_Hub

PostPosted: Mon 04 Feb 2013, 04:20    Post subject:  

Sure it is, so long as your repos are configured. You may have to switch around in the search window..
repo_config.jpg
 Description   
 Filesize   23.47 KB
 Viewed   254 Time(s)

repo_config.jpg

libcrypto.jpg
 Description   
 Filesize   41.74 KB
 Viewed   276 Time(s)

libcrypto.jpg

Back to top
View user's profile Send private message 
hikohan

Joined: 29 Nov 2011
Posts: 17

PostPosted: Mon 04 Feb 2013, 05:29    Post subject: add ubuntu repo then...  

Backup save(.sfs) is important before package install and recovery.

first, add repo and wait database update.

so I recovery the save.

Thanks for your help and kindness!! Smile

seems more fixes on PRECISE, before that, I can stay on WARY 5.3.90.

Thanks!!
bb1.png
Description  repo append.
png

 Download 
Filename  bb1.png 
Filesize  30.5 KB 
Downloaded  60 Time(s) 
bb2.png
 Description   wait DB update
 Filesize   18.21 KB
 Viewed   241 Time(s)

bb2.png

bb3.png
Description  seems gtk conflicts package dependency.
png

 Download 
Filename  bb3.png 
Filesize  89.56 KB 
Downloaded  68 Time(s) 
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 4130
Location: World_Hub

PostPosted: Mon 04 Feb 2013, 09:07    Post subject:  

Hikohan- see this Wink for that nasty desktop.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 672

PostPosted: Mon 04 Feb 2013, 13:36    Post subject:  

I'm back to wary and firefox 18.0.1 with the new gtkdialog 0.8.3 in common repository. In precise I installed sylpheed following this post:

http://bkhome.org/blog/?viewDetailed=02955
Back to top
View user's profile Send private message 
hikohan

Joined: 29 Nov 2011
Posts: 17

PostPosted: Mon 04 Feb 2013, 21:34    Post subject: libcrypt and gtk fault.
Subject description: back to WARY?
 

Thanks WATCHDOG, I'd try the pets but still met the same error message

Code:
# ldd sylpheed
./sylpheed: /usr/lib/i386-linux-gnu/libcrypto.so.1.0.0: no version information available (required by ./sylpheed)
./sylpheed: /usr/lib/i386-linux-gnu/libssl.so.1.0.0: no version information available (required by ./sylpheed)


I'll back to WARY for all purpose works and try PRECISE for puppy LTS upgrade.

Thanks for your kindness and patient on this thread. Smile

needs more time and fixes. Wink
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 672

PostPosted: Tue 05 Feb 2013, 01:43    Post subject: Re: libcrypt and gtk fault.
Subject description: back to WARY?
 

hikohan wrote:

Code:
# ldd sylpheed
./sylpheed: /usr/lib/i386-linux-gnu/libcrypto.so.1.0.0: no version information available (required by ./sylpheed)
./sylpheed: /usr/lib/i386-linux-gnu/libssl.so.1.0.0: no version information available (required by ./sylpheed)


needs more time and fixes. Wink


My command:

Code:
ldd sylpheed


exits with no errors on dependencies.
Checking the dependencies from Menu-Setup I have no missing dependencies.
After removing your install of sylpheed remove /root/.sylpheed and /root/Mail. Then install Barry's pets. You can now copy in /root your Mail and .sylpheed-2.0 directories from another working install of sylpheed. The Barry's pet uses still /root/.sylpheed-2.0.
Back to top
View user's profile Send private message 
hikohan

Joined: 29 Nov 2011
Posts: 17

PostPosted: Tue 05 Feb 2013, 03:03    Post subject:  need more luck, maybe  

same error when startup sylpheed.

./sylpheed: /usr/lib/i386-linux-gnu/libcrypto.so.1.0.0: no version information available (required by ./sylpheed)
./sylpheed: /usr/lib/i386-linux-gnu/libssl.so.1.0.0: no version information available (required by ./sylpheed)

attached text is dependency check by ldd sylpheed command.

nothing lost.

Anyway, thanks for your kindness and patient on this thread!!

Smile

Code:
# ldd sylpheed

./sylpheed: /usr/lib/i386-linux-gnu/libcrypto.so.1.0.0: no version information available (required by ./sylpheed)
./sylpheed: /usr/lib/i386-linux-gnu/libssl.so.1.0.0: no version information available (required by ./sylpheed)
   linux-gate.so.1 =>  (0xffffe000)
   libgmodule-2.0.so.0 => /usr/lib/i386-linux-gnu/libgmodule-2.0.so.0 (0xb77b8000)
   libssl.so.1.0.0 => /usr/lib/i386-linux-gnu/libssl.so.1.0.0 (0xb7777000)
   libcrypto.so.1.0.0 => /usr/lib/i386-linux-gnu/libcrypto.so.1.0.0 (0xb7650000)
   libgtkspell.so.0 => /usr/lib/i386-linux-gnu/libgtkspell.so.0 (0xb764a000)
   libgtk-x11-2.0.so.0 => /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0 (0xb71e2000)
   libgdk-x11-2.0.so.0 => /usr/lib/i386-linux-gnu/libgdk-x11-2.0.so.0 (0xb7133000)
   libpangocairo-1.0.so.0 => /usr/lib/i386-linux-gnu/libpangocairo-1.0.so.0 (0xb7126000)
   libgdk_pixbuf-2.0.so.0 => /usr/lib/i386-linux-gnu/libgdk_pixbuf-2.0.so.0 (0xb7104000)
   libcairo.so.2 => /usr/lib/i386-linux-gnu/libcairo.so.2 (0xb7039000)
   libpango-1.0.so.0 => /usr/lib/i386-linux-gnu/libpango-1.0.so.0 (0xb6fef000)
   libenchant.so.1 => /usr/lib/i386-linux-gnu/libenchant.so.1 (0xb6fe3000)
   libgobject-2.0.so.0 => /usr/lib/i386-linux-gnu/libgobject-2.0.so.0 (0xb6f94000)
   libpthread.so.0 => /lib/libpthread.so.0 (0xb6f78000)
   libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0xb6e7f000)
   libc.so.6 => /lib/libc.so.6 (0xb6cd5000)
   libdl.so.2 => /lib/libdl.so.2 (0xb6cd0000)
   libatk-1.0.so.0 => /usr/lib/i386-linux-gnu/libatk-1.0.so.0 (0xb6cb0000)
   libgio-2.0.so.0 => /usr/lib/i386-linux-gnu/libgio-2.0.so.0 (0xb6b58000)
   libresolv.so.2 => /lib/libresolv.so.2 (0xb6b40000)
   libpangoft2-1.0.so.0 => /usr/lib/i386-linux-gnu/libpangoft2-1.0.so.0 (0xb6b14000)
   libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xb6a2f000)
   libpixman-1.so.0 => /usr/lib/i386-linux-gnu/libpixman-1.so.0 (0xb6997000)
   libpng12.so.0 => /usr/lib/i386-linux-gnu/libpng12.so.0 (0xb696c000)
   libXrender.so.1 => /usr/X11R7/lib/libXrender.so.1 (0xb6964000)
   libX11.so.6 => /usr/X11R7/lib/libX11.so.6 (0xb6864000)
   libxcb.so.1 => /usr/X11R7/lib/libxcb.so.1 (0xb684f000)
   libXau.so.6 => /usr/X11R7/lib/libXau.so.6 (0xb684c000)
   libm.so.6 => /lib/libm.so.6 (0xb681f000)
   libfontconfig.so.1 => /usr/X11R7/lib/libfontconfig.so.1 (0xb67f7000)
   libfreetype.so.6 => /usr/lib/i386-linux-gnu/libfreetype.so.6 (0xb675d000)
   libz.so.1 => /lib/libz.so.1 (0xb6747000)
   libexpat.so.1 => /lib/libexpat.so.1 (0xb671d000)
   libgthread-2.0.so.0 => /usr/lib/i386-linux-gnu/libgthread-2.0.so.0 (0xb6719000)
   librt.so.1 => /lib/librt.so.1 (0xb6710000)
   libXfixes.so.3 => /usr/lib/i386-linux-gnu/libXfixes.so.3 (0xb670a000)
   libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xb66f8000)
   libXinerama.so.1 => /usr/lib/i386-linux-gnu/libXinerama.so.1 (0xb66f4000)
   libXi.so.6 => /usr/lib/i386-linux-gnu/libXi.so.6 (0xb66e3000)
   libXrandr.so.2 => /usr/lib/i386-linux-gnu/libXrandr.so.2 (0xb66da000)
   libXcursor.so.1 => /usr/lib/i386-linux-gnu/libXcursor.so.1 (0xb66cf000)
   libXcomposite.so.1 => /usr/lib/i386-linux-gnu/libXcomposite.so.1 (0xb66cb000)
   libXdamage.so.1 => /usr/lib/i386-linux-gnu/libXdamage.so.1 (0xb66c7000)
   libxcb-shm.so.0 => /usr/lib/i386-linux-gnu/libxcb-shm.so.0 (0xb66c2000)
   libxcb-render.so.0 => /usr/lib/i386-linux-gnu/libxcb-render.so.0 (0xb66b8000)
   libffi.so.6 => /usr/lib/i386-linux-gnu/libffi.so.6 (0xb66b1000)
   /lib/ld-linux.so.2 (0xb77bf000)
   libpcre.so.3 => /lib/libpcre.so.3 (0xb6675000)
   libselinux.so.1 => /lib/libselinux.so.1 (0xb6656000)
   libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb6637000)

# ls -l /usr/lib/i386-linux-gnu/libcrypto.so.1.0.0
-r-xr-xr-x 1 root root 1188328  4月  4  2012 /usr/lib/i386-linux-gnu/libcrypto.so.1.0.0
# ls -l /usr/lib/i386-linux-gnu/libssl.so.1.0.0
-r-xr-xr-x 1 root root 266576  4月  4  2012 /usr/lib/i386-linux-gnu/libssl.so.1.0.0
[/code]
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 4130
Location: World_Hub

PostPosted: Tue 05 Feb 2013, 07:29    Post subject:  

Install those two from the repo <they're there> and run ldconfig after they're in..

HOLD ON! Ya know maybe they are there and Sylpheed, for whatever reason, doesn't see'm. With Pfind, search your system for these, I'll bet they're there: libcrypto.so.1 and libssl.so.1.

Furthermore- *which* did you install?
be_specific.jpg
 Description   
 Filesize   20.38 KB
 Viewed   169 Time(s)

be_specific.jpg

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0836s ][ Queries: 13 (0.0061s) ][ GZIP on ]