Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 03:10
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to get MUT running in Macpup 5.2.8? (SOLVED)
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Mercedes350se

Joined: 16 Apr 2008
Posts: 633

PostPosted: Fri 01 Feb 2013, 21:26    Post_subject:  How to get MUT running in Macpup 5.2.8? (SOLVED)
Sub_title: I did a frugal install of 5.2.8
 

Personal preference - I hate pmount.

I would like to get MUT running.

I have copied the files across to /usr/lib/mut from my 3.01 LiveCD.

I have set up the desktop information in /usr/share/applications the same as in 3.01 but it does not appear to run.

If I type mut in the console I only get the drive types, capacities and the number of partitions shown in the console.

Edited_times_total
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3938
Location: World_Hub

PostPosted: Sat 02 Feb 2013, 18:18    Post_subject:  

This MUt, or, that a typo? Turn your Ubuntu repos on and two versions of the latter are there.

I'd get rid of what'cha copied first. MacPup *includes* a menu maker.
mutt_1.5.jpg
 Description   
 Filesize   108.82 KB
 Viewed   247 Time(s)

mutt_1.5.jpg

Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 633

PostPosted: Sat 02 Feb 2013, 20:14    Post_subject:  

MUT as in Mount Unmount Tool is what I want to install.
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3938
Location: World_Hub

PostPosted: Sat 02 Feb 2013, 22:00    Post_subject:  

http://hardkap.net/forums/topic/macpup-525#post-2256

http://hardkap.net/forums/topic/macpup-525#post-2329

To be honest, run the vanilla 5.28 if it isn't too heavy..
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 633

PostPosted: Mon 04 Feb 2013, 20:15    Post_subject:  

Progress - well sort of.

I find that if I click on /usr/lib/mut/disks.tcl MUT opens and works as expected albeit much slower than in 3.01.

However if I try to run it from within the menu but trying to fake it that it is in the console i.e.

exec /usr/bin/urxvt -e disks.tcl (in the desktop setup)

nothing happens.

Similarly if I try to create a desktop icon using the same parameters nothing happens - to be expected really!

Any ideas?
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6687
Location: lisbon

PostPosted: Mon 04 Feb 2013, 22:49    Post_subject:  

I installed mut-29dec06.pet, and it definitely works from the menu of macpup-528...that is with the tcl_tk_games.sfs sfs_loaded as mentioned in your freecell thread.
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 633

PostPosted: Mon 04 Feb 2013, 23:10    Post_subject:  

Thank you. Where/how did you find the .pet?
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6687
Location: lisbon

PostPosted: Mon 04 Feb 2013, 23:21    Post_subject:  

From puppy v3 ibiblio repository...here.
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 633

PostPosted: Tue 05 Feb 2013, 19:09    Post_subject:  

Page is now bookmarked.

Thank you.

If I run "mut" from the console I get:

sh-4.1# mut
Application initialization failed: Can't find a usable tk.tcl in the following directories:
/usr/lib/tcl8.5/tk8.5 /usr/lib/tk8.5 /lib/tk8.5 /usr/library

/usr/lib/tk8.5/tk.tcl: invalid command name "ttk::style"
invalid command name "ttk::style"
while executing
"ttk::style theme settings default {

ttk::style configure "." -borderwidth 1 -background $colors(-frame) -foreground black -troughcolor $colo..."
(in namespace eval "::ttk::theme::default" script line 14)
invoked from within
"namespace eval ttk::theme::default {
variable colors
array set colors {
-frame "#d9d9d9"
-window "#ffffff"
-activebg "#ececec"
-selectbg..."
(file "/usr/lib/tk8.5/ttk/defaults.tcl" line 7)
invoked from within
"source /usr/lib/tk8.5/ttk/defaults.tcl"
("uplevel" body line 1)
invoked from within
"uplevel #0 [list source [file join $library defaults.tcl]] "
(procedure "ttk::LoadThemes" line 5)
invoked from within
"ttk::LoadThemes"
(file "/usr/lib/tk8.5/ttk/ttk.tcl" line 140)
invoked from within
"source /usr/lib/tk8.5/ttk/ttk.tcl"
("uplevel" body line 1)
invoked from within
"uplevel \#0 [list source $::ttk::library/ttk.tcl]"
invoked from within
"if {$::ttk::library ne ""} {
uplevel \#0 [list source $::ttk::library/ttk.tcl]
}"
(file "/usr/lib/tk8.5/tk.tcl" line 599)
invoked from within
"source /usr/lib/tk8.5/tk.tcl"
("uplevel" body line 1)
invoked from within
"uplevel #0 [list source $file]"


This probably means that tk wasn't installed properly.
Back to top
View user's profile Send_private_message 
ICPUG

Joined: 24 Jul 2005
Posts: 1290
Location: UK

PostPosted: Wed 06 Feb 2013, 08:47    Post_subject:  

I used to prefer MU's MUT too.

However, it is coded in tcl/tk so requires that to be part of the Puppy if MUT is to run. I think tcl/tk went out of favour with devs around 4.x although Whodo put it back into the very excellent 4.3.1.
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 633

PostPosted: Thu 07 Feb 2013, 00:20    Post_subject:  

@ICPUG, Something to keep in mind.

Thank you.
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 633

PostPosted: Thu 07 Feb 2013, 17:26    Post_subject:  

ICPUG wrote:
... Whodo put it back into the very excellent 4.3.1.


Not in the 4.3.1 I downloaded. Still haven't ironed out some of the issues but freecell (subject of another thread) and MUT work in it as expected - after some effort.

I am surprised to see that CPU use is a lot higher than 3.01.
Back to top
View user's profile Send_private_message 
ICPUG

Joined: 24 Jul 2005
Posts: 1290
Location: UK

PostPosted: Fri 08 Feb 2013, 08:15    Post_subject:  

Sorry Mercedes350se - it was 4.2.1 NOT 4.3.1 that Whodo created with TCL/TK. Just reading another thread triggerred my recognition of the mistake.

Note that 4.2.1 had a lot more bling than some people liked - but it had a lot of other good things too.

That was a bit of a slip because 4.3.1 was back in Barry's hands and I was none too happy at the time because some of the good things of 4.2.1 had gone! I think the MUT in 4.3.1 is a development of MU's MUT. I seem to recall PMount having the ability to work in native mode or use the MUT engine but this is a long time ago so my memory may have faded - hence my quoting an incorrect version number of Whodo's masterpiece!
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 633

PostPosted: Sat 09 Feb 2013, 01:39    Post_subject:  

No worries!

A few minutes download, a few minutes CD burn and another Puppy to try.

I should add that both freecell and MUT installed and work (in 4.3.1).
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 633

PostPosted: Sun 10 Feb 2013, 03:56    Post_subject:  

Another few minutes here and there and a frugal install of the "vanilla" 5.2.8 and it works.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0778s ][ Queries: 13 (0.0133s) ][ GZIP on ]