Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Sep 2014, 06:27
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
ArchPup - First Puppy with pacman for installing apps
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 17 of 17 [247 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17
Author Message
mavrothal


Joined: 24 Aug 2009
Posts: 1633

PostPosted: Tue 05 Feb 2013, 00:59    Post subject:  

"xrandr -s NNNNxNNN" works at my end as long as you pick one of the available resolutions (typing only "xrandr" will give you a list of them).

If is not working see what /var/log/Xorg.0.log reports and the driver is using.
Code:
cat /var/log/Xorg.0.log | grep EE # will show you the errors
cat /var/log/Xorg.0.log | grep Loading | grep drivers # will tell the video driver


You may also try to force your resolution by adding in /etc/X11/xorg.cong something like
Code:
Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 24
   Subsection "Display"
      Depth       24
      Modes       "1366x768"
   EndSubsection
EndSection

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
stifiling

Joined: 29 Dec 2007
Posts: 388

PostPosted: Tue 05 Feb 2013, 07:12    Post subject:  

is the kernel source available? if not that's a huge issue. u can't install virtualbox without it.

if the kernel source isn't available, i'm thinking we should remaster the main.sfs with a different kernel, that has the source available. retroprecise's non-pae kernel 3.2.32 has been working just fine for me......

Last edited by stifiling on Tue 05 Feb 2013, 07:17; edited 1 time in total
Back to top
View user's profile Send private message 
stifiling

Joined: 29 Dec 2007
Posts: 388

PostPosted: Tue 05 Feb 2013, 07:16    Post subject:  

error post
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 1633

PostPosted: Tue 05 Feb 2013, 09:52    Post subject:  

stifiling wrote:
is the kernel source available? if not that's a huge issue. u can't install virtualbox without it.

Are you sure about that? I do not use VB but unless you need to compile an in-tree module you do not need the source.
Usually you need the headers to compile and these are available in devx.
Anyway, from what I can see the source is vanilla 3.4.28 patched with aufs but I do think simargl should provide it.
I'll ask and we'll see.

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
stifiling

Joined: 29 Dec 2007
Posts: 388

PostPosted: Tue 05 Feb 2013, 11:39    Post subject:  

i may be wrong. i thought the kernel src was needed though to compile vboxdrv.ko vboxnetadp.ko vboxnetflt.ko and vboxpci.ko
Back to top
View user's profile Send private message 
rameshiyer

Joined: 17 Sep 2009
Posts: 232
Location: Calicut, Kerala, India

PostPosted: Fri 08 Feb 2013, 11:29    Post subject: Archpupy 13.2
Subject description: not updating
 

I am just asking with academic interest. Why this warning or problem while updating with pacman?

[root@archpup ~]# pacman -Syu
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
warning: linux: ignoring package upgrade (3.4.28-1 => 3.7.5-1)
warning: linux-api-headers: ignoring package upgrade (3.4.28-1 => 3.7.4-1)
warning: pango: ignoring package upgrade (1.30.1-1 => 1.32.5-1)
warning: ignoring package replacement (udev-175-1 => systemd-197-4)
there is nothing to do
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger 
simargl8

Joined: 06 Feb 2013
Posts: 65

PostPosted: Fri 08 Feb 2013, 11:52    Post subject: Re: Archpupy 13.2
Subject description: not updating
 

rameshiyer wrote:
I am just asking with academic interest. Why this warning or problem while updating with pacman?

[root@archpup ~]# pacman -Syu
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
warning: linux: ignoring package upgrade (3.4.28-1 => 3.7.5-1)
warning: linux-api-headers: ignoring package upgrade (3.4.28-1 => 3.7.4-1)
warning: pango: ignoring package upgrade (1.30.1-1 => 1.32.5-1)
warning: ignoring package replacement (udev-175-1 => systemd-197-4)
there is nothing to do

That's because I recompiled those packages with various reasons using older versions than
in original Arch. To prevent pacman overwriting them, they are in IgnorePkg list in /etc/pacman.conf.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 17 of 17 [247 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0660s ][ Queries: 13 (0.0112s) ][ GZIP on ]