Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Jul 2015, 19:23
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Problem logging in to wifi hotspot (Solved)
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 07 Feb 2013
Posts: 30
Location: Manchester, England

PostPosted: Fri 08 Feb 2013, 08:32    Post_subject:  Problem logging in to wifi hotspot (Solved)  

hi Friends,

I wonder if anyone can help me with this.

I have a Precise Puppy 5.4.3 installed on a USB flash drive. I used the "Douglas" software to connect to wifi.

When I try to connect in McDonalds to their free wifi, it works if and only if I have previously connected from another version of Linux within the previous few hours.

Here is how it works from Firefox or Chrome in Ubuntu:

McD wifi is "open", ie un-encrypted, but like a lot of wifi cafes they trap the first page you open in the browser and ask you to log in. Once you have done this it becomes automatic, You ask for (say) Google and you get a McD page saying "welcome back". Thereafter that day, you do not even get that.

Clearly the local router is remembering the MAC address of my wifi card, because having once connected from Firefox, it goes straight in when using a different browser, or even from a different Operating system, So it can't be cookies.

Now, once it has connected from Ubuntu, it will connect from Seamonkey in Puppy. The wifi connection is up and running in Puppy when I boot, so it does not seem to be a wifi config issue.

But, first time in the day, Seamonkey says it cannot locate the server. Obviously DNS lookup is failing somehow. Yet it works fine for a few hours if I have "pre-registered" from ubuntu.

Any ideas how to fix this? What is missing?

Is it possible that Seamonkey does not offer something that the handshaking requires? Should I try installing Firefox or Chrome on Puppy?

If I have to load Ubuntu before I use Puppy every time I want to work in an internet cafe, I might as well stay in Ubuntu and check my mail there. I wanted to use Puppy for this (ahem) precisely because it is so fast...

Back to top
View user's profile Send_private_message 

Joined: 28 Sep 2012
Posts: 813

PostPosted: Fri 08 Feb 2013, 15:15    Post_subject:  

Do you do "Auto DHCP"? Click "Connect" and choose classic Kauler-Douglas Puppy Network Wizard, click your wireless connection "wlan0" (or "eth1"), click "Wireless", click "Scan" to find the network, configure it: if the network is open you don't have to set a password, click "Save profile", click "Use this profile", click "Auto DHCP". Open now Seamonkey.
Back to top
View user's profile Send_private_message 

Joined: 07 Feb 2013
Posts: 30
Location: Manchester, England

PostPosted: Fri 08 Feb 2013, 16:41    Post_subject:  

hi watchdog

yes, I have done all that, and it works if I was already on the wifi using ubuntu, and it fails if I wasn't on the wifi earlier. So I figure it is not a wifi config problem, but a problem triggered by the way McDonalds ask people to log in.

Let me spell this out a bit more.

If I do exactly the same boot up process with Puppy on the laptop within an hour or so of connecting the wifi works, and it all happens automatically, even without me repeating the commands that watchdog mentions.

But, if it is a day or so since I connected at the same cafe, the network reports that it is connected, but whatever url I type into Seamonkey cannot be found. And it still cannot be found if I repeat all the commands watchdog mentions again, even though all those commands report success.

When connectinmg for the first time in the day from Ubuntu, the first page you try to get in Firefox (whatever the url) goes instead to the McDonalds login page.

It is this re-direction that is failing to happen when the first connection is done under Puppy.

Is Seamomkey capable of understanding a redirection reply? Maybe it regards a redirect as a fail?

Does Puppy only open a firewall after a successful connection or something like that?

This is confusing....

If I do not get any suggestions soon, I will try to install firefox, to see if it is the difference between firefox and seamonkey that is revealing the problem, or the difference between the Puppy wifi and the Ubuntu wifi.

But first, has anyone got any better ideas for moving towards an understanding of what is going wrong here?

Back to top
View user's profile Send_private_message 

Joined: 29 Jan 2006
Posts: 3629
Location: Sydney Australia

PostPosted: Sat 09 Feb 2013, 06:00    Post_subject:  

Better off with Frisbee.


Frisbee for Precise is in my post.

Back to top
View user's profile Send_private_message 

Joined: 11 Oct 2008
Posts: 7956
Location: qld

PostPosted: Sat 09 Feb 2013, 06:16    Post_subject:  

Firstly, all routers are designed to remember MAC addresses and assign "leases" to them for a period of time. They keep them in the "routing table".

Secondly, run ifconfig wlan0 and check your IP address, if it is 169.xx.xx.xx you are getting the default address which indicates failure. You would expect it to begin with 10.xx.xx.xx or 192.xx.xx.xx. If your IP address appears sane then proceed,,

Third, try to ping an external address such as sourceforge.net, pupylinux.com, or whatever.
ping -c4
(that's google by the way, you can use url or IP address). You would expect 100% packet return if you are connected. When that works..

Fourth, try to browse.


Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 

Joined: 24 Feb 2007
Posts: 440
Location: Green Island Cairns for the winter

PostPosted: Sun 10 Feb 2013, 04:54    Post_subject:  

I have a couple of WiFi adaptors TP-Link and Digitech. Small ones with the same guts in them . They use an rtl8172cu driver that did not work straight up from Puppy precise 5.4.2. I got another driver with the kind help of Pemasu ,and they were then able to connect .

However I get similar problems to you in that they connect to the WiFi router OK , run fine for a while then suddenly they can't find the server. If I disconnect and try to reconnect they don't even find the router .

In my case to fix this I must reboot the router. It happens a couple of times a day and does not seem to be a regular period of time that might be associated to lease times granted. I think the clue is that once disconnected you can't find the router again without a reboot. Looking at the logs shows a lot of dropped packets

I'm suspecting it might be a Router problem. mine is a D-Link . I tried cutting the power output to 50% and gave it a couple of good cleans inside to no avail.

Maybe you have something similar happening . Dont like your chances of a reboot though to test it.

Neither my Family nor my Property are Government issues. Governments should do what they were designed to do Manage the larger issues best done by Governments
To stop corruption give them 3 times the penalty. Get their agreement on first employment.
Back to top
View user's profile Send_private_message 

Joined: 07 Feb 2013
Posts: 30
Location: Manchester, England

PostPosted: Sun 10 Feb 2013, 09:30    Post_subject:  

@01micko @tytower @watchdog @cthisbear

Thanks for helpful suggestions, which turned out to be unnecessary - but are gratefully accepted in the spirit they were offered.

The problem seems to have gone away without my doing anything. My best guess, now, is that tytower was right and it was an issue in the router (which belongs to McDonalds and so is outside my control).

If this issue arises again I will be less likely to blame Puppy - but you'll understand that when something doesn't work the first time you are using a new distro that is where the finger tends to point...

The site I usually ping is www.whitehouse.gov (as that is one of the most always-up sites on the net). Using is a new one to me - I will remember that.

A couple of responses to specific suggestions:


The site I usually ping by name is www.whitehouse.gov (as that is one of the most always-up sites on the net). Using is a new one to me - I will remember that.

Some readers may wonder why it is useful to have a mix of numeric and named ping addresses - that because if the numeric ping works and the ping by name fails, it suggests DNS as the next place to look for issues.


thanks for the suggestion about frisbee - it is a useful alternative to the standard wifi software that comes with Puppy. I tried it anyway, even though the issue had resolved itself by then.

It was also, as it happens, my very first pet install, so I learnt something from doing that successfully.

I like the way it tells you what it is doing as it connects and so on.

Would it have solved the problem I was having the other day? Who knows - impossible to check now. But I will be using it in the future in any case. So something good came out of this problem Smile

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0676s ][ Queries: 12 (0.0041s) ][ GZIP on ]