Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 17:01
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Install games and place in Menu > Fun
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
highway_man

Joined: 06 Feb 2013
Posts: 15

PostPosted: Sun 10 Feb 2013, 23:07    Post_subject:  Install games and place in Menu > Fun
Sub_title: Running PET, TGZ, PUP files (and others)
 

Reference files are located here. Not required to answer e-mail.
http://www.brighthub.com/computing/linux/articles/36351.aspx
http://fph.altervista.org/prog/bastet.html
http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/TBS/Gweled-3449.shtml

Added: Precise 5.4.2 (frugal) on AMD Athalon XP Processor 3000+ 798MHz 513Mb RAM

I am trying to install Galaga, Zaxxon, Bastet, and Gweled on Puppy Linux, but I don't know the next step(s) to take.

Galaga & Gweled extensions are TAR.GZ
Bastet extension is TGZ
Zaxxon extension is PUP

I have downloaded these and managed to place the in My Documents in Puppy Linux. Now the big question...How do I install and run these files?

TAR.GZ both appear to be zipped C/C++ files only because main.c is among the list. Now mind you, I only know enough to be dangerous. I have heard that Puppy might be fussy about where and how directories are structured. Any hints in that department will be well received.

Now...on to TGZ. It (Bastet-0.41) shows up in my Puppy Package Manager as an installed package. What is a TGZ file exctly? More importantly, how do I run it?
NOTE: Console -> # fixmenus didn't help

PUP files, according to the error message, are older PET files. I get the following error:
Quote:
PUP packages are an older package system superceded by PET packages. If you want to install a DotPup package, you must first run the PETget package manager (see install icon on desktop) and install the 'dodpuphandler' and 'puppybasic' PET packages.

When I go Install on my Desktop, I do not see PETget package manager. I didn't see it in the menu either - I looked, but could have missed it.
I also checked Puppy Package Manager for the 2 PET packages. I couldn't find those either.

SO...Any help to run any of these is much appreciated. I would also like to organize the icon(s) in the Menu > Fun location.
Thanks in advance.

Edited_time_total
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4138
Location: World_Hub

PostPosted: Mon 11 Feb 2013, 00:08    Post_subject:  

Without having to search- your Pup of choice?
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Mon 11 Feb 2013, 05:19    Post_subject:  

Here's a link for zaxxonrr repackaged as a pet:

http://205.196.123.14/t7h49zu4rehg/y1748avpmqb9wni/zaxxonrr-0.4.125.pet
Back to top
View user's profile Send_private_message 
Makoto


Joined: 03 Sep 2009
Posts: 1820
Location: Out wandering... maybe.

PostPosted: Mon 11 Feb 2013, 05:42    Post_subject:  

.tgz archives are .tar.gz archives, just with a shorter extension.

Keep in mind that while .tar.gz archives are often source code archives, in my experience, they can, technically, hold anything - you'll find tar.gz/tgz archives out there containing compiled binaries, too.

Even though your package manager might have 'installed' the .tgz, it might still have been a source code archive, and the package manager just placed the source code files somewhere. Unfortunately, if the site or server you download the files from doesn't tell you whether or not it's a source code archive, the only way to tell is to browse the files within the archive.

Hope this helps, somewhat. I do tend to ramble. Smile

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4138
Location: World_Hub

PostPosted: Mon 11 Feb 2013, 07:10    Post_subject:  

One more thing to keep in mind.. Pkgs *outside* the repo are generally a crapshoot.
Back to top
View user's profile Send_private_message 
Mercedes350se

Joined: 16 Apr 2008
Posts: 658

PostPosted: Sun 17 Feb 2013, 00:30    Post_subject: Re: Install games and place in Menu > Fun
Sub_title: Running PET, TGZ, PUP files (and others)
 

highway_man wrote:

Quote:
PUP packages are an older package system superceded by PET packages. If you want to install a DotPup package, you must first run the PETget package manager (see install icon on desktop) and install the 'dotpuphandler' and 'puppybasic' PET packages.



Both pets are available here (Note the corrected name of one)

http://distro.ibiblio.org/puppylinux/pet_packages-3/. They are for puppy version 3 but should work.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0542s ][ Queries: 12 (0.0031s) ][ GZIP on ]