Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 11:14
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
pMusic 4.4.6
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 106 of 125 Posts_count   Goto page: Previous 1, 2, 3, ..., 104, 105, 106, 107, 108, ..., 123, 124, 125 Next
Author Message
sheldonisaac

Joined: 21 Jun 2009
Posts: 434
Location: Philadelphia, PA

PostPosted: Sun 10 Feb 2013, 16:12    Post_subject: Re: radio stations  

zigbert wrote:
sheldonisaac wrote:
Could this be a problem with the gtkdialog in Lucid Puppy 5.5.8??
pMusic includes a dependency checker. Either from the help-menu or by executing
Code:
pmusic -D

Sigmund

Thank you, Sigmund. Of course, I had typoed above - it's
Lucid Puppy 5.2.8 - Updated ISO Version 005 - APR 05 2012

Somehow a day or two ago, flashplyer no longer worked, and eventually I started with a fresh Lucid Puppy.

I think that may be when the problem with updating rhe radio stations started.

Is there a foolproof way to set up all the dependencies etc for Pmusic?

Code:
~> pmusic -D
GTKDIALOG is gtkdialog
  R E Q U I R E D                           
    bash                                      [OK]
    coreutils, awk, sed, diff                 [OK]
    gtkdialog                        >= 0.8.3 [OK]
    ffmpeg                           >= 0.11  [??]
    aplay  (alsa)                             [OK]

  R E C O M M E N D E D                     
    streamripper (extended radio-rip/play)    [OK]
    cdda2wav     (play/rip audio-CD)          [OK]
    wget         (connection to www)          [OK]

  O P T I O N A L                           
    pBurn        (burning audio-CD)           [OK]
    pFilesearch  (File-search engine) >= 1.28 [OK]
    pSchedule    (podcast managing)   >= 1.12 [MISSING]
    pEqualizer   (10 band equalizer)          [MISSING]

Code:

ffmpeg version 0.8.12, Copyright (c) 2000-2011 the FFmpeg developers
  built on Jul 25 2012 04:52:58 with gcc 4.3.4


Code:
gtkdialog version 0.8.3 r478M (C) 2003-2007 Laszlo Pere, 2011-2012 Thunor
Built with additional support for: Glade, VTE.
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5788
Location: Valåmoen, Norway

PostPosted: Sun 10 Feb 2013, 17:58    Post_subject:  

sheldonisaac
It seems that your dependencies are a bit old.

Your ffmpeg is old, but I don't think that should do any harm for playback. pMusic benefits of later ffmpeg when it comes to embedding av albumart into the audio file.

Worse is the gtkdialog built from svn. This is not the official 0.8.3 version, but a prebuild. You will meet problems of the very latest gui improvements in pMusic as the export window and the save box....


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Sun 10 Feb 2013, 18:28    Post_subject:  

zigbert wrote:


Worse is the gtkdialog built from svn. This is not the official 0.8.3 version, but a prebuild. You will meet problems of the very latest gui improvements in pMusic as the export window and the save box....


Sigmund


That's where I get my updates...it's currently 0.8.4. Your saying there are problems with it?
Back to top
View user's profile Send_private_message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 434
Location: Philadelphia, PA

PostPosted: Sun 10 Feb 2013, 18:48    Post_subject: LuPu problems with ffmpeg and gtkdialog  

zigbert wrote:
sheldonisaac
It seems that your dependencies are a bit old.

Your ffmpeg is old, but I don't think that should do any harm for playback. pMusic benefits of later ffmpeg when it comes to embedding av albumart into the audio file.

Worse is the gtkdialog built from svn. This is not the official 0.8.3 version, but a prebuild. You will meet problems of the very latest gui improvements in pMusic as the export window and the save box....

Thanks, Sigmund.

I hope someone can direct me to the appropriate ffmpeg and gtkdialog, or where to ask for them.

I don't see many recent posts in the forum thread for LuPu 5.2.8, but will try asking there, after a while.

I have SolidPup 5.1.1-B Lite, 'lina-lite, and racy-5.3-BABYbarebones

Possibly the ffmpeg and gtkdialog from one or another would work with Lucid Puppy 528.
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5788
Location: Valåmoen, Norway

PostPosted: Mon 11 Feb 2013, 03:43    Post_subject:  

jpeps wrote:
That's where I get my updates...it's currently 0.8.4. Your saying there are problems with it?
Not at all. It is only problematic if you compiled gtkdialog from svn BEFORE the OFFICIAL release of 0.8.3.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Mon 11 Feb 2013, 03:51    Post_subject:  

zigbert wrote:
jpeps wrote:
That's where I get my updates...it's currently 0.8.4. Your saying there are problems with it?
Not at all. It is only problematic if you compiled gtkdialog from svn BEFORE the OFFICIAL release of 0.8.3.


Sigmund


Good news, thanks
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5788
Location: Valåmoen, Norway

PostPosted: Mon 11 Feb 2013, 17:36    Post_subject:  

I have been looking at a possible solution for an improved audio mixer.
Of course, this could look like whatever, but I have some limitations in my approach.
- I don't want to add more graphical bloat than highly required. This solution makes it possible to get rid of the balance-icon.... +1
- I want the Volume/Balance to be clearly separated from the equalizer.
- It would be great if it works with global GTK theme.
- The width should fit into the same size as the playlist for (optional) future docking. This made me narrow the pEqualizer gui a bit. Do you (Mick) find this troublesome?
- There should probably also be a link (button) to hardware settings in the preferences.

You might think that this should have been a part of pEqualizer, but since it has very specific dependencies, we must at least think twice.

Suggestions are very welcome


_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5788
Location: Valåmoen, Norway

PostPosted: Mon 11 Feb 2013, 19:02    Post_subject:  

Version 3.1.5
See main post

Changelog
- Bugfix: OK-box won't show if containing extended text-string.

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
666philb


Joined: 07 Feb 2010
Posts: 1882
Location: wales

PostPosted: Tue 12 Feb 2013, 13:51    Post_subject:  

hi zigbert,

the music transit bar isn't working properly in precise puppy. it scrolls to then end within a few seconds and then stays there.

the song in the picture has just started playing and the bar is at the end


_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5788
Location: Valåmoen, Norway

PostPosted: Tue 12 Feb 2013, 17:25    Post_subject:  

666philb
That pic doesn't look good Smile

Is this the latest alpha of precise?
Does the song continue to play after reaching the end of the bar?
What version of pMusic?
What is the output of
Code:
pmusic -D

What is the output of
Code:
ffmpeg -version



Thank you for reporting
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
666philb


Joined: 07 Feb 2010
Posts: 1882
Location: wales

PostPosted: Tue 12 Feb 2013, 17:41    Post_subject:  

Very Happy
hi sigmund ,

the music still continues to play when the bar gets to the end
this is happening in both precise 5.4.3 and the precise alpha, with both these pmusic versions 3.1.3 & 3.1.5

Code:
# 3.1.3
# pmusic -D
  R E Q U I R E D                           
    bash                                      [OK]
    coreutils, awk, sed, diff                 [OK]
    gtkdialog                        >= 0.8.3 [OK]
    ffmpeg                           >= 0.11  [??]
    aplay  (alsa)                             [OK]

  R E C O M M E N D E D                     
    streamripper (extended radio-rip/play)    [OK]
    cdda2wav     (play/rip audio-CD)          [OK]
    wget         (connection to www)          [OK]

  O P T I O N A L                           
    pBurn        (burning audio-CD)           [OK]
    pFilesearch  (File-search engine) >= 1.28 [OK]
    pSchedule    (podcast managing)   >= 1.12 [OK]
    pEqualizer   (10 band equalizer)          [OK]

# ffmpeg -version
ffmpeg version 0.8.5-4:0.8.5-0ubuntu0.12.04.1, Copyright (c) 2000-2012 the Libav developers
  built on Jan 24 2013 18:03:14 with gcc 4.6.3
*** THIS PROGRAM IS DEPRECATED ***
This program is only provided for compatibility and will be removed in a future release. Please use avconv instead.
ffmpeg 0.8.5-4:0.8.5-0ubuntu0.12.04.1
libavutil    51. 22. 1 / 51. 22. 1
libavcodec   53. 35. 0 / 53. 35. 0
libavformat  53. 21. 1 / 53. 21. 1
libavdevice  53.  2. 0 / 53.  2. 0
libavfilter   2. 15. 0 /  2. 15. 0
libswscale    2.  1. 0 /  2.  1. 0
libpostproc  52.  0. 0 / 52.  0. 0
#

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Tue 12 Feb 2013, 17:53    Post_subject:  

Ah the "libav" fork. Lots of distros seem to be adopting it. One would think though that Ubuntu has the real ffmpeg in their repositories, but probably not the main ones.
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5788
Location: Valåmoen, Norway

PostPosted: Tue 12 Feb 2013, 18:41    Post_subject:  

Has Barry stated that he is moving from ffmpeg to libav?
It sounds like a bad idea without verifying FFConvert, Pavrecord, Precord, pBurn, pdvdrsab and pMusic.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Tue 12 Feb 2013, 20:49    Post_subject:  

zigbert wrote:
Has Barry stated that he is moving from ffmpeg to libav?
It sounds like a bad idea without verifying FFConvert, Pavrecord, Precord, pBurn, pdvdrsab and pMusic.


Sigmund


Hopefully, they'd just require a name change. Another vote for static apps Smile
Back to top
View user's profile Send_private_message 
OscarTalks

Joined: 05 Feb 2012
Posts: 926
Location: London, England

PostPosted: Tue 12 Feb 2013, 20:53    Post_subject:  

Sigmund,

I may have got this wrong, but in the case of Precise Puppy I think he already has changed from ffmpeg to libav project if he has used the official Ubuntu packages.

Are the official Ubuntu Precise packages of the libav*.so libs not compiled from the source package of libav version 0.8.5? I think they may be. Easy not to realise that they are not compiled from ffmpeg source code because they have all the same names and may even be compatible. All the avconv bins are there (avplay instead of ffplay etc) and the "courtesy" ffmpeg bin.

Development of ffmpeg seems a mess just lately with new major versions with broken backward compatibilty. Some of the apps I like to use now won't compile against newer ffmpegs so I understand why distros are switching to the libav project. Nice that someone is providing stability.

Debian Wheezy looks like it has gone libav project too by the way.

_________________
Oscar in England

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 106 of 125 Posts_count   Goto page: Previous 1, 2, 3, ..., 104, 105, 106, 107, 108, ..., 123, 124, 125 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1340s ][ Queries: 13 (0.0314s) ][ GZIP on ]