Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 11:29
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
All browsers are broken
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Thu 14 Feb 2013, 14:08    Post_subject:  All browsers are broken
Sub_title: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found
 

Well, something went wrong, and all my browsers broke. I ran Chromium and Seamonkey via command-line, and here's what I got:

Code:
# chromium
/opt/chromium/chrome: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /opt/chromium/chrome)
/opt/chromium/chrome: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found (required by /opt/chromium/chrome)
# ldd /opt/chromium/chrome
/opt/chromium/chrome: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /opt/chromium/chrome)
/opt/chromium/chrome: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found (required by /opt/chromium/chrome)
   linux-gate.so.1 =>  (0xffffe000)
   libX11.so.6 => /usr/lib/libX11.so.6 (0xb279b000)
   libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb2792000)
   libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb2787000)
   libXss.so.1 => /usr/lib/libXss.so.1 (0xb2783000)
   libXext.so.6 => /usr/lib/libXext.so.6 (0xb2771000)
   librt.so.1 => /lib/librt.so.1 (0xb2768000)
   libdl.so.2 => /lib/libdl.so.2 (0xb2763000)
   libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb2714000)
   libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb2710000)
   libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0xb2617000)
   libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb21af000)
   libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb2100000)
   libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb20e0000)
   libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb20be000)
   libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb20b1000)
   libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb1fe6000)
   libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb1f9c000)
   libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb1f02000)
   libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb1ecd000)
   libnss3.so => /usr/lib/libnss3.so (0xb1da3000)
   libnssutil3.so => /usr/lib/libnssutil3.so (0xb1d85000)
   libsmime3.so => /usr/lib/libsmime3.so (0xb1d5b000)
   libplc4.so => /usr/lib/libplc4.so (0xb1d55000)
   libnspr4.so => /usr/lib/libnspr4.so (0xb1d17000)
   libpthread.so.0 => /lib/libpthread.so.0 (0xb1cfb000)
   libgconf-2.so.4 => /usr/lib/libgconf-2.so.4 (0xb1ccd000)
   libdbus-1.so.3 => /lib/libdbus-1.so.3 (0xb1c84000)
   libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xb1c80000)
   libasound.so.2 => /usr/lib/libasound.so.2 (0xb1b8e000)
   libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb1b89000)
   libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb1b83000)
   libcups.so.2 => /usr/lib/libcups.so.2 (0xb1b45000)
   libgcrypt.so.11 => /lib/libgcrypt.so.11 (0xb1ac0000)
   libbz2.so.1.0 => /lib/libbz2.so.1.0 (0xb1aaf000)
   libexpat.so.1 => /lib/libexpat.so.1 (0xb1a85000)
   libudev.so.0 => /lib/libudev.so.0 (0xb1a77000)
   libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb1991000)
   libm.so.6 => /lib/libm.so.6 (0xb1965000)
   libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb1947000)
   libc.so.6 => /lib/libc.so.6 (0xb179d000)
   /lib/ld-linux.so.2 (0xb77a2000)
   libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb177c000)
   libffi.so.6 => /usr/lib/libffi.so.6 (0xb1774000)
   libpcre.so.3 => /lib/libpcre.so.3 (0xb1738000)
   libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xb15e1000)
   libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb15b5000)
   libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb15b1000)
   libXi.so.6 => /usr/lib/libXi.so.6 (0xb15a0000)
   libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb1595000)
   libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb1590000)
   libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb14f8000)
   libpng12.so.0 => /lib/libpng12.so.0 (0xb14ce000)
   libxcb-shm.so.0 => /usr/lib/libxcb-shm.so.0 (0xb14c9000)
   libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0xb14bf000)
   libz.so.1 => /lib/libz.so.1 (0xb14a9000)
   libplds4.so => /usr/lib/libplds4.so (0xb14a4000)
   libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0xb1486000)
   libssl.so.1.0.0 => /lib/libssl.so.1.0.0 (0xb142f000)
   libcrypto.so.1.0.0 => /lib/libcrypto.so.1.0.0 (0xb1284000)
   libcrypt.so.1 => /lib/libcrypt.so.1 (0xb1253000)
   libgpg-error.so.0 => /lib/libgpg-error.so.0 (0xb124e000)
   libXau.so.6 => /usr/lib/libXau.so.6 (0xb124a000)
   libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb1242000)
   libselinux.so.1 => /lib/libselinux.so.1 (0xb1223000)
   libresolv.so.2 => /lib/libresolv.so.2 (0xb120b000)
# seamonkey
XPCOMGlueLoad error for file /usr/lib/seamonkey-2.13.1/libxpcom.so:
/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib/seamonkey/libxul.so)
Couldn't load XPCOM.
# ldd /usr/bin/seamonkey
   linux-gate.so.1 =>  (0xffffe000)
   libdl.so.2 => /lib/libdl.so.2 (0xb77b2000)
   libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb76cc000)
   libm.so.6 => /lib/libm.so.6 (0xb769f000)
   libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7681000)
   libpthread.so.0 => /lib/libpthread.so.0 (0xb7666000)
   libc.so.6 => /lib/libc.so.6 (0xb74bc000)
   /lib/ld-linux.so.2 (0xb77b9000)
#


...anyway, help would be much appreciated. I think installing the SDL libs (that most Puppy Linux games need) broke them, although uninstalling them didn't help, even after rebooting.
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3966
Location: World_Hub

PostPosted: Thu 14 Feb 2013, 14:41    Post_subject:  

Have you tried reinstalling libstdc++6? PPM should show it as >> libstdc++6_4.6.3-1ubuntu5_i386

libstdc++.so.6 is usually a symlink pointing to the real lib. Aboard my 528 >> libstdc++.so.6.0.13.

So, you probably have a broken symlink. On Precise, it should point to >> libstdc++.so.6.0.16.

On my rather vanilla Precise, libSDL-1.2.so.0 should point to >> libSDL-1.2.so.0.11.3.

Furthermore.. I suggest you install libc-bin if you're unable to run ldconfig.
Back to top
View user's profile Send_private_message 
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Thu 14 Feb 2013, 20:10    Post_subject:    

SCORE! Reinstalling that package fixed everything! Thank you! Very Happy
_________________
Version 27. Dotpet. Click here.
(SFS available too!)

Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3966
Location: World_Hub

PostPosted: Thu 14 Feb 2013, 21:05    Post_subject:  

Good! No one leaves Wink dissatisfied.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0632s ][ Queries: 12 (0.0050s) ][ GZIP on ]