Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 01:14
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to get Minecraft working?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Sun 10 Feb 2013, 13:32    Post subject:  How to get Minecraft working?
Subject description: org.lwjgl.LWJGLException: X Error - disp: 0x70281ff0 serial: 24 error: BadRequest
 

I downloaded the JRE tarball from the official Java website, then extracted it to /usr/java (so now I have a folder /usr/java/jre1.7.0_13/) and linked /usr/java/jre1.7.0_13/bin/java to /usr/bin.
I then ran java -Xmx1024M -Xms512M -cp minecraft.jar net.minecraft.LauncherFrame, just like the official instructions said, but for some reason, I can't get any of the text boxes for the login credentials in focus. I can middle-click to paste stuff in them, so that worked, and I set it to remember my password, but there are 2 people who play Minecraft on that computer, so that would be a problem.

Also, when I try to play, I get this:
Code:
# java -Xmx1024M -Xms512M -cp minecraft.jar net.minecraft.LauncherFrame
asdf
Exception in thread "Thread-3" java.lang.UnsatisfiedLinkError: /root/.minecraft/bin/natives/liblwjgl.so: libjawt.so: cannot open shared object file: No such file or directory
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary1(Unknown Source)
        at java.lang.ClassLoader.loadLibrary0(Unknown Source)
        at java.lang.ClassLoader.loadLibrary(Unknown Source)
        at java.lang.Runtime.load0(Unknown Source)
        at java.lang.System.load(Unknown Source)
        at org.lwjgl.Sys$1.run(Sys.java:69)
        at java.security.AccessController.doPrivileged(Native Method)
        at org.lwjgl.Sys.doLoadLibrary(Sys.java:65)
        at org.lwjgl.Sys.loadLibrary(Sys.java:81)
        at org.lwjgl.Sys.<clinit>(Sys.java:98)
        at net.minecraft.client.Minecraft.F(SourceFile:1976)
        at asz.<init>(SourceFile:20)
        at net.minecraft.client.Minecraft.<init>(SourceFile:75)
        at asq.<init>(SourceFile:38)
        at net.minecraft.client.MinecraftApplet.init(SourceFile:38)
        at net.minecraft.Launcher.replace(Launcher.java:136)
        at net.minecraft.Launcher$1.run(Launcher.java:79)
..so I decide to update my lwjgl.
After updating, it throws this at me:
Code:
# java -Xmx1024M -Xms512M -cp minecraft.jar net.minecraft.LauncherFrame
asdf
27 achievements
210 recipes
Setting user: codegeek98, -2563761272650108803
LWJGL Version: 2.8.5
org.lwjgl.LWJGLException: X Error - disp: 0x70287438 serial: 24 error: BadRequest (invalid request code or no such operation) request_code: 135 minor_code: 14
   at org.lwjgl.opengl.LinuxDisplay.globalErrorHandler(LinuxDisplay.java:318)
   at org.lwjgl.opengl.LinuxDisplayPeerInfo.initDefaultPeerInfo(Native Method)
   at org.lwjgl.opengl.LinuxDisplayPeerInfo.<init>(LinuxDisplayPeerInfo.java:61)
   at org.lwjgl.opengl.LinuxDisplay.createPeerInfo(LinuxDisplay.java:788)
   at org.lwjgl.opengl.DrawableGL.setPixelFormat(DrawableGL.java:61)
   at org.lwjgl.opengl.Display.create(Display.java:843)
   at org.lwjgl.opengl.Display.create(Display.java:754)
   at net.minecraft.client.Minecraft.a(SourceFile:223)
   at asq.a(SourceFile:56)
   at net.minecraft.client.Minecraft.run(SourceFile:515)
   at java.lang.Thread.run(Unknown Source)
org.lwjgl.LWJGLException: X Error - disp: 0x70287438 serial: 31 error: BadRequest (invalid request code or no such operation) request_code: 135 minor_code: 14
   at org.lwjgl.opengl.LinuxDisplay.globalErrorHandler(LinuxDisplay.java:318)
   at org.lwjgl.opengl.LinuxDisplayPeerInfo.initDefaultPeerInfo(Native Method)
   at org.lwjgl.opengl.LinuxDisplayPeerInfo.<init>(LinuxDisplayPeerInfo.java:61)
   at org.lwjgl.opengl.LinuxDisplay.createPeerInfo(LinuxDisplay.java:788)
   at org.lwjgl.opengl.DrawableGL.setPixelFormat(DrawableGL.java:61)
   at org.lwjgl.opengl.Display.create(Display.java:843)
   at org.lwjgl.opengl.Display.create(Display.java:754)
   at org.lwjgl.opengl.Display.create(Display.java:736)
   at net.minecraft.client.Minecraft.a(SourceFile:232)
   at asq.a(SourceFile:56)
   at net.minecraft.client.Minecraft.run(SourceFile:515)
   at java.lang.Thread.run(Unknown Source)


What do I need to do? I have Precise Puppy 5.4.3.

UPDATE: I suspect graphics driver issues. I have a Radeon HD 4350, so I installed the ATI fglrx driver, but aticonfig --initial always returns "aticonfig: No supported adapters detected", no matter whether I'm running it from urvxt or the actual console. Rebooting didn't fix anything either.

Last edited by JamesTheAwesomeDude on Sun 10 Feb 2013, 23:50; edited 1 time in total
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3965
Location: World_Hub

PostPosted: Sun 10 Feb 2013, 15:58    Post subject:  

While it could well be graphics, perhaps this post sheds some light..
Back to top
View user's profile Send private message 
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Sun 10 Feb 2013, 23:48    Post subject:  

The other person reported everything fine in Precise Puppy, the only problem was having to symlink java. I've already gotten the java command working, so that didn't help. Nothing else in the post was really applicable to me.

I think it's an issue with my graphics. I still need help. Sad
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3965
Location: World_Hub

PostPosted: Tue 12 Feb 2013, 07:53    Post subject:  

The game lib doesn't appear to have been the problem, nor updating it, the solution. This a 64bit box?
Back to top
View user's profile Send private message 
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Sat 16 Feb 2013, 14:16    Post subject:  

Yep, the computer is 64-bit, but I keep everything in Puppy Linux 32-bit.

I've reinstalled Precise 5.4.3 (for an unrelated reason,) and installed Java 7 update 13 via official download. I then ran Minecraft. (I also manually updated LWJGL to the latest stable release.) Everything seems to be working, except that when I start the game or join a server, it's paused, and the "Back to Game" button doesn't work. On singleplayer, the world doesn't render at all, but when joining a server, the world renders (although I can't exit the pause screen.) I can provide logs if you need.

I also deleted ~/.minecraft/bin/natives/*64.so, because they were just wasting space. They wouldn't do anything, since Puppy Linux is 32-bit, and deleting them didn't change a thing. It still doesn't work.

_________________
Version 27. Dotpet. Click here.
(SFS available too!)

Back to top
View user's profile Send private message 
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Mon 25 Feb 2013, 18:11    Post subject:  

Okay, starting with a fresh install of Slacko:
  • Installed official JRE from java.com
  • Downloaded minecraft.jar, got everything set up.
  • Updated Minecraft, then manually updated the LWJGL .jar's and .so's. Deleted all 64-bit ones.

What do I need to do driver-wise? Radeon HD 4350 on Slacko 5.4. Kernel release 3.2.33-4g.

_________________
Version 27. Dotpet. Click here.
(SFS available too!)

Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3965
Location: World_Hub

PostPosted: Mon 25 Feb 2013, 20:01    Post subject:  

You mean you have Pup's ATI fglrx driver, not >> amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run?

There's a page that shows a few adjustments you can make to xorg.conf >> http://linux.die.net/man/4/radeon
Back to top
View user's profile Send private message 
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Mon 25 Feb 2013, 21:01    Post subject:  

Semme wrote:
You mean you have Pup's ATI fglrx driver, not >> amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run?

There's a page that shows a few adjustments you can make to xorg.conf >> http://linux.die.net/man/4/radeon
Okay, I couldn't make anything of that man page you sent me, but after reinstalling everything matching "radeon" in PPM, then using Xorgwizard from the prompt, I rebooted, ran Minecraft, and got this:
Terminal output:
Code:
# minecraft
asdf
27 achievements
210 recipes
Setting user: codegeek98, XXXXXXXXXXXXXXXXXXX
LWJGL Version: 2.8.5
org.lwjgl.LWJGLException: Could not get VisualInfo from GLX 1.3 config
   at org.lwjgl.opengl.LinuxDisplay.nCreateWindow(Native Method)
   at org.lwjgl.opengl.LinuxDisplay.createWindow(LinuxDisplay.java:480)
   at org.lwjgl.opengl.Display.createWindow(Display.java:303)
   at org.lwjgl.opengl.Display.create(Display.java:845)
   at org.lwjgl.opengl.Display.create(Display.java:754)
   at net.minecraft.client.Minecraft.a(SourceFile:223)
   at asq.a(SourceFile:56)
   at net.minecraft.client.Minecraft.run(SourceFile:515)
   at java.lang.Thread.run(Unknown Source)
org.lwjgl.LWJGLException: Could not get VisualInfo from GLX 1.3 config
   at org.lwjgl.opengl.LinuxDisplay.nCreateWindow(Native Method)
   at org.lwjgl.opengl.LinuxDisplay.createWindow(LinuxDisplay.java:480)
   at org.lwjgl.opengl.Display.createWindow(Display.java:303)
   at org.lwjgl.opengl.Display.create(Display.java:845)
   at org.lwjgl.opengl.Display.create(Display.java:754)
   at org.lwjgl.opengl.Display.create(Display.java:736)
   at net.minecraft.client.Minecraft.a(SourceFile:232)
   at asq.a(SourceFile:56)
   at net.minecraft.client.Minecraft.run(SourceFile:515)
   at java.lang.Thread.run(Unknown Source)


Minecraft Crash Window output:
Code:


      Minecraft has crashed!
      ----------------------

Minecraft has stopped running because it encountered a problem; failed to start game

A full error report has been saved to http://pastebin.com/Q6aRYX11 - Please include a copy of that file (Not this screen!) if you report this crash to anyone; without it, they will not be able to help fix the crash :(



--- BEGIN ERROR REPORT fe5df6 --------
Full report at:
http://pastebin.com/Q6aRYX11
Please show that file to Mojang, NOT just this screen!

Generated 2/25/13 6:25 PM

-- System Details --
Details:
        Minecraft version: 1.4.7
        Operating System: Linux (i386) version 3.2.33-4g
        Java Version: 1.7.0_15, Oracle Corporation
        Java VM Version: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation
        Memory: 422130424 bytes (402 MB) / 518979584 bytes (494 MB) up to 1037959168 bytes (989 MB)
        JVM Flags: 2 total; -Xmx1024M -Xms512M
        AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
        Suspicious classes: No suspicious classes found.
        IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
        LWJGL: 2.8.5
        OpelGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the surrent thread.
        Is Modded: Probably not. Jar signature remains and client brand is untouched.
        Type: Client (map_client.txt)
        Texture Pack: Default
        Profiler Position: N/A (disabled)
        Vec3 Pool Size: ~~ERROR~~ NullPointerException: null[failed to get system properties (java.lang.RuntimeException: No OpenGL context found in the current thread.)]


org.lwjgl.LWJGLException: Could not get VisualInfo from GLX 1.3 config
        at org.lwjgl.opengl.LinuxDisplay.nCrateWindow(Native Method)
        at org.lwjgl.opengl.LinuxDisplay.createWindow(LinuxDisplay.java:480)
        at org.lwjgl.opengl.Display.createWindows(Display.java:303)
        at org.lwjgl.opengl.Display.create(Display.java:845)
        at org.lwjgl.opengl.Display.create(Display.java:754)
        at org.lwjgl.opengl.Display.create(Display.java:736)
        at net.minecraft.client.Minecraft.a(SourceFile:232)
        at asq.a(SourceFile:56)
        at net.minecraft.client.Minecraft.run(SourceFile:515)
        at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT c52bdf8d ----------



This crash screen appeared as soon as I clicked "Login". It didn't even display the Mojang logo. Updating gave me the Black Screen and this:
Code:
# minecraft
asdf
Exception in thread "Thread-3" java.lang.UnsatisfiedLinkError: /root/.minecraft/bin/natives/liblwjgl.so: libjawt.so: cannot open shared object file: No such file or directory
   at java.lang.ClassLoader$NativeLibrary.load(Native Method)
   at java.lang.ClassLoader.loadLibrary1(Unknown Source)
   at java.lang.ClassLoader.loadLibrary0(Unknown Source)
   at java.lang.ClassLoader.loadLibrary(Unknown Source)
   at java.lang.Runtime.load0(Unknown Source)
   at java.lang.System.load(Unknown Source)
   at org.lwjgl.Sys$1.run(Sys.java:69)
   at java.security.AccessController.doPrivileged(Native Method)
   at org.lwjgl.Sys.doLoadLibrary(Sys.java:65)
   at org.lwjgl.Sys.loadLibrary(Sys.java:81)
   at org.lwjgl.Sys.<clinit>(Sys.java:98)
   at net.minecraft.client.Minecraft.F(SourceFile:1976)
   at asz.<init>(SourceFile:20)
   at net.minecraft.client.Minecraft.<init>(SourceFile:75)
   at asq.<init>(SourceFile:38)
   at net.minecraft.client.MinecraftApplet.init(SourceFile:38)
   at net.minecraft.Launcher.replace(Launcher.java:136)
   at net.minecraft.Launcher$1.run(Launcher.java:79)

_________________
Version 27. Dotpet. Click here.
(SFS available too!)

Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3965
Location: World_Hub

PostPosted: Mon 25 Feb 2013, 21:29    Post subject:  

I'll leave this for anyone else to dissect. Me? I'd go with the AMD driver. They got a shiny new beta too..
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0907s ][ Queries: 12 (0.0036s) ][ GZIP on ]