Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 18:52
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
GUI to download LibreOffice - beta quality
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 15 of 18 Posts_count   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, 18 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Sun 17 Feb 2013, 16:41    Post_subject:  

Thanks Henry,

Well your save may be taking all the space on the drive but it's not the pupmode 6 (7 was wrong) I thought it was.

Looks like your RAM is full, so I need to improve the RAM test, but if your partition is full there may be another problem. Anyway, I can see why the older versions of get_libre work for you, they don't build in RAM.

Q. Do you have swap?

I'll post a fix soon.

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
tlchost

Joined: 05 Aug 2007
Posts: 1729
Location: Baltimore, Maryland USA

PostPosted: Sun 17 Feb 2013, 16:44    Post_subject: Memory Bug  

version 25 and many earlier ones report a low memory condition on my desktop system which has 16 gigs of memory.

Recognizing an impossible statement when I see one, I tested version 25 on my laptop which has a paltry 4 gigs of memory. It works!

So, my non-technical, I am a simple end user observation is that the memory reporting/detection/error trapping is not functioning correctly.

Thom
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Sun 17 Feb 2013, 16:53    Post_subject:  

Thom, can you post the out put of free please?
Code:
free

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
tlchost

Joined: 05 Aug 2007
Posts: 1729
Location: Baltimore, Maryland USA

PostPosted: Sun 17 Feb 2013, 17:39    Post_subject:  

01micko wrote:
Thom, can you post the out put of free please?


16:39:17 ~ > free
total used free shared buffers
Mem: 16376392 611804 15764588 0 46084
-/+ buffers: 565720 15810672
Swap: 0 0 0
Back to top
View user's profile Send_private_message Visit_website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Sun 17 Feb 2013, 17:56    Post_subject:  

01micko wrote:
Thanks Henry,

Well your save may be taking all the space on the drive but it's not the pupmode 6 (7 was wrong) I thought it was.

Looks like your RAM is full, so I need to improve the RAM test, but if your partition is full there may be another problem. Anyway, I can see why the older versions of get_libre work for you, they don't build in RAM.

Q. Do you have swap?

I'll post a fix soon.

Cheers


Just looked at the computer again, and it's all stuffed up, can't do much of anything. So I restored the backup system.

To clarify: My pupsave does not take up all the space on the drive, at least normally. It is set for 630M of which 376M is nearly always available. (I put nearly all the variable data, cache, etc. into /mnt/home.) No swap file.

It looks like the downloaded LO debs ended up in /tmp (ram) instead of /mnt/home as a usual sfs. (They are now copied to another HD and I guess could be undebed.)

However, I'm just a user and it's unimportant whether I use 3.6 or 4.0. But it is interesting - thanks for all the creative and generous things you do.
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Mon 18 Feb 2013, 16:33    Post_subject:  

There's a hole in my program dear Henry!

I fixed it with straw... [ Rolling Eyes .. I'm terrible with humour!]

I rewrote the RAM check function and it should build in /mnt/home if your RAM is getting a bit full. All my machines have swap so it builds in RAM for me anyway and if RAM fills up swap comes into play.

Anyway, it *should* work, Thom, I'd be interested in your results too.

Here's my log, while it won't show much in the way of error messages it will help me pinpoint where there is a breakdown and give me useful info about your system for debugging. It's located at /tmp/LO_log_"today's date"
Quote:
LO LOG
-------
Tue_Feb_19_06:04:42_EST_2013
get_libreoffice-0.26
PUPMODE = 13
en-GB
Is it ok to build in RAM? yes
building in /tmp
moving to /initrd/mnt/dev_save
this is 4.0.0
major ver: 4.0
help enabled? true
lang enabled? true
LibreOffice_4.0.0_Linux_x86_deb_helppack_
LibreOffice_4.0.0_Linux_x86_deb_langpack_
Current working dir is /tmp/libre_download/LibreOffice_4.0.0.3_Linux_x86_deb/DEBS

0.26 is going up now

see main post

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
tlchost

Joined: 05 Aug 2007
Posts: 1729
Location: Baltimore, Maryland USA

PostPosted: Mon 18 Feb 2013, 17:27    Post_subject:  

01micko wrote:


Anyway, it *should* work, Thom, I'd be interested in your results too



Looks like you caught the little bugger....works fine here on the 'bountiful memory machine'.

Thanks!

Thom
Back to top
View user's profile Send_private_message Visit_website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Mon 18 Feb 2013, 18:05    Post_subject: Testing 0.26
Sub_title: It's progress!
 

Download complete. System working normally, seems unaffected except for the large files in /tmp, totalling about 524M instead of the usual 76M.

A popup says: "Sorry, constructing LibreOffice-4.0.0_en-US_xz.sfs has failed"
Code:
LO LOG
-------
Mon_Feb_18_13:07:57_PST_2013
get_libreoffice-0.26
PUPMODE = 12
en-US
Is it ok to build in RAM? yes
building in /tmp
moving to /initrd/mnt/dev_save
this is 4.0.0
major ver: 4.0
help enabled? true
lang enabled? false
LibreOffice_4.0.0_Linux_x86_deb_helppack_
LibreOffice_4.0.0_Linux_x86_deb_langpack_
Current working dir is /tmp/libre_download/LibreOffice_4.0.0.3_Linux_x86_deb/DEBS
ERROR: failed to unpack libobasis4.0-en-us-help_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-en-us-math_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-en-us-res_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-en-us-writer_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-en-us_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-beanshell-script-provider_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-javascript-script-provider_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-mediawiki-publisher_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-nlpsolver_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-presentation-minimizer_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-python-script-provider_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-report-builder_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-gnome-integration_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-graphicfilter_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-images_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-impress_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-javafilter_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-kde-integration_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-librelogo_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-math_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-ogltrans_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-onlineupdate_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-ooofonts_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-ooolinguistic_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-postgresql-sdbc_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-pyuno_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-writer_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-xsltfilter_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-base_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-calc_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-debian-menus_4.0.0-103_all
ERROR: failed to unpack libreoffice4.0-dict-en_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-dict-es_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-dict-fr_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-draw_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-en-us_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-impress_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-math_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-stdlibs_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-ure_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-writer_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0_4.0.0.3-103_i386


libre_download (523.9M debs) is also in /tmp

Is the xz compression perhaps giving a problem?

Henry
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Mon 18 Feb 2013, 18:39    Post_subject:  

Thanks for the log Henry

Now, looks like everything is fine except the unpacking of the debs, which leads me to believe it might be a NOP specific problem. Have you ever had any problem installing a deb? The LO script uses the same code to unpack the debs as PPM uses to install them.

EDIT:

I just successfully built in NOP. So that dismisses a NOP bug. I don't *think* xz compression will make a difference to you, you have plenty of RAM. (You may want to get it tested) . I think I'm allowing plenty of room for the construction which is at 900M, IIRC it unpacks to ~500M plus the size of the debs ~160M (gz) then the sfs ~130M (xz) ~160M(gz) for a max of around 700M. I'll bump it to 1GB anyway and may offer a checkbox to build in /mnt/home (essentially having the checkbox checked will force "no" for the RAM test).

I'm on it.

_________________
Woof Mailing List | keep the faith Cool |

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Mon 18 Feb 2013, 19:40    Post_subject:  

Thanks for working with me on this. I think it's time to take a breather while I review about unpacking debs. Many years ago I recall doing that to download OpenOffice, but my memory is not what it used to be.

Could you suggest a simple test to check PreciseNop for this?
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Mon 18 Feb 2013, 19:51    Post_subject:  

Henry wrote:
Thanks for working with me on this. I think it's time to take a breather while I review about unpacking debs. Many years ago I recall doing that to download OpenOffice, but my memory is not what it used to be.

Could you suggest a simple test to check PreciseNop for this?


Nah, NOP is fine.. I'll put in the checkbox to opt out of RAM building, because v0.17 was successful for you. You can blame Thom, he forced me into doing the RAM build! Laughing .

Translators take note, there will be extra lines for the pot file... not many though.

---------------------------------------------------------------------------

Henry, I changed my mind and made it a Yes/no box. It's pretty simple to understand. Choose "No" and it will build on the hard drive like the old versions, the log reflects that too.

Hope it works! (works for me in NOP-543)

See main post for 0.27

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Tue 19 Feb 2013, 00:19    Post_subject:  

01micko wrote:
Henry, I changed my mind and made it a Yes/no box. It's pretty simple to understand. Choose "No" and it will build on the hard drive like the old versions, the log reflects that too.

Hope it works! (works for me in NOP-543)

See main post for 0.27

Works beautifully! I've been checking pretty much since 0.27 arrived and can't find any problem.

Thanks!!
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Tue 19 Feb 2013, 11:34    Post_subject:  

Henry wrote:
Works beautifully! I've been checking pretty much since 0.27 arrived and can't find any problem.

Thanks!!
Great! Now I need some luthier lessons off you! [joke of course]
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
rameshiyer

Joined: 17 Sep 2009
Posts: 232
Location: Calicut, Kerala, India

PostPosted: Tue 19 Feb 2013, 13:20    Post_subject: LibreOffice 4
Sub_title: SFS fiel
 

Please provide cut down version of Libreoffice - only Writer preferably SFS file.
Back to top
View user's profile Send_private_message YIM MSNM 
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Tue 19 Feb 2013, 13:37    Post_subject: Re: LibreOffice 4
Sub_title: SFS fiel
 

rameshiyer wrote:
Please provide cut down version of Libreoffice - only Writer preferably SFS file.

Maybe... one day...

A bloke like jrb (who is a true minimalist) may be interested in this...

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 15 of 18 Posts_count   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, 18 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1097s ][ Queries: 13 (0.0193s) ][ GZIP on ]