Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 22:32
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Mypaint 1.1.0 precise
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
666philb


Joined: 07 Feb 2010
Posts: 1724
Location: wales

PostPosted: Wed 05 Dec 2012, 14:40    Post_subject:  Mypaint 1.1.0 precise
Sub_title: digital painting
 

this is mypaint ..



MyPaint is a fast and easy open-source graphics application for digital painters. It lets you focus on the art instead of the program. You work on your canvas with minimum distractions, bringing up the interface only when you need it.

MyPaint comes with a large brush collection including charcoal and ink to emulate real media, but the highly configurable brush engine allows you to experiment with your own brushes and with not-quite-natural painting.

website here http://mypaint.intilinux.com/
Before beginning it is a good idea to read the quick-start tutorial http://mypaint.intilinux.com/?page_id=3
You can also visit the MyPaint Wiki. http://wiki.mypaint.info/



this is only for precise puppy
.pet here http://www.wuala.com/666philb/Documents/mypaint-1.1.0.pet/ 50mb
MD5 f96ea01e899c89c5e93ba91f1125bafa

.sfs herehttp://www.mediafire.com/file/adn3x4cz3x9ccjt/mypaint-1.1.0_sfs4.sfs 50mb
MD5 d3fe5de87915bba6550d5f2b4b245a00

extra brushes here http://wiki.mypaint.info/Brush_Packages

enjoy

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739

Edited_times_total
Back to top
View user's profile Send_private_message 
ASRI éducation


Joined: 09 May 2009
Posts: 2472
Location: France

PostPosted: Sat 15 Dec 2012, 12:34    Post_subject:  

Thank you.
Mypaint is a nice application.
Back to top
View user's profile Send_private_message Visit_website 
Keef


Joined: 20 Dec 2007
Posts: 630
Location: Staffordshire

PostPosted: Wed 16 Jan 2013, 13:35    Post_subject:  

Works very well on Upup Precise 3.7.2.
Thanks.
Back to top
View user's profile Send_private_message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Tue 12 Feb 2013, 06:32    Post_subject: Not works for me  

I tried to install Mypaint 1.0.0 but it works for me only in a fresh installed Precise.

In Precise where I load .sfs files like VirtualBox, Java, LibreOffice, Devx and Kernel Source (my work softwares), Mypaint program don't work, if I try to launch it via command-line it gives to me an error message that I attach in this page .

This happens in Upup Precise 3.7.2 and Upup Precise 3.2.9

Thanks.
image-1.png
Description 
png

 Download 
Filename  image-1.png 
Filesize  142.62 KB 
Downloaded  384 Time(s) 
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1724
Location: wales

PostPosted: Tue 12 Feb 2013, 13:24    Post_subject:  

hi Fabio T,

you're possibly installing something containing python modules, which aren't compatible with precises python.
the devx, kernel src & libre office are fine as i have them installed and mypaint works fine.... i can't see virtualbox affecting it, what are these 'work softwares' ?

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3307
Location: Ontario

PostPosted: Wed 13 Feb 2013, 15:01    Post_subject:  

Note to 666philb...

There is at least two versions(2.6 or 2.7) of python available on the forum.
The official repository 'Packages-puppy-precise-official'
by Barry Kauler doesn't have a package.


It would help the users if you told us which python pet or sfs
package to use.

.
Back to top
View user's profile Send_private_message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Wed 13 Feb 2013, 18:30    Post_subject:  

don570 wrote:
Note to 666philb...

There is at least two versions(2.6 or 2.7) of python available on the forum.
The official repository 'Packages-puppy-precise-official'
by Barry Kauler doesn't have a package.


It would help the users if you told us which python pet or sfs
package to use.

.


Python in my Upup Precise is 2.7.3 version.

My Work software is that I've already mentioned (LibreOffice, Java, VirtualBox, Devx and Kernel Source, plus driver for Bluetooth and a card Driver for my laptop).

To identify software conflict I'll try to test sequential installation of all software.
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1724
Location: wales

PostPosted: Wed 13 Feb 2013, 18:49    Post_subject:  

hi don570

precise puppy comes with python already installed so no need to install a python package, and it is compatible with the python modules in the PPM.

installing python.pets from the forum, or apps which contain python modules that aren't from the ubuntu precise repos, will break compatibility with python apps in the PPM

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send_private_message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Fri 15 Feb 2013, 15:45    Post_subject: Mypaint  

It's strange, but Mypaint works only if is loaded as the first app even in .sfs, when I install Bluetooth, Card Driver, Wacom Driver and xbacklight, don't works anymore.

If I don't load wacom driver I can't test it with touchscreen....

How can I install version 1.1.0? I had read readme file but suggested commands don't works...
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1724
Location: wales

PostPosted: Fri 15 Feb 2013, 17:16    Post_subject:  

hi Fabio T

i've updated the mypaint package to 1.1.0.... see first post

is the bluetooth package the one off the forum, with python?

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send_private_message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Sun 17 Feb 2013, 02:25    Post_subject:  

Is the package Bluetooth 0.5

I installed it and Mypaint halts with errors, I remove Bluetooth .pet and Mypaint works correctly

If you want to get a look: This is link to download file.

http://www.datafilehost.com/download-4a8250c0.html
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3307
Location: Ontario

PostPosted: Wed 20 Feb 2013, 15:58    Post_subject: works in ToOpPy and Puplette  

Good News!!

MyPaint 1.1 SFSworks in Puplette and ToOpPy.

and Wacom Bamboo Tablette works in Puplette
(not in ToOpPy).


xf86-input_k.3.2.29-upup-wacom-0.17.0.pet
available

Back to top
View user's profile Send_private_message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Sun 17 Mar 2013, 17:52    Post_subject:  

This is my experience with Mypaint 1.1.0 .SFS:
In Upup Precise 3.7.2. works fine (but I don't load Bluetooth Mouse Driver).

In a fresh installed Upup Precise 3.8.3, Mypaint 1.1.0 .SFS won't start.

I enclose a snapshot of error message that complains that icons are missed.

I follow the web link in the error message and instructions in the web page, but without any success.

What can I do to make Mypaint in order to work on Upup 3.8.3?

Thanks in advance
capture13374.png
 Description   Error message from Mypaint 1.1.0
 Filesize   34.58 KB
 Viewed   1793 Time(s)

capture13374.png

Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1724
Location: wales

PostPosted: Mon 18 Mar 2013, 13:18    Post_subject:  

hi fabio t,

i just tested both the .pet and .sfs in pemasus upup precise 3.8.3no pae (fresh install) and they started fine for me.....

so not sure what's going on! did you install anything else?

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send_private_message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Mon 18 Mar 2013, 16:26    Post_subject:  

666philb wrote:
hi fabio t,

i just tested both the .pet and .sfs in pemasus upup precise 3.8.3no pae (fresh install) and they started fine for me.....

so not sure what's going on! did you install anything else?


I am not installin anything else. I redo the test.

But..

Very Happy Oh My GOD!

I can't believe.... Evil or Very Mad

I redo installation of Precise 3.8.3 No-PAE kernel with frugal method, create save file, reboot, install mypaint.1.1.0.sfs, reboot , open a rxvt window and type: mypaint. Surprised

Nothing happens. Only appear the screen I've post in my previous message. Evil or Very Mad

I install Bluetooth 0.5 (that prevents mypaint to work).
I REMOVE Bluetooth 0.5 (from Puppy Package Manager) without launch it

I launch now mypaint in a terminal window and NOW....WORKS!!! Laughing Laughing

BUT WHY ????? Shocked

How can it tell to mypaint where are his icons? Shocked Shocked Shocked

Perhaps a Python bug?

i don't want to install a useless .PET (i've found a solution to install bluetooth mouse without install Bluetooth 0.5)

Any idea?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0820s ][ Queries: 13 (0.0054s) ][ GZIP on ]