Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 11:16
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
SOLVED: Compaq Presario c500 keyboard buggy on precise 5.4.9
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
kurtdriver

Joined: 16 Jan 2009
Posts: 29

PostPosted: Wed 20 Feb 2013, 00:32    Post_subject:  SOLVED: Compaq Presario c500 keyboard buggy on precise 5.4.9  

Hi, I've reinstalled several times and keep having this problem. The keyboard continues to repeat the first character typed, a long string of "ggggggggggggggggg" or what have you that doesn't stop untill I kill the window. This happens in Seamonkey'ssearch bar, pfind, Geany, or the terminal.

This laptop belongs to a guy I work with, I agreed to install an operating system for him, bum I'm at my wit's end. Anyone have any ideas? I should add that this same keyboard has at some installations not worked at all.

It works and is wonderful, I sent him an email Sunday eve, when 5.4.3 was on it telling him how impressed I was and how zippy it is. I don't think he'll be impressed with needing to carry a USB keyboard around.

I'm having this problem both with the full install to the hard drive and when booted from a USB key.
Kurt

Edited_time_total
Back to top
View user's profile Send_private_message 
darkcity


Joined: 23 May 2010
Posts: 2462
Location: near here

PostPosted: Wed 20 Feb 2013, 16:27    Post_subject:  

Hi KurtDriver

One possibility is the keyboard has a mechanical fault, you could try clean the keyboard.
http://h10010.www1.hp.com/ewfrf/wc/document?docname=c00292159&lc=en&cc=us&dlc=en&product=3318985

Another possibility is the delay/repeat settings have been set incorrectly, one of these topics may help-
http://www.murga-linux.com/puppy/viewtopic.php?t=33823
http://www.murga-linux.com/puppy/viewtopic.php?t=18019

---

Does the problem occur if you USB boot without loading the SaveFile?
http://puppylinux.org/wikka/HowToAvoidLoadingSaveFile

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send_private_message Visit_website 
kurtdriver

Joined: 16 Jan 2009
Posts: 29

PostPosted: Wed 20 Feb 2013, 21:02    Post_subject:  

Hi thanks for your reply. I think I've found a reliable solution; booting with numlock off causes the keyboard to not work at all, turning it on causes it to work but with the repeating character, and turning it off again causes it to work normally. It's worked like that through several reboots. I turned numlock on, which is persistant, can you think of any way to turn it off automatically, after it goes on?
Back to top
View user's profile Send_private_message 
darkcity


Joined: 23 May 2010
Posts: 2462
Location: near here

PostPosted: Thu 21 Feb 2013, 06:39    Post_subject:  

Num Lock can to configured to be on/off on startup see PersonalizeSettings. There is also the numlockx command to control the key.

For example you could make a script and put it in ~/Startup

Code:
#!/bin/sh
#toggle num lock
numlockx on
numlockx off


seems like an odd problem though, maybe something else is at play as well as the Num lock?

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send_private_message Visit_website 
kurtdriver

Joined: 16 Jan 2009
Posts: 29

PostPosted: Thu 21 Feb 2013, 17:22    Post_subject:  

I found some stuff on the internet about that particular property of the keyboard. Turns out the numlockx file exists in Startup, so I just added a line at the end to turn it off. Thanks for your effort, darkcity.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0539s ][ Queries: 12 (0.0095s) ][ GZIP on ]