Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 21:40
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
lupu 5.28plus en français
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
musher0


Joined: 04 Jan 2009
Posts: 3810
Location: Gatineau (Qc), Canada

PostPosted: Thu 07 Mar 2013, 13:41    Post subject:  lupu 5.28plus en français
Subject description: paquet de francisation adapté
 

Bonjour !

En marge de la francisation du Small Business Pup (SBP) de e_mattis, voici celle du lupu 5.28plus de playdayz, dont le SBP est issu. Un peu tard, me direz-vous, au vu des nouvelles distros precise et slacko, wary et quirky,etc.

La lupu 5.28plus de playdayz a pour elle d'avoir été testée -- et bien testée -- sous toutes ses coutures et d'être extrêmement stable.

Et puis, contrairement aux nouvelles distros, elle ne change pas tous les deux jours !!! C'est le cauchemar, ça, pour un adaptateur !!!

J'ai donc le grand plaisir de vous offrir la lupu 5.28plus en français. Smile

Seule remarque : sortie usine, elle est configurée pour fr_CA. Pour qu'elle reconnaisse d'autres caractéristiques langagières, il suffit de charger /etc/profile.local dans un éditeur et de changer fr_CA à fr_FR, fr_BE, fr_CH ou fr_LU, selon le cas. Il y a des liens en conséquence dans /usr/share/locale, donc vous n'aurez rien d'autre à faire.

http://limelinx.com/ztia (1,1 Mo environ)
L'image iso de la lupu-5.28plus se trouve à http://diddywahdiddy.net/Puppy500/lupu-528.005.iso, et son fil de discussion à http://www.murga-linux.com/puppy/viewtopic.php?t=70855.

Au plaisir ! Smile

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 3810
Location: Gatineau (Qc), Canada

PostPosted: Fri 08 Mar 2013, 10:31    Post subject:  

Quelques mots d'explications, pour que personne ne se sente insulté : le menu de la lupu 5.28plus s'entêtait à parler anglais.

Après enquête, j'ai découvert le bobo : les fichiers *desktop de la francisation prévue pour lupu ne contenaient pas d'entreé "Name[fr]".

La solution a été de rétro-porter les fichiers *.desktop du paquet de francisation de mars 2012 sur le paquet prévu pour le lupu 5.28plus.
(En fait, cette francisation ne contenait aucun fichier *.desktop.)

Pour ne conserver que les *.desktop du paquet de mars 2012 qui s'appliquaient à la lupu 5.28 plus, j'ai fait une synchronisation rétrograde entre les deux à l'aide de jFileSync.

J'ai ajouté, pour que ça marche complètement pour fr_CA, mon fichier profile.local habituel et des liens fr_CA, etc., vers fr dans usr/share/locale.

J'ai aussi remonté le fichier-maquette jwm français dans /etc/xdg/templates et j'ai traduit celui qui était prévu pour icewm, que je préfère à jwm.

C'est tout. Ce fut un patient travail de détective, mais ça n'a rien d'agressif, et surtout, ça ne veut blesser personne. C'est une édition "augmentée", qui n'a rien chamboulé de l'édition précédente.

Je ne suis pas là pour réduire l'importance du travail des collaborateurs qui m'ont précédé, mais pour l'améliorer, le cas échéant, si je le peux.

Au revoir.

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)

Last edited by musher0 on Sat 09 Mar 2013, 12:49; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Médor


Joined: 26 May 2011
Posts: 1331

PostPosted: Fri 08 Mar 2013, 20:12    Post subject:  

Bonsoir musher0,

Deux p'tites questions en rapport à la version 528 Plus :
- Les scripts notamment pour Xorg et ceux dans /etc/rc.d/* sont-ils "gettextisés" ?
- Quelle est la version de bash (# bash -version) ?

Ici, je suis resté sur des bases de 528-4 avec les éléments déjà francisés, les 'mo', etc. en commun avec l'Asri-300 et adapté les trads incluses dans initrd.gz.

Il y a quelques jours J'ai téléchargé des mises à jour pour passer Gtk2 en version 2.24.6 ce qui permettra d'utiliser ou de compiler des paquets plus récents !
Mais cette opération est assez risquée car on ne peut pas installer correctement ces paquets deb par le PPM, le système utilisant la version 2.20.1 !

L'opération suivante étant d'intégrer/adapter toute la série des derniers scripts "gettextisés" et utilitaires pour la localisation des versions 5.5 Laughing

Pour info :
J'ai installé sur ma Lucid le dernier paquet hardinfo-0.5.2pre-i486.pet sur ce fil avec le 'mo' extrait du dernier pack d'esmourguit.


Cordialement,
Médor.
HardInfo FR.jpg
 Description   
 Filesize   91.09 KB
 Viewed   261 Time(s)

HardInfo FR.jpg


_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 2291
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 08 Mar 2013, 20:30    Post subject: Bien testée ? on va voir.
Subject description: Voyons si les bogues de la 528 ont disparu.
 

Bogues de la 528 : pas de son, pas de wifi.
Ah bien sûr, les privilégiés captent. Le but c'est que tout le monde ait la wifi et le son sans trifouiller. Je vais vérifier.
Ce sera ma prochaine USB.
Si tout fonctionne, la Lucid 528 est une distro 'must'

Dernières testées : la Racypi : clavier qwerty only, dommage
la lighthouse 64 : elle ne charge pas les paquets, le reste ok, très dommage. Donc moins bien que la vieille 5.0.3 (qui elle aussi ne capte pas la wifi sur mon uptodate computer')
Back to top
View user's profile Send private message Yahoo Messenger 
Médor


Joined: 26 May 2011
Posts: 1331

PostPosted: Fri 08 Mar 2013, 21:35    Post subject:  

Bonsoir Pelo,

Se plaindre à longueur de temps sur le forum est une chose, mais donner des informations détaillées sur ta carte WiFi comme je l'ai déjà demandé permettrait sans doute de régler le problème.
De plus cette carte WiFi fonctionnant sur des Puppies plus récentes il y a bon espoir de pouvoir la faire fonctionner !

La réalisation de la lucid étant bien antérieure à la date de fabrication de ton PC, ce n'est donc absolument pas un bogue comme tu oses par surcroît le prétendre !

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 3810
Location: Gatineau (Qc), Canada

PostPosted: Sat 09 Mar 2013, 12:55    Post subject:  

@Médor

Merci de l'info sur la localisation de hardinfo.

La version de bash dans lupu 5.28 plus (SBP):
> GNU bash, version 4.1.0(1)-release (i686-pc-linux-gnu)

Pour savoir si c'est "get-text-isé", les signes, c'est quoi ? Je sais déjà que le système de localisation avec "sss" n'existe pas sur la lupu 5.28 plus.

A+

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 3810
Location: Gatineau (Qc), Canada

PostPosted: Sat 09 Mar 2013, 12:58    Post subject:  

Médor a écrit :

> Il y a quelques jours J'ai téléchargé des mises à jour pour passer Gtk2 en version 2.24.6 ce qui permettra d'utiliser ou de compiler des paquets plus récents !
Mais cette opération est assez risquée car on ne peut pas installer correctement ces paquets deb par le PPM, le système utilisant la version 2.20.1 !


Tu ne dis pas si l'opération a été un succès ou un échec ? Confused
"En cas de doute, s'abstenir," dit le proverbe...

m0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
Médor


Joined: 26 May 2011
Posts: 1331

PostPosted: Sat 09 Mar 2013, 14:27    Post subject:  

Bonsoir musher0,

J'ai la même version de Bash sur ma Lucid, le 'mo' se trouvant dans ton pack FR et celui de la version de bash 3.1 utilisé sur Wary/Racy, d'autres fichiers 'mo' pour les scripts Puppy (d'origine contenus dans les packs récents d'esmourguit) sont faits pour les dernières versions 5.4/5.5 et ne fonctionnent pas sur Lucid à moins d'intégrer les scripts correspondants de ces versions mais il faudrait s'assurer qu'ils soient tous compatibles...

La localisation par 'sss' de L18L n'est plus conseillé, il est recommandé d'utiliser les scripts conçus pour fonctionner avec l'utilitaire gettext : c'est la méthode commune à l'ensemble des logiciels *nix pour les traductions...

Tu peux extraire des 'mo' et d'autres scripts traduits en dur de l'Asri 300, celui de bash est bien en version 4.1 !
Ici je visualise directement le contenu d'un 'mo' avec mc (F3) pour lire le numéro de version du projet, l'auteur et le dernier traducteur si les champs sont bien renseignés, les dates des fichiers sont trompeuses !
Le plus souvent pour les logiciels courants les versions des 'mo' même plus récentes sont meilleures...

Pour le passage à gtk 2.24 je n'ai malheureusement pas encore testé...

Edité :

La solution ultime pour les traductions et les scripts associés de la Lucid se trouve sur ce fil :
i18n-ed Gettexted Scripts In The PET (for Slacko and Lupu)
Prévoir quelques centaines d'heures Wink

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
boxR


Joined: 13 Aug 2011
Posts: 215
Location: France

PostPosted: Sun 10 Mar 2013, 12:28    Post subject: Re: Bien testée ? on va voir.
Subject description: Voyons si les bogues de la 528 ont disparu.
 

Pelo wrote:
Bogues de la 528 : pas de son

@Pelo
Tu as déjà écrit ici que tu avais des problèmes de son et que la mise à jour d'alsa pour lucid 5.2.8 avec les nouveaux drivers n'a rien résolu pour toi (pour moi si).
Ouvre un post si tu veux de l'aide.
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 2291
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 11 Mar 2013, 06:50    Post subject: la 528 capte pas la wifi
Subject description: Slacko, Racy, et DPUP exprimo captent
 

Network controller Intel Corporation Centrino Wireless-N 1030
Ethernet controller Atheros Communications Device 1083
USB Controller Texas Instruments Device 8241

Ethernet : le pilote c'est atl1c ou atl1e
Wireless : iwlagn dans iwlwifi.

Ces pilotes sont bien en mémoire, mais quand on fait loadmodule dans le wizard, pas de réseau.

Bon je capte en ethernet. Je me fait ouspillé alors que je suis un fan de la Lucid 528 et que ce qui est sensé fonctionner doit fonctionner. Il n'y a juste qu'a réparer la liaison manquante.
ça fait deux ans que je cherche, bon c'est par challenge, mais ça ne fait rien.
Messieurs les mécanos, à vous de jouer !

Pendant que vous y êtes il n'y a aucune liaison internet sur les distros antérieures 4xx et 3xx avec les pilotes cités ci-dessus.
Et pas avec la Toutou 5.5 qui vient de sortir (alors que la Racy de base connecte tout)

En virtual machine, même les vieilles captent (Toutou, DPUP, Teenpup) appararemment parce que la virtualmachine à les pilotes qu'il faut.
wary55.jpg
 Description   Wary 5.5 : les modules sont pourtant là ; ni réseau câblé, ni réseau wifi. La prochaine version le fera.
 Filesize   54.76 KB
 Viewed   185 Time(s)

wary55.jpg

Back to top
View user's profile Send private message Yahoo Messenger 
musher0


Joined: 04 Jan 2009
Posts: 3810
Location: Gatineau (Qc), Canada

PostPosted: Mon 11 Mar 2013, 09:34    Post subject:  

Salut, Pelo.

D'accord avec BoxR, tu devrais ouvrir un fil dédié aux problèmes de connexion sur telle ou telle machine. Tu auras sans doute réponse à tes questions en un rien de temps.

Ici, on aimerait bien parler de la francisation du Lucid Puppy 5.28 plus, tu vois, sans se faire interrompre...

Merci d'avance de ta compréhension.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
Pelo


Joined: 10 Sep 2011
Posts: 2291
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 11 Mar 2013, 10:06    Post subject: francisez !
Subject description: Je vais ailleurs
 

Je vais aller demander de l'aide chez les anglais, parce que pour charger mon langage pack, il me faut internet sur la wary 5.5, je suis dessus en virtual machine.
Je vais me faire voir chez les grecs !
wary55VM.jpg
 Description   
 Filesize   25.92 KB
 Viewed   183 Time(s)

wary55VM.jpg

Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0699s ][ Queries: 13 (0.0042s) ][ GZIP on ]