Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 04:36
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff)
Using pets/Sfses compiled in one pup in a different pup
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
mikeslr


Joined: 16 Jun 2008
Posts: 841
Location: Union New Jersey USA

PostPosted: Sat 26 Jan 2013, 14:37    Post subject:  Using pets/Sfses compiled in one pup in a different pup  

Hi All,
I don't compile, but do run or test various Pup(let)s as they develop. This has been my experience regarding the utility of using pets and SFSes in one Puplet that were compiled in another puplet.

First factor to consider: on which distro, if any, was the Pup(let) based. Different distros use different libs using the same name. Installation may overwrite a lib, breaking the application which used it, or try to use an existing lib which is slightly different and so unusable. Trying to use an SFS built in a different Pup is safer than installing a pet from a different Pup. The SFS may not work, or interfere with other apps, but unloading it will eliminate the conflict. Uninstalling a problem pet doesn't reinstall libs which were over-ridden. If you have a favorite pet, you may want to use one of the apps to convert it to an SFS.
Rule 1: Before installing a pet from a different Puplet ALWAYS backup your SaveFile. If you have a Full install, don't install pets from other puplets. Or set up a second version of your Puplet as a frugal install and test the pet there first.
Rule 2: Hardware specific drivers --such as for graphic cards and wireless adapters-- are kernel dependent. Consequently, a graphic driver compiled in, for example, Version A of Exprimo using Kernel A, probably won't work in Version B of Exprimo using Kernel B. But it might work in a version of Precise using Kernel A. The first post in a puplet's thread will usually tell you what kernel was used.
Wary, Racy, Saluki, Carolina and 'lina-lite are T2 builds from sources, with Saluki, and the Carolinas being themselves based on Racy. Their pets may, but probably won't, work in non-T2 Pups. Saluki pets usually work in the Carolinas. Usually Racy and wary pets will work in Saluki. Insufficient experience at present to say anything about Racy and wary pets under the Carolinas.
Perhaps strangely, pets built in Puppy 4.31 --also a T2 build--will often function in any Pup. But they may overwrite libs, so see Rule 1.
Slackos are based on Slackware. Their pets will usually only work in other Slackos.
Lucid and Lupu were based on Ubuntu 10 & 11, Precise is based on Ubuntu 12. Exprimo is based on debian squeeze. But the Ubuntus, themselves, were based on debian or often employed debian libs. Its rare that a pet compiled in Lucid, Lupu, Precise or Exprimo won't function in the others of this group, except to some extent newer pets are not backward compatible with older pups. Warning, see Rules 1 & 2.
FatDog 64 and LighthousePup 64. I have little experience with these Puplets. Although I have a 64-bit computer, my testing of both indicated only an insignificant speed advantage. Currently I prefer the simple windows managers and more extensive software available in the 32-bit pups. It is my understanding that both Fatdog 64 and LighthousePup 64 can run 32-bit pets & sfses but only if a pet has been installed or an sfs loaded enabling them to do so. It is further my understanding that while older versions of these Puplets were T2 builds, newer versions are based on slackware. Someone can correct me if I'm wrong. Warning, see Rules 1 & 2.
64-bit pets and sfses will not run under 32-bit puplets.
Wine is an application interface layer that enables you to run some XP applications. It is not dependent on which puplet you are using, except that a 64-bit wine won't run in a 32-bit puplet, and a 32-bit wine requires the installation of a pet or loading of an sfs enabling the use of 32-bit applications before you can uses them in a 64-bit puplet. Once wine is installed/loaded, almost all portable applications will run under 32-bit wine. Are there 64-bit portable xp programs? Your guess is as good as mine. Two portable xp applications I usually install are 7zip and Foxit Reader. I'm not sure that Linux (de)compression apps have caught up to 7zip. Portable Foxit Reader is currently superior to Linux pdf readers, including the Linux version of Foxit Reader, as the XP version permits you to highlight and annotate texts. Before trying to install non-portable xp programs, see what the wine organization has to say about their usability, and what advice it gives regarding pre-installation requirements. Portables do not have to be installed in the .wine directory you'll find by opening your file manager to root and showing hidden files. That's where they'll be installed by default. I run portables from /mnt/home by placing the setup file in its own directory there and installing it to that directory. You'll find a post under my signature explaining how to create desktop icons and adding them to menus. I've had less success trying to run non-portables from /mnt/home. XP programs can safely be tested under wine in any pup. If it doesn't work, or is no longer wanted, you can just delete the directory into which they've been installed. If you didn't create a directory outside of wine, you find the program's directory was installed to /.wine/drive_c/Program Files. Portables don't write to wine's imitation XP registry. Non-portables do and just deleting the folder will not remove the registration entries, but they take up little space and appear to do no harm. I've never bothered to use wine's uninstall module. But there are only two non-portable xp programs I frequently use.

mikesLr
Back to top
View user's profile Send private message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Tue 12 Mar 2013, 11:06    Post subject:  

.
Last edited by simargl on Sun 01 Sep 2013, 10:39; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Karl Godt


Joined: 20 Jun 2010
Posts: 3982
Location: Kiel,Germany

PostPosted: Thu 21 Mar 2013, 23:49    Post subject:  

Quote:
Perhaps strangely, pets built in Puppy 4.31 --also a T2 build--will often function in any Pup. But they may overwrite libs, so see Rule 1.

The main hurdle to run pets or sfs in another Puppy Version is the GLIBC-VERSION .

Since Puppy 4 is GLIBC-2.6.1 these programs likely will run in any later Puppy with GLIBC-2.7 and above.

Slacko already has GLIBC-2.13 which is higher than the one of Puppy-Lupu-5 that has GLIBC-2.11.x , so won't run on Lupu . But actual Wary-5 and Racy-5 have GLIBC-2.10.x and likely will run also in Lupu environment , though Lupu is older but relies on the Ubuntu GLIBC.

GLIBC is a little beast to compile, much more difficult than the kernel . Compiling GLIBC is safest having a static toolchain of gcc, make, binutils, coreutils, find, busybox and probably some more , since installing would break many needed tools like cp, ln, chmod which are segfaulting after the install script copies the ld-GLIBC-VERSION.so into /lib , even if it is the same GLIBC Version but different compile options.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0624s ][ Queries: 12 (0.0082s) ][ GZIP on ]