Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 17:41
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Sound not working (Radeon HD 6250/6310 chip) (Solved)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
Kerry Blue

Joined: 19 May 2012
Posts: 24

PostPosted: Tue 12 Mar 2013, 16:01    Post subject:  Sound not working (Radeon HD 6250/6310 chip) (Solved)  

Hi,

I use a computer with Radeon HD 6250/6310 chip. I read that more users of this chip have problems with sound.

I tried all sorts of Puppy on this machine (Saluki, Racy, Precise 5.5), but it just doesn't work.
I think that the problem is that HDMI is set as dafault soundcard. (alsamixer shows this). I tried blacklisting this, by altering the blacklist.conf file and adding this line:

blacklist snd-hda-codec-hdmi

However, when I reboot, this line doesn't show any more in the blacklist.conf file.

Any idea why this line disappears after a reboot and/or what more I could do?
It works fine under Linux Mint, so the hardware is OK.


KB

Last edited by Kerry Blue on Tue 12 Mar 2013, 17:27; edited 2 times in total
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3982
Location: Kiel,Germany

PostPosted: Tue 12 Mar 2013, 16:37    Post subject:  

Watch out for Puppy scripts writing there . Read /etc/rc.d/rc.sysinit and all the scripts it calls by udev.rules files.
Back to top
View user's profile Send private message Visit poster's website 
Kerry Blue

Joined: 19 May 2012
Posts: 24

PostPosted: Tue 12 Mar 2013, 16:46    Post subject:  

After many hours I just solved it!!!! (boy, am I happy)

Change the following entries in /usr/share/alsa/alsa.conf with an editor from value "card 0" to "card 1":

So inside /usr/share/alsa/alsa.conf change these lines, from :

defaults.ctl.card 0 to defaults.ctl.card 1
defaults.pcm.card 1 to defaults.pcm.card 1
defaults.rawmidi.card 1 to defaults.rawmidi.card 1
defaults.hwdep.card 1 to defaults.hwdep.card 1
defaults.timer.card 1 to defaults.timer.card 1

Then run alsaconf and select the right soundcard: I now have sound!

The only thing is: the volume can't be lowered by using the volume control slider on the taskbar: it's always set at 65295% and can't be lowered.

Which files control the volume and can be altered in a similar way?

Last edited by Kerry Blue on Wed 13 Mar 2013, 06:11; edited 8 times in total
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 4133
Location: World_Hub

PostPosted: Tue 12 Mar 2013, 18:34    Post subject:  

Mmmm.. perhaps this allows and saves it? This may help..
Back to top
View user's profile Send private message 
npierce

Joined: 28 Dec 2009
Posts: 858

PostPosted: Tue 12 Mar 2013, 20:39    Post subject:  

If the configuration interface for retrovol hasn't changed since Racy 5.2.2, this might work:

1. Right-click on the speaker icon in the task bar.

2. Choose Config Window from the menu that pops up.

3. Click the Hardware tab.

4. Change Sound Card from "hw:0" to "default".
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11180
Location: Arizona USA

PostPosted: Tue 12 Mar 2013, 23:50    Post subject:  

Kerry Blue, you marked this as solved, but gave us no idea how the problem was solved. Confused
Back to top
View user's profile Send private message 
Kerry Blue

Joined: 19 May 2012
Posts: 24

PostPosted: Wed 13 Mar 2013, 05:17    Post subject:  

> you marked this as solved, but gave us no idea how the problem was solved.
Yes I did: by changing the "card 0" to "card 1" values in the /usr/share/alsa/alsa.conf file.
See my posting above. I edited it for clarity.

Just a short guide for people who read this because they have a similar problem with the above soundchip:

The problem is indeed that Puppy (and maybe other Linuxes too) selects HDMI as default soundcard. You can check this by starting alsamixer in a terminal and in Alsamixer you press F6 to select the soundcard. Then you choose the "default" option so you can see which card is default. If it's marked HDMI, then the above will help you.

NOTE: changing the Soundcard in Puppy's Sound Setup menu won't help! HDMI stays default, whatever you change there. So only manually editing alsa.conf and setting the card settings mentioned above from value "0" to "1" will do the trick.

I found these values in a terminal , typing lspci -vv. You can check if you have the same setup:

(Card 0)
00:01.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310] [1002:1314]

(Card 1)
00:14.2 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) [1002:4383] (rev 40)

Last edited by Kerry Blue on Wed 13 Mar 2013, 05:49; edited 3 times in total
Back to top
View user's profile Send private message 
Kerry Blue

Joined: 19 May 2012
Posts: 24

PostPosted: Wed 13 Mar 2013, 05:38    Post subject:  

@npierce : many thanks! That worked fine.

What was it pointing to , using hw:0 , btw. HDMI?

Also many thanks to all others who responded. I'll look into your suggestions.
Back to top
View user's profile Send private message 
npierce

Joined: 28 Dec 2009
Posts: 858

PostPosted: Wed 13 Mar 2013, 08:25    Post subject:  

You're welcome.

Kerry Blue wrote:
What was it pointing to , using hw:0 , btw. HDMI?

Yes, hw:0 points to card 0, which in your case was HDMI.

You could probably also use "hw:1", but I prefer "default" since it follows whatever you set for the default card in alsa.conf or asound.conf. (Also, retrovol will crash on a Puppy that only has a single card, if set to "hw:1".)
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11180
Location: Arizona USA

PostPosted: Wed 13 Mar 2013, 09:00    Post subject:  

Let me see if I got this straight. Laughing Your motherboard has onboard HDMI sound, which Puppy tried to use but didn't work, so you switched Puppy's sound configuration to use a sound card that's in the PCI bus. Is that correct?
Back to top
View user's profile Send private message 
Kerry Blue

Joined: 19 May 2012
Posts: 24

PostPosted: Wed 13 Mar 2013, 13:21    Post subject:  

I don't have HDMI. Therefore I want to use the other sound card that the computer has onboard, but Puppy wouldn't let me: it was impossible to make the other video card the default device, so I didn't have sound.
Back to top
View user's profile Send private message 
CLAM01

Joined: 22 May 2010
Posts: 79

PostPosted: Sat 16 Mar 2013, 19:09    Post subject:  

Flash,

This Radeon sound problem arises on chipsets that accompany, among others, AMD C-series 64-bit processors (C-50 and C-60). Current Puppies appear to recognize two sound driver possibilities, listing one as 0, and one as 1. The 0, which is the wrong one, is loaded, while the 1, which appears to be the correct one, is rejected. It is the system rejection, causing refusal to load the right driver, that causes difficulty. The system will not load the right driver when it is selected for alternative. The system reverts to the wrong, the 0 driver, causing the problem to persist. Kerry Blue's fix forces override of the system's wrong choice, though the 'right' choice may not be wholly right, since volume control is absent.

The problem can be recognized on Pup install by a combination of the sound not working together with a sound percentage 'tip' message stating "volume: 65950%", or similar.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0714s ][ Queries: 12 (0.0048s) ][ GZIP on ]