Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 21:07
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
"Sorry, cannot start X...
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Author Message
danleff


Joined: 08 May 2005
Posts: 294
Location: Albany, NY

PostPosted: Sun 15 May 2005, 17:49    Post_subject:  

These older cdrom drives are not capable of booting cdrw media and in some cases, home burned cd-r media. I just had to burn Puppy 1.0.2 RC2 three times to finally get it to work on my system, at 1X speed.

The same issue as well with the other burned cd's not being able to find usr_cram.fs on the cd-r disk, as well as X until I burned it at 1X. It looks like a drive read-seek error on the previous 2 burns, so /usr is not loaded.

cp: /usr: no such file or directory error on boot.

Burn them slow guys...at 60 mb for the iso file, it only takes a few more minutes!

...and mine is a newer dvd/cdrw drive. So, burn speed and the quality of the drive are two variables.

_________________
I love it when a plan comes together

--Hannibal Smith
Back to top
View user's profile Send_private_message Visit_website 
newuser
Guest


PostPosted: Sun 15 May 2005, 18:44    Post_subject:  

yes, i have tried with and without the usb key after deleting the 001 from the key. there was no 001 file on my harddrive though.

now it's just giving me the same error booting with or w/o the usb key.
Back to top
sindi

Joined: 16 Aug 2009
Posts: 395

PostPosted: Sat 25 Jan 2014, 16:25    Post_subject: booting puppy 1.07 with loadlin, can't find usr_cram.fs
Sub_title: frugal, from hda1,
 

loadlin vmlinuz initrd=image.gz root=/dev/ram0
(and I also tried pmedia=idehd pdev=hda1 psubdir=pup107 and pfile=/dev/hda1/pup107/usr_cram.fs)

Boots to CLI with error message about not finding usr_cram.fs after looking for it on (nonexistent) cdrom.

ro instead of root=/dev/ram0 got me a kernel panic and message about not finding init.

I found a suggestion to use tiny.exe instead of loadlin.exe.
tiny.exe has been replaced by some large graphical loader.
I am used to loadlin. It works in puppy 3 and 4.

I want OSS for a Winbook 300Mhz where ALSA sound won't work but I know OSS sound does, and also ipchains (2.4 kernel). A previous puppy 1.0.x would probably be good enough if it boots.

Instructions I found were to copy the fs to /root and reboot. but this is a frugal install.

Loadlin also does not work with puppy 5. It is helpful for trying out puppies without burning a CD or editing lilo or grub.

Using a 2003 DELL D600 with USB floppy drive - puppy kept looking for files there, and found the other two files on hard drive.
Back to top
View user's profile Send_private_message 
sindi

Joined: 16 Aug 2009
Posts: 395

PostPosted: Sat 25 Jan 2014, 18:07    Post_subject: Booted puppy 1.0.7 to CLI with loadlin
Sub_title: Mounted usr_cram.fs -o loop
 

Boot as above, when told usr_cram.fs is not mounted on /usr
mkdir /mnt/hda1
mount -t vfat /dev/hda1 /mnt/hda1
cd /mnt/hda1/pup107
mount -o loop usr_cram.fs /usr

This produces a page of errors messages about filesystems and CD-ROM
but mountts the files on /usr/

xorgwizard, choose Xorg (Xvesa not usable with i810), choose 1024x768x16,
black screen (crash), implying Xorg could not handle my i810 2003 video.

Turn off computer.

By running 1.0.7 (2005) from live CD before this I determined that
(1) it uses iptables not ipchains which I was after
(2) it does not support 2005 wireless cards (cardbus with WPA2 or even without),
mainly only orinoco and aironet and variants.
(3) wizard did not identify my card and assign it a module but I had to load it manually (broadcom).
(4) no sound wizard .
(5) I won't be using Puppy 1 so no need to boot it with loadlin and learn how to make Xorg behave on here.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0487s ][ Queries: 12 (0.0068s) ][ GZIP on ]