Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 25 May 2015, 08:03
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Creating SFS file from txz slacko repo packages
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 15 Jul 2010
Posts: 45

PostPosted: Tue 12 Mar 2013, 20:36    Post_subject:  Creating SFS file from txz slacko repo packages  

OK guys...I have been trying to create an SFS file from the 16 txz files that come down from the slacko repos for the GnuCash application.

I am using the mksquashfs utility and have successfully created the gnucash.sfs file. However, trying the run gnucash results in his error message:

"gnucash: error while loading shared libraries: libgnc-gnome.so.0: cannot open shared object file: No such file or directory."

What I have discovered is that there is a file named:
libgnc-gnome.so.0.0.0 within the sfs file.

So it seems that gnucash is asking for the file to load but is asking for it's shortened name

Any insight on how to fix this problem?

I am running a frugal install of puppy_slacko_5.5 on a fat32 formatted USB drive.
Back to top
View user's profile Send_private_message 

Joined: 18 Feb 2013
Posts: 490

PostPosted: Tue 12 Mar 2013, 20:57    Post_subject:  

Try to make a symlink libgnc-gnome.so.0 to the file libgnc-gnome.so.0.0.0 inside the sfs or inside the OS for testings.

Might work.

If not you got to search for the lib.


LazY Puppy Home
The new LazY Puppy Information Centre

Back to top
View user's profile Send_private_message 

Joined: 11 Oct 2008
Posts: 7937
Location: qld

PostPosted: Tue 12 Mar 2013, 21:30    Post_subject:  

Standard slackware packages do not contain any symbolic links. You have to run the install/doinst.sh file relative to where you unpack the package. If you take a look at install/doinst.sh you will see that many symbolic links will be made on installation. I have a very rough script to do just what you want.

echo $PROG

[ ! "$1" ] && echo "provide a package name" && exit
[ "$2" = "xz" ] && COMP="-comp xz" || COMP=""

[ -d $DIR ] || mkdir $DIR
touch $DIR/$DESC

for i in `ls|grep -iE "txz$|tgz"|grep -v "$PROG"`; do
  cp -af $i $DIR
  (cd $DIR
  echo -n "$i "
  tar xf $i
  [ "$?" = 0 ] || exit $?
  [ -f install/doinst.sh ]&& . install/doinst.sh
  cat install/slack-desc >> $DESC
  rm $i)
echo "mksquashfs $DIR $SFS $COMP"

mksquashfs $DIR $SFS $COMP
[ "$?" = 0 ] && echo "Success!" || echo "FAILED :("

I place the script and the packages in a folder and run the script. It also concatenates all the descriptions (slack-desc) into one big description, kind of a manifest.


EDIT: also, be aware that trying to make symlinks while on vFAT will fail, you need to do it on a linux filesystem AND vFAT messes up the permissions, so does NTFS.

Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 

Joined: 15 Jul 2010
Posts: 45

PostPosted: Thu 14 Mar 2013, 20:44    Post_subject:  

I've been working on this off and on for the past couple of days with no luck.

I first reformatted my USB drive to ext2 and frugal-ed slacko 5.5 onto it again.

Micko, I tried using your script but I couldn't get any sort of response out of it when I tried to execute it. (I saved it as "create.sh" and gave it the appropriate executable permissions).

I tried running it from the directory that holds all 16 of the compressed "txz" files...no go.

Then I tried extracting all 16 into a separate directory and running your script there after all were extracted..no go.

(no go = no terminal window or any other indication it was running)

After these attempts I simply tried running the doinst.sh file manually after each txz file was extracted. That resulted in symlinks being created in the install directory but at the end of the process all symlinks were red/broken. (I extracted all 16 txz files into the same top level directory so that the doinst.sh file was rewritten each time. Then I gave each new doinst.sh file execute permissions and ran it.)

I have a feeling I am in a little over my head as I am not well versed in scripting.

As a side note, I did try to simply install Gnucash from the repository (not make an sfs file). Everything seemed to install but upon execution I got the same error message that I initially posted about above.

Thanks in advance for any other hand-holding you are willing to do with me.
Back to top
View user's profile Send_private_message 

Joined: 15 Jul 2010
Posts: 45

PostPosted: Fri 30 Aug 2013, 09:21    Post_subject:  

Without being able to resolve this I switched over to Precise 5.6.1. where Gnucash works well with the old 'pet' that I had used with Lucid in the past.

If anyone ends up having success with GnuCash under Slacko please let me/us know.
Back to top
View user's profile Send_private_message 
Karl Godt

Joined: 20 Jun 2010
Posts: 4026
Location: Kiel,Germany

PostPosted: Fri 30 Aug 2013, 22:27    Post_subject:  

(no go = no terminal window or any other indication it was running)

Sometimes USER is not able to see the console icon .
In Germany KONSOLE usually means PlayStation or XBOX .

Tired of these .

For the 98,001st time here on the forum :
Open a rxvt , urxvt or xterm console in that directory by right click in the rox filer window and navigating to "Window > Terminal here" and type :

INFO : The code tag is for proper rendering in the browser using Monospace font .

«Give me GUI or Death» -- I give you [[Xx]term[inal]] [[Cc]on[s][ole]] .
Macpup user since 2010 on full installations.
People who want problems with Puppy boot frugal Razz
Back to top
View user's profile Send_private_message 

Joined: 23 Nov 2006
Posts: 10541

PostPosted: Sat 31 Aug 2013, 07:12    Post_subject:  

After messing with gnucash which i decided was a bloated awkward piece of stuff I grabbed mmex... small and neat and seemed to do the job

So the slack in slackware refers to the state of their packaging...I always suspected this lol... On the 3.5 occasions I have used their stuff it was with a tgz2lzm so I never noticed the absense of sysmlinks


debian for a gnucash source?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0629s ][ Queries: 12 (0.0039s) ][ GZIP on ]