Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 31 Aug 2014, 06:37
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Upup Precise 3.8.3.1 created by using up-to-date Woof
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 4 of 12 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 10, 11, 12 Next
Author Message
artsown

Joined: 12 Sep 2012
Posts: 147

PostPosted: Thu 14 Mar 2013, 13:10    Post_subject:  

Ok, I edited my "how to" on the wireless power management bug,
altering the procedure to say that a reboot should be done
after placing the script in /root/startup

Art
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4231
Location: Gatineau (Qc), Canada

PostPosted: Thu 14 Mar 2013, 13:16    Post_subject:  

Oops, meant for the wheezy thread. Sorry.
_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
James C


Joined: 26 Mar 2009
Posts: 5722
Location: Kentucky

PostPosted: Thu 14 Mar 2013, 19:38    Post_subject:  

Fresh manual frugal install on the old P4 test box. No problems....everything working well ootb.

For whatever reason every release with a 3.8.X kernel has a problem detecting and/or mounting flash drives on my older hardware (in particular my main Athlon XP box) but no such trouble on newer boxes.Or maybe it's a problem with AMD. Anyway...no problems on this box.

# report-video
VIDEO REPORT: Upup Precise, version 3.8.2

Chip description:
VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

Requested by /etc/X11/xorg.conf:
Resolution (widthxheight, in pixels): 1024x768
Depth (bits, or planes): 24
Modules requested to be loaded: dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
Driver loaded (and currently in use): intel
Loaded modules: dbe dri dri2 extmod fb glx kbd mouse record

Actual rendering on monitor:
Resolution: 1024x768 pixels (270x203 millimeters)
Depth: 24 planes

...the above also recorded in /tmp/report-video
#
-Computer-
Processor : Intel(R) Pentium(R) 4 CPU 2.80GHz
Memory : 2592MB (242MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Thu 14 Mar 2013 06:41:50 PM CDT
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Mesa DRI Intel(R) 865G x86/MMX/SSE2
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : ICH4 - Intel ICH5
Precise-3.8.2.jpg
 Description   
 Filesize   51.81 KB
 Viewed   960 Time(s)

Precise-3.8.2.jpg

Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2086
Location: Ontario Canada

PostPosted: Thu 14 Mar 2013, 21:39    Post_subject: Upup Precise 3.8.2 created by using up-to-date Woof  

video-info-glx 1.5.2 Thu14Mar 2013 on Upup Precise 3.8.2 Linux 3.8.2-upup i686
0.0 VGA compatible controller: Advanced Micro Devices
[AMD] nee ATI RV530 [Radeon X1600]
oem: ATI ATOMBIOS
product: RV530 01.00
X Server: Xorg Driver: radeon
X.Org version: 1.11.3
dimensions: 1440x900 pixels (380x238 millimeters)
depth of root window: 24 planes
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RV530
OpenGL version string: 2.1 Mesa 8.0.4
AMD Athlon(tm) 64 Processor 3300+
Core 0: @2411 MHz
Memory 1553MB (106MB used)
Multimedia
Audio Adapter CX2341[56] - IVTV-0
Audio Adapter USB-Audio - Sound Blaster X-Fi Go! Pro

There is no volume control in the tray but sound levels can be adjusted
in applications and with alsamixer.
382 is working well on this 7 or 8 (forget) year old desktop pc.
screenshot.jpg
 Description   
 Filesize   42.51 KB
 Viewed   922 Time(s)

screenshot.jpg

Back to top
View user's profile Send_private_message 
Ted Dog


Joined: 13 Sep 2005
Posts: 2314
Location: Heart of Texas

PostPosted: Thu 14 Mar 2013, 23:22    Post_subject: MOUSE FROZEN at boot gave up after 6 tries  

This is a problem with the current crop of precise puppy and its WOLF spins, does not occur in Ubuntu Precise.
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5722
Location: Kentucky

PostPosted: Thu 14 Mar 2013, 23:46    Post_subject:  

Possibly related to some of these problems....... some broken drivers in the 3.8.x kernels was reported in the Slackware changelog of March 12...
ftp://ftp.osuosl.org/pub/slackware/slackware-current/ChangeLog.txt

Quote:
For this kernel update I decided to go with 3.7.10. Yeah, the 3.7 series
is EOL, but I've heard about some broken drivers in 3.8.x that make me
hesitate to push forward.
Back to top
View user's profile Send_private_message 
Rangan Masti

Joined: 01 Jan 2013
Posts: 8

PostPosted: Fri 15 Mar 2013, 11:31    Post_subject:  

Hey !
Good work !!! Smile
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 15 Mar 2013, 18:06    Post_subject:  

Radky. My first attempt:
http://www.spinics.net/lists/netdev/msg228552.html
broadcom-tg3-driver-update-0.0.1.pet
Description 
pet

 Download 
Filename  broadcom-tg3-driver-update-0.0.1.pet 
Filesize  65.81 KB 
Downloaded  110 Time(s) 
Back to top
View user's profile Send_private_message 
radky

Joined: 02 May 2010
Posts: 448

PostPosted: Fri 15 Mar 2013, 18:25    Post_subject:  

pemasu wrote:
Radky. My first attempt:
http://www.spinics.net/lists/netdev/msg228552.html

Quote:
# cat /sys/class/net/eth0/statistics/rx_bytes
3430539
# cat /sys/class/net/eth0/statistics/tx_bytes
345355

Excellent! Smile

Thanks pemasu
Back to top
View user's profile Send_private_message 
ETP


Joined: 19 Oct 2010
Posts: 535
Location: UK

PostPosted: Sat 16 Mar 2013, 06:11    Post_subject: Upup Precise 3.8.2 created by using up-to-date Woof
Sub_title: Testing.
 

Fresh manual frugal install to vfat/f2fs USB2 stick.Syslinux 4.04 boot with kernel held on 16Meg 1st partition and savefile (ext4) & sfs files on 2nd f2fs partition.
Initial boot to desktop with working sound,wired ethernet and Nouveau driver at correct res.
The following pets & sfs were installed and tested. (DVB-T works fine)

    PETS
    PupControl-2.3|PupControl panel
    PupClockset-1.9.2|PupClockset manager
    tempiconsvg-0.17-i486|no description provided
    pupsaveconfig-2.2.5|PupSave personal storage setup
    smplayer-0.8.3-precise|Add file(s) to the SMPlayer playlist
    smtube-1.5-precise|Search and download videos from YouTube
    lxtask-0.1.4|LXTask task manager
    chromium-25.0.1323.1-i686-1sl|Browse the Web
    flashplayer11-11.2.202.275|Adobe Flash Player 11 browser plugin and Preferences. Note, this may not work on older PCs, use instead an earlier 11.x or even 10.x
    tickr-0.6.0-i686|RSS Feed Reader
    thunderbird-16.0.1|Thunderbird mail reader
    faenza_lrx_new|
    vlc-2.0.5_two_flower|Open with VLC media player
    xdotool-2.20110530.1-3|no description provided
    Roxterm-1.17.1-Lucid|Use the command line with copy & paste
    video-info-glx-1.5.1-noarch|OpenGL Graphics/CPU Report
    PupSnap-1.8_Scrot-0.8_32Bit|PupSnap screen capture
    SFS
    qt-4.8.2.sfs

Many thanks for this fine Pup. No issues so far.
image-1.jpg
 Description   
 Filesize   70.2 KB
 Viewed   646 Time(s)

image-1.jpg


_________________
Regards ETP
Accessibility Pups: -- Magoo -- The Pup With No Name -- MouseCam -- Obedient
Back to top
View user's profile Send_private_message 
recobayu


Joined: 15 Sep 2010
Posts: 112
Location: indonesia

PostPosted: Sat 16 Mar 2013, 07:11    Post_subject:  

i checked the md5 is right, but when i run in virtualbox, i got this message.
http://2.bp.blogspot.com/-WNnVIdz3eZo/UURT-D0NaFI/AAAAAAAAA5c/O4Q1xdLZY8w/s1600/error.png
do the iso file corrupt?

Edited: Ok Pemasu, I link it now. Thank you, I realize now that the problem is the virtualbox, after I copied 3 files: vmlinuz, initrd.gz, and the .sfs into a folder, and I modified menu.lst. and this puppy walk without problem.
Thank you for this great puppy!
Very Happy

Edited_time_total
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 16 Mar 2013, 07:22    Post_subject:  

recobayu.
I know nothing about virtualboxes and virtual machines. For me...only way is that I get more reports of the succes or failure and also suggestions...if there is something wrong with kernel or base build.

These too wide pics give problems also...they screw the thread page.

http://2.bp.blogspot.com/-WNnVIdz3eZo/UURT-D0NaFI/AAAAAAAAA5c/O4Q1xdLZY8w/s1600/error.png

I suggest placing url link instead of img link so that the page will not be screwed.

Cheers.
Back to top
View user's profile Send_private_message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Sat 16 Mar 2013, 10:45    Post_subject: Can't compile rts5220 driver in precise 3.8.2  

Hi Pemasu,
excuse me for this message but I can't compile rts5229 driver in Upup precise 3.8.2., that instead compiles it regularly in Upup 3.7.2 and 3.2.29.
I don't know why... perhaps I need something else?
I installed devx.sfs and kernel source.sfs, MAKE command works but...

I enclose source code for driver.

Can you tell me something about this?

P.S. thanks for upgrading wacom driver, my notebook thanks Smile
rts5229.tar.bz2
Description  Driver for Realtek RTS5229 PCI Card Reader
bz2

 Download 
Filename  rts5229.tar.bz2 
Filesize  65.6 KB 
Downloaded  101 Time(s) 
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 16 Mar 2013, 11:33    Post_subject:  

Fabio T. Supporting module is missing.
It needs this one in kernel config:
CONFIG_MFD_RTSX_PCI=m

I compile the missing supporting module and then rts5229 should compile...and it is already in kernel source. I can compile the kernel included one as module on same time.

I will be back soon.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 16 Mar 2013, 12:54    Post_subject:  

Fabio T. Your missing module or compile problem finding has revealed more serious problem with multifunction, memory stick and sdhc cards. it seems I have missed some vital modules.
Compiling them afterwards is not possible. The compiled modules are not compatible, there is symbol errors which means they are not accepted by this kernel.
Okay. The missing modules are crucial enough that I will recompile the kernel and then I will create new build.

Now comes the question. Should I update to the 3.8.3 kernel. It has a lot fixes. For example radkys needed somewhat broken tg3 has been fixed in it straight and I suppose there as some other important fixes also.
I think I do the decision tomorrow. If someone has opinion or knowledge, the arena is all yours.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 4 of 12 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 10, 11, 12 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0930s ][ Queries: 13 (0.0075s) ][ GZIP on ]