Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 09:39
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Portabase Database for Lucid
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Author Message
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Fri 15 Jul 2011, 16:55    Post subject:  Portabase Database for Lucid  

I made a .pet for this little database, including the missing libs and menu entry. Download it from here http://puppylinuxstuff.meownplanet.net/DaveS/
username puppy
password linux

You need the portabase.pet. The other .pet, portabaselibs.pet is only required if you have installed another version and it is not working.


_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
jakfish

Joined: 18 Jul 2008
Posts: 756

PostPosted: Sat 16 Jul 2011, 08:44    Post subject:  

Well done, many thanks. I use portabase in both Puppy and Windows, and also in my Sharp Zaurus (qtopia linux).

If it had ever been ported to Symbian, I would've kept my E90 phone. I never found anything closer to the old Psion Date program.

Jake
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sat 16 Jul 2011, 13:37    Post subject:  

Continuing on from this, Jabu2 has made the following valid point in a PM:

More than almost any other piece of software, it may become critical - and any functional failure of a database may represent a large loss (time and effort) to the user.

Databases tend to enlarge in every direction, with time. Rarely does a database end up the way it started out. Design of a database is normally more important than choice of software to run it.

I don't know if Portabase (which seems to have reported no news for a year now) is able to handle what this, or any other user, needs.

Personally, on puppy, if you can load/use LibreOffice or Open Office, then that suite's ability to provide a database function should be mentioned. Both have SFS, and one or both will stay the course, at source and originally and in Puppy SFS format.

IMHO both are pretty solid even with quite sizeable data sets. I haven't tried Portabase - why would you, unless you couldn't use LibreOffice?


There are of course many others, including the new Calligra but it's a bit new for me at this stage. OK to try, but not to use for a real database which one may need to be be ongoing and robust for many years.


This is valid advice... Horses for courses.

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
tatamata

Joined: 02 May 2010
Posts: 63

PostPosted: Wed 20 Jul 2011, 15:18    Post subject:  

Maybe you could try MightyQuery as well.
http://murga-linux.com/puppy/viewtopic.php?t=68596

It is truelly portable database with absolutelly no dependencies...
Back to top
View user's profile Send private message 
Colonel Panic


Joined: 16 Sep 2006
Posts: 1511

PostPosted: Sun 31 Jul 2011, 08:53    Post subject:  

Thanks for the new packages.

As for the question of Portabase's adequacy, which has been raised in this thread, I can see how it might come up wanting if you want to use a database for a lot of complex relational stuff, but for what I want to do with a database (keep a database of local dialect words and meanings, and also several files of names and contact details), it fits the bill perfectly and it's also compact and easy to set up and use.

I suspect many other Puppy users would find it suitable for their needs too. I've tried and failed to get the database in Open Office to work, and from what I gather from forums elsewhere it's not an easy thing to learn even if you need to.

Someone also mentioned the possibility of failure in Portabase, and the answer's simple; back up both your Portabase data files (extension .pob), and also and more regularly, the file you get when you export the data in your updated ones to a comma-delimited text file (ending in .csv). Then, if the database fails at any time, you can reconstruct it by loading an old copy of the data file, deleting the data in it (but still keeping the database structure) and then importing the newest .csv file you've got into it.

I should honestly buy Warren a beer (at least) for all the time and effort Portabase has saved me since I started using it, and for what it's enabled me to do. I hope he still looks in here.

_________________
Stone Pentium IV (2.4 GHz), 2 GB of RAM, 160 GB hard drive running Puppy Slacko 5.9.3, Puppy EmSee v2.1, Puppy 4.31 Workhorse, Puppy Carolina 1.2, Puppy Legacy OS2 LTS and Puppy Upup Raring 3.9.9.2.

Last edited by Colonel Panic on Mon 23 Jan 2012, 17:41; edited 1 time in total
Back to top
View user's profile Send private message 
Colonel Panic


Joined: 16 Sep 2006
Posts: 1511

PostPosted: Sun 08 Jan 2012, 09:37    Post subject:  

A quick update; the Portabase pet doesn't seem to work in Slack-based Pups such as PuppEX (the one I'm using now). What does work is to install portabaselibs. pet and then portabase.deb (the Debian version of Portabase).
_________________
Stone Pentium IV (2.4 GHz), 2 GB of RAM, 160 GB hard drive running Puppy Slacko 5.9.3, Puppy EmSee v2.1, Puppy 4.31 Workhorse, Puppy Carolina 1.2, Puppy Legacy OS2 LTS and Puppy Upup Raring 3.9.9.2.
Back to top
View user's profile Send private message 
Colonel Panic


Joined: 16 Sep 2006
Posts: 1511

PostPosted: Tue 09 Oct 2012, 11:56    Post subject:  

I've just seen that the Portabase devs have released a new version of their excellent database program (2.1), so I've downloaded it and am using it now. 2.1 works well in Debian and should work in Puppy too with the portabaselibs pet.

It looks good and works well except that at the moment it's opening my files in read-only mode. This isn't a problem at the moment but may be in future when I want to do some editing.

_________________
Stone Pentium IV (2.4 GHz), 2 GB of RAM, 160 GB hard drive running Puppy Slacko 5.9.3, Puppy EmSee v2.1, Puppy 4.31 Workhorse, Puppy Carolina 1.2, Puppy Legacy OS2 LTS and Puppy Upup Raring 3.9.9.2.

Last edited by Colonel Panic on Sat 20 Oct 2012, 03:03; edited 2 times in total
Back to top
View user's profile Send private message 
Dingo


Joined: 11 Dec 2007
Posts: 1415
Location: somewhere at the end of rainbow...

PostPosted: Tue 09 Oct 2012, 13:30    Post subject:  

try my QT4-STATIC build (no dependencies needed)
- http://www.fileden.com/files/2008/3/19/1824460/portabase
- http://ubuntuone.com/5NZlVXx8bEdJFU4xlUVSLV (mirror)

built in Puppy 5.2.5 with QT 4.7.3 STATIC

_________________
replace .co.cc with .info to get access to stuff I posted in forum
dropbox 2GB free
OpenOffice for Puppy Linux

Last edited by Dingo on Sat 04 May 2013, 09:31; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Colonel Panic


Joined: 16 Sep 2006
Posts: 1511

PostPosted: Tue 09 Oct 2012, 17:09    Post subject:  

Dingo wrote:
try my QT4-STATIC build (no dependencies needed)
- http://www.fileden.com/files/2008/3/19/1824460/portabase

built in Puppy 5.2.5 with QT 4.7.3 STATIC


Many thanks, I will!

Cheers,

CP .

_________________
Stone Pentium IV (2.4 GHz), 2 GB of RAM, 160 GB hard drive running Puppy Slacko 5.9.3, Puppy EmSee v2.1, Puppy 4.31 Workhorse, Puppy Carolina 1.2, Puppy Legacy OS2 LTS and Puppy Upup Raring 3.9.9.2.
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1006
Location: South of Belgium

PostPosted: Fri 07 Dec 2012, 13:39    Post subject: Portabase 2.1 git 20120910  

Hi,
thanks having kept updating this post !
Portabase was what i missed till now.
Here running Pemasu's dPup-Exprimos since a few months ...so got a try running Portabase on it.
The latest version Portabase 2.1 git 20120910 might well need (...imho..!) libs from Qt4.8.0 to run on it: libQtCore, libQtXml and libQtGUI. These are present in qt4-4.8.0.sfs at Exprimo repository here:
http://smokey01.com/pemasu/Sfs/qt4-4.8.0.sfs

Here is a pet with full locale and html tutorial , without the libs.

Have fun ;->
Charlie

last edited: to tell you all about this pet ...
- I tried to compile because the forums member Dingo's static compilation has only the english locale (thanks anyway, Dingo ! Smile );
- compilation attempts failed here; so i gave up trying to compile as 2.1 binaries already exist which also seem running nicely with Qt-4-4.80.
- this is a pet arrangement using the debian's Portabase_2.1-git20120910-1-i386.deb from debian repo. The /usr/bin/portabase here is a (home-made) script launching the original 'portabase' renamed to 'portabase_2.1git20120910';
- I believe it could be the same /usr/bin/portabase (1902K) file that is available on te sourceforge portabase repo (i.e. http://ignum.dl.sourceforge.net/project/portabase/portabase/2.1/portabase_2.1-1_i386.deb whose binary is also 1902K size)
- this pet might work on other Puppies
- tested on uPup Precise 54X4 ... just that the preview is a bit "jerky" if the window size is to small when selecting File/Print Preview / icon Adjust on width.
- OK on dPup Exprimo 3.6.2
portabase_2.1-git20120910-1_i386.pet
Description  Portabase_2.1 pet WITHOUT Qt libs
pet

 Download 
Filename  portabase_2.1-git20120910-1_i386.pet 
Filesize  1.26 MB 
Downloaded  433 Time(s) 
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 4231
Location: Gatineau (Qc), Canada

PostPosted: Fri 15 Mar 2013, 18:04    Post subject:  

Hi, Charlie6.

Thanks for making this handy database utility available to Puppyists.

However, I believe you have the full libQtCore twice in the -2.0 package and in the libs package... If you put a link instead, your pet archives would be about 1,2 Mg smaller?

I also found this symbol error running the 2.1 version :
/usr/bin/portabase_2.1git20120910: symbol lookup error: /usr/bin/portabase_2.1git20120910: undefined symbol: _ZNK7QLocale11uiLanguagesEv
I suppose I don't have the proper locale installed on my computer? Thanks in advance for any insight.

Best regards.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
charlie6


Joined: 30 Jun 2008
Posts: 1006
Location: South of Belgium

PostPosted: Sun 17 Mar 2013, 16:24    Post subject:  

Bonjour Musher0 ! Very Happy

musher0 wrote:
...
However, I believe you have the full libQtCore twice in the -2.0 package and in the libs package... If you put a link instead, your pet archives would be about 1,2 Mg smaller?

this 2.1 version is free from Qt libs ...so i do not understand ... Confused
(see tree in attachment)

Quote:
...I also found this symbol error running the 2.1 version :
/usr/bin/portabase_2.1git20120910: symbol lookup error: /usr/bin/portabase_2.1git20120910: undefined symbol: _ZNK7QLocale11uiLanguagesEv
I suppose I don't have the proper locale installed on my computer? Thanks in advance for any insight.


I only used it on exprimo ... which accepts debian archives ...and the proposed .pet is derived from the portabase debian archive.
So it might not run properly on other Puppies. I tried to compile the source without success and i gave up as i found the debian archive working on exprimo.

Hope this answers your question .
Charlie
ps: i now have choosen to dig into Sqlitestudio as portabase seems no longer being supported (i did not yet have got any answer on a PM to its developper ...)
prtbase.txt.gz
Description  !!! just rename and drop the .gz extension for reading !!!
gz

 Download 
Filename  prtbase.txt.gz 
Filesize  22.43 KB 
Downloaded  268 Time(s) 
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 4231
Location: Gatineau (Qc), Canada

PostPosted: Sun 17 Mar 2013, 17:45    Post subject:  

My appologies, Charlie6.

My bad... I should've addressed the comment to DaveS, the person who packaged version 2.0.
Your version 2.1 has indeed a different packaging. (However, I cannot get it to work on my set-ups, which is why I went back to version 2.0 and found the oversight.)

BFN.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 4231
Location: Gatineau (Qc), Canada

PostPosted: Sun 17 Mar 2013, 17:52    Post subject:  

Charlie6 wrote:
> ps: i now have choosen to dig into Sqlitestudio as portabase seems no longer being supported (i did not yet have got any answer on a PM to its developper ...)

Well, about that... My motivation would have fallen flat too, if my international call for funding a web version of my "popular" program had reined in only 150 $ or so... Humans are free-riders, aren't they?

BFN.

m0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
charlie6


Joined: 30 Jun 2008
Posts: 1006
Location: South of Belgium

PostPosted: Mon 18 Mar 2013, 00:29    Post subject:  

Bonjour Misher0,
i went to get a try installing the above portabase -2.1
pet on pemasu's wheezy-3.5.2.5 + qt-4.8.0-basic-with-qtwebkit-dpup.pet (see pemasu's repo), pristine boot:
portabase runs OK ootb even if there is still a missing libicui18n.so.42 dep reported .
Charlie
[ps: to get libicui18n.so.42 , install the libicui18n from debian wheezy repo + make a symlink to the libicui18n.so.48.1.1]
PortaNwheezy.jpg
 Description   portabase 2.1 on wheezy-3.5.2.5 + qt-4.8.0-basic-with-qtwebkit-dpup.pet
 Filesize   26.49 KB
 Viewed   445 Time(s)

PortaNwheezy.jpg

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0909s ][ Queries: 13 (0.0074s) ][ GZIP on ]