Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 20:04
All times are UTC - 4
 Forum index » Off-Topic Area » Security
hd led blinking
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Author Message

Joined: 04 Sep 2007
Posts: 1580
Location: Canada

PostPosted: Thu 21 Mar 2013, 18:09    Post_subject:  

Just the government spying on your computer, nothing to worry about

As far as I know the long red flash is the USA gov...the short flashing is the Israeli gov and the middle is the Arab gov along with the Chinese and Russians so no need to worry....it's just the "Watcher".

I had this as well to be honest....If you don't mind, then, they won't mind.

It's a browser thing.


PS...I run without a hdd so no matter to me...you see.

Be not afraid to grow slowly, only be afraid of standing still.
Chinese Proverb

Back to top
View user's profile Send_private_message 
Official Dog Handler

Joined: 04 May 2005
Posts: 11463
Location: Arizona USA

PostPosted: Thu 21 Mar 2013, 22:30    Post_subject:  

Ted Dog wrote:
...I noticed it as well on a DVD booted machine without a HD about every six seconds

Well then it couldn't possibly have anything to do with accessing the hard disk. What else could it be? Could ramdisk cause the light to flicker?
Back to top
View user's profile Send_private_message 
Karl Godt

Joined: 20 Jun 2010
Posts: 4026
Location: Kiel,Germany

PostPosted: Thu 21 Mar 2013, 23:14    Post_subject:  

In former times i have read , that the linux kernel created a virtual ramdisk of a fixed size,
that can be adjusted at kernel compile time,
( also the amount of automatically created ramdisks in /dev/ram* )
to load the initrd.gz into.
That's where the bootparameter root=/dev/ram0 derives from.

Puppy's older kernels up to and above had a ramdisk size of 12-13KiB .

Very recent kernel configurations have that increased since such a ramdisk is used for full installations to perform the file system check,
since a full installation does not use an initrd.gz,
so loads all the needed programs and libraries into that ramdisk,
unmounts the partition and performs the filesystem check ending with a reboot,
but the sizes of the libraries have incresed already from 4.3 to Lupu
and now they wont fit anymore into the 12-13kib ramdisk .

I worked around it myself by using two ramdisks : one for /lib and one for all the other programs in /etc, /bin, /sbin .

You could test it like
bash-3.00# ls /dev/ram*
/dev/ram0 /dev/ram11 /dev/ram14 /dev/ram3 /dev/ram6 /dev/ram9
/dev/ram1 /dev/ram12 /dev/ram15 /dev/ram4 /dev/ram7
/dev/ram10 /dev/ram13 /dev/ram2 /dev/ram5 /dev/ram8
bash-3.00# disktype /dev/ram0

--- /dev/ram0
Block device, size 16 MiB (16777216 bytes)
Blank disk/medium

and of course create an ext2 filesystem like
mkfs.ext2 /dev/ram0 && mkdir -p /mnt/ram0 && mount /dev/ram0 /mnt/ram0 && cd /mnt/ram0 && echo "HUHU, I am in $PWD : )"

The point is now, that the kernel nowerdays loads the initrd.gz directly into a temporary tmpfs filesystem, that has no fixed size,
so no "real physical ramdisk" is used anymore by default and the kernel manages this all in ram and discards the initrd.gz after it had finished switching root.

I believe that since the HDD LED in the front side of a computer case is attached to the mobo, the BIOS/CHIP/CPU is sending the impulses to that joint, not the HDD directly. Whatever the real cause is, it might be that the BIOS simply is programmed to expect a HDD and therfore sends signals, or the cable is wrongly attached/damaged .
Back to top
View user's profile Send_private_message 

Joined: 12 Apr 2011
Posts: 9

PostPosted: Wed 29 May 2013, 08:43    Post_subject:  

Sorry for the thread resurrection, but I'm having a similar issue, except my HD access is a lot more intense, about once per second. I can hear the heads move as something accesses data. I have a 2GB swap partition, but according to swapon -s it is currently mounted but not being used.

Q5sys wrote:

Here they are. But as I mentioned.. iotop requires python to run. (its a python script)

According to the package manager it is installed, but running iotop returns:

 bash: /bin/iotop: /usr/bin/python: bad interpreter: No such file or directory

I'm running Slacko 5.5.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Off-Topic Area » Security
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0556s ][ Queries: 13 (0.0051s) ][ GZIP on ]