Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 00:41
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Wary and Racy 5.5, released March 3, 2013
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 7 of 11 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 Next
Author Message
EgyB

Joined: 20 Mar 2013
Posts: 2

PostPosted: Wed 20 Mar 2013, 05:34    Post_subject: thank you  

Thank you! I will do that when I get home.
Back to top
View user's profile Send_private_message 
linuxcbon

Joined: 09 Aug 2007
Posts: 792

PostPosted: Wed 20 Mar 2013, 12:33    Post_subject:  

Racy 5.5. Another bug :
Save http://launchpadlibrarian.net/13579707/N9Y4AAAAMAAJ.pdf
Open that pdf file with epdfview from shell.
Code:
 Error (74600): Error in JPX stream

And takes 60% CPU to go to the next page.
See https://bugs.freedesktop.org/show_bug.cgi?id=15629
epdfview is not developped anymore ? http://trac.emma-soft.com/epdfview/ down.
Any better pdf reader ?
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Wed 20 Mar 2013, 13:03    Post_subject:  

The problem isn't with epdfview - it's with the version of libpoppler that it uses.

I didn't check Racy, but Wary 5.5 uses the very old libpoppler-7 and shows the same symptoms as you reported.

However, Slacko 5.5 uses libpoppler-26 and handles your test PDF fine.
Back to top
View user's profile Send_private_message 
linuxcbon

Joined: 09 Aug 2007
Posts: 792

PostPosted: Wed 20 Mar 2013, 13:14    Post_subject:  

rcrsn51 wrote:
The problem isn't with epdfview - it's with the version of libpoppler that it uses.
I didn't check Racy, but Wary 5.5 uses the very old libpoppler-7 and shows the same symptoms as you reported.
However, Slacko 5.5 uses libpoppler-26 and handles your test PDF fine.

So why didnt you report it here ?
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4345
Location: Gatineau (Qc), Canada

PostPosted: Wed 20 Mar 2013, 22:40    Post_subject:  

linuxcbon & rcrsn51,

I can confirm that: all the console pdfto* utilities are of no use because the libpoppler.so.19 library is not there.

Working on it now.

musher0

~~~~~~~~~~~~~~~~~
Ok, here's a freshly compiled drop-in replacement for whatever poppler-ish material exists in wary 5.5 (untried in racy 5.5). This means it should replace all the pdfto*, pdfinfo, etc., utilities and the corresponding libraries. This version, poppler-0.22.2 is dated March 11, 2013 (10 days ago). It contains the executables and the corresponding libraries.

Please download from : http://limelinx.com/c617i Should you wish to preview the contents, a directory and file listing of this *.pet archive is attached below in g'zipped text format.

References : http://poppler.freedesktop.org/ (author's web site); http://poppler.freedesktop.org/poppler-0.22.2.tar.gz (source code)

Enjoy!

musher0
poppler-0.22.2.lst.tar.gz
Description 
gz

 Download 
Filename  poppler-0.22.2.lst.tar.gz 
Filesize  1.41 KB 
Downloaded  311 Time(s) 

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Thu 21 Mar 2013, 10:00    Post_subject:  

linuxcbon wrote:
Quote:
Dillo is fast but not complete, no javascript and no css float.
Did you try it at http://www.murga-linux.com/puppy/viewtopic.php?t=52534

Yes, I use it all the time.
Dillo's limitations won't prevent you from visiting either here or here and downloading the full browser of your choice.
(either with Dillo or a download manager such as Uget or Wget)

This also works with Mozilla's official builds.
(Haven't tried any of the others.)
Back to top
View user's profile Send_private_message 
watchdog

Joined: 28 Sep 2012
Posts: 639

PostPosted: Thu 21 Mar 2013, 12:59    Post_subject: Re: skype problem  

EgyB wrote:
Can someone help me?

I run racy 5.5 from usb stick.
I install skype 2.1 over install puppy package.

When I log in skype it won't work. Just freeze and keep skype logo (arrow which go in circle) running, but nothing else...


In wary 5.5 I use successfully skype 2.2.0.35. You can download the tar.bz2 archive from my shared link:

http://www.4shared.com/file/StyW-ofz/skype_static-22035tar.html

Click on the archive, select all and extract to /usr/local. Then copy in /usr/bin the binary skype from the directory you extracted. From /usr/bin you can create a link to the desktop or launch "skype" in console. I have to say that I install from puppy3 repository qt 3.3.8 but I don't know if it is necessary.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Thu 21 Mar 2013, 14:29    Post_subject:  

musher0 wrote:
I can confirm that: all the console pdfto* utilities are of no use because the libpoppler.so.19 library is not there.

I am not seeing a problem with libpoppler in Wary 5.5. All of the pdfto* tools work correctly.

I believe that the only issue here is updating libpoppler to handle linuxcbon's particular PDF file. All you need are:
Code:
libpoppler-glib.so.8  ->   libpoppler-glib.so.8.6.0
libpoppler.so.35 -> libpoppler.so.35.0.0

Then epdfview can be compiled against them to make a version that reads his PDF.
Back to top
View user's profile Send_private_message 
linuxcbon

Joined: 09 Aug 2007
Posts: 792

PostPosted: Thu 21 Mar 2013, 14:52    Post_subject:  

Barry, for privacy, can you do this ?
Code:
rm -r /root/.adobe/
rm -r /root/.macromedia/
ln -s /dev/null /root/.adobe
ln -s /dev/null /root/.macromedia
= avoiding cookies from flashplayer
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4345
Location: Gatineau (Qc), Canada

PostPosted: Thu 21 Mar 2013, 14:56    Post_subject:  

rcrsn51 wrote:
musher0 wrote:
I can confirm that: all the console pdfto* utilities are of no use because the libpoppler.so.19 library is not there.

I am not seeing a problem with libpoppler in Wary 5.5. All of the pdfto* tools work correctly.

I believe that the only issue here is updating libpoppler to handle linuxcbon's particular PDF file. All you need are:
Code:
libpoppler-glib.so.8  ->   libpoppler-glib.so.8.6.0
libpoppler.so.35 -> libpoppler.so.35.0.0

Then epdfview can be compiled against them to make a version that reads his PDF.


Doesn't load in zathura either, but in foxitreader, it's ok.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
anikin

Joined: 10 May 2012
Posts: 529

PostPosted: Thu 21 Mar 2013, 15:48    Post_subject:  

linuxcbon wrote:
Barry, for privacy, can you do this ?
Code:
rm -r /root/.adobe/
rm -r /root/.macromedia/
ln -s /dev/null /root/.adobe
ln -s /dev/null /root/.macromedia
= avoiding cookies from flashplayer

linuxcbon,
to be on the safe side, should I run these commands before remastering *any* puppy? No side effects?
Back to top
View user's profile Send_private_message 
artsown

Joined: 12 Sep 2012
Posts: 147

PostPosted: Thu 21 Mar 2013, 17:10    Post_subject:  

Concerning the pdf issue, I informed Pemasu that his precise
3.8.3.1 and his wheezy 3.5.2.5 also have problems. I thought his
reply was interesting:
http://murga-linux.com/puppy/viewtopic.php?p=693616&sid=aaaa3bf66ee8ef9295057eaf26825c52

To get a working reference that handles the graphical illustrations
ok he used Google chrome browser instead of slacko.

Art
Back to top
View user's profile Send_private_message 
linuxcbon

Joined: 09 Aug 2007
Posts: 792

PostPosted: Fri 22 Mar 2013, 01:25    Post_subject:  

anikin wrote:
linuxcbon wrote:
Barry, for privacy, can you do this ?
Code:
rm -r /root/.adobe/
rm -r /root/.macromedia/
ln -s /dev/null /root/.adobe
ln -s /dev/null /root/.macromedia
= avoiding cookies from flashplayer

linuxcbon,
to be on the safe side, should I run these commands before remastering *any* puppy? No side effects?

You can do it , no problemo.
You can add these ones too :
Code:
 rm /root/.local/share/recently-used.xbel
 mkdir /root/.local/share/recently-used.xbel
Back to top
View user's profile Send_private_message 
anikin

Joined: 10 May 2012
Posts: 529

PostPosted: Fri 22 Mar 2013, 06:08    Post_subject:  

Note taken.
Thank you, linuxcbon!
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4345
Location: Gatineau (Qc), Canada

PostPosted: Fri 22 Mar 2013, 10:40    Post_subject:  

rcrsn51 wrote:
musher0 wrote:
I can confirm that: all the console pdfto* utilities are of no use because the libpoppler.so.19 library is not there.

I am not seeing a problem with libpoppler in Wary 5.5. All of the pdfto* tools work correctly.

I believe that the only issue here is updating libpoppler to handle linuxcbon's particular PDF file. All you need are:
Code:
libpoppler-glib.so.8  ->   libpoppler-glib.so.8.6.0
libpoppler.so.35 -> libpoppler.so.35.0.0

Then epdfview can be compiled against them to make a version that reads his PDF.


Hello, rcrsn51.

I never lie. See attached capture.

Regards.

musher0
libpoppler_so_19-no_such_file.jpg
Description 
jpg

 Download 
Filename  libpoppler_so_19-no_such_file.jpg 
Filesize  20.28 KB 
Downloaded  321 Time(s) 

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 7 of 11 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0957s ][ Queries: 13 (0.0082s) ][ GZIP on ]