Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Jul 2015, 19:26
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to install Puppy with no CD or USB boot?
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 16 Mar 2013
Posts: 2

PostPosted: Sat 16 Mar 2013, 08:08    Post_subject:  How to install Puppy with no CD or USB boot?
Sub_title: Do not get past orange screens

I have a old laptop which is giving me a lot of trouble. It does not boot from usb and will not boot from an external CD drive, eventhough it is supposed to. (Many other people have the same problem)

Windows runs incredibly slowly so I just want to get a lightweight linux distro running on it so that it can be used, ideally with a few basic apps already in the distro like word processors etc. It has "256mb ddr sdram (fixed)" and a 1ghz Transmeta Crusoe processor.

I am reasonably handy but have no idea mostly how linux works. I first tried to get the latest macpup running, but I got a PAE error. So someone recommended I try puppy 528. With this I also got the puppy logo picture up but then it gave some error about that it was looking for files. I do not know if I am totally messing up somewhere when trying to install it.

Because usb/CD booting does not work, I am using the docking station that came with the laptop that lets you connect to its hard drive with a usb cable like an external hard drive. I have been trying to follow this guide: http://murga-linux.com/puppy/viewtopic.php?t=29653

I get the first few dialog screens when starting puppy uni installer and then some of those orange/yellow screens asking to wipe the drive/partition and then after that is completed I get nothing.

I dont get to this dialog box at all

or this one either

If anyone can help I would really appreciate it, I have no idea whats going wrong. thanks. I just tried wary puppy linux 5.5, but I get the same problem, when booting up it says "searching for puppy files... puppy_wary_5.5.sfs not found etc" It almost makes me think it doesnt install the puppy linux at all?
Back to top
View user's profile Send_private_message 
Official Dog Handler

Joined: 04 May 2005
Posts: 11463
Location: Arizona USA

PostPosted: Sat 16 Mar 2013, 09:23    Post_subject:  

If you're getting that message when the computer tries to boot, then I think Puppy got installed. Did you create a swap partition? With only 256 MB of RAM, Puppy might need some virtual memory to run in that computer (swap memory is virtual memory). 512 MB would be enough. Alternatively, you could install more RAM.
Back to top
View user's profile Send_private_message 

Joined: 16 Mar 2013
Posts: 2

PostPosted: Sat 16 Mar 2013, 09:37    Post_subject:  

Yes exactly like the tutorial here said http://murga-linux.com/puppy/viewtopic.php?t=29653

That part worked 100% like they said. I gave it 550mb for the swap partition. It says (fixed) so it sounds like the ram isnt upgradeable. Though it worked fine in the beginning so Id prefer not to spend anymore, on a tight budget too.

It looked to me like it got installed too because of the picture boot up screen, But the fact it looked like it was struggling to find the right files looked bad, on top of the fact that I never get to those dialog boxes I put pictures up of - they look like theyre an important part of the process.
Back to top
View user's profile Send_private_message 

Joined: 28 Dec 2009
Posts: 858

PostPosted: Wed 20 Mar 2013, 00:31    Post_subject:  

Hi buftox,

Welcome to the forum.

Seeing as how I've never installed Puppy on anything, much less a hard drive located on another PC, I'm probably not the best person to answer this. But since three days have gone by without a new post on this thread, I thought I'd see if I can help. Maybe if I ask the right questions someone with experience at installing Puppy will have an idea what is wrong.

buftox wrote:
Because usb/CD booting does not work, I am using the docking station that came with the laptop that lets you connect to its hard drive with a usb cable like an external hard drive.

First, I'm not sure I understand your setup. Am I correct in assuming that you are using another PC to install Puppy to the hard drive on your old laptop?

When installing, what partition (e.g., /dev/sdb1) did you install to?

Now let's see what got installed.

Using the same setup that you used for installing, click on the partition (at the bottom of your desktop) to mount it. If it mounts, a window should open showing the files in the top directory. Immediately after the window opens, press your ` (grave accent) key to open a terminal window, and enter the following two commands:
find . -xdev -name "puppy*.sfs" -o -name "vmlinuz" -o -name "initrd.gz" -o -name "*linux.cfg" -o -name "menu.lst" -o -name "grub*"

(The second command should be typed as one long line, even though it may display as more than one line in your browser window.)

Now copy the resulting contents of the terminal window into your next post. (If you don't know how to copy and paste from the terminal, just ask. Or you can simply copy it by hand.)

Perhaps that information will give me or someone else a clue as to what went wrong.

I'm thinking that Puppy may be confused by one or two things: You installed it via USB, but you'll want it to boot from an internal drive. So when you try to boot from your old laptop, the bootloader may be trying to boot from the wrong partition, or the pmedia boot parameter may be set to "usbhd", telling Puppy to search for files on a USB drive when they are actually on the old laptop's internal hard drive.

If either is the case, it shouldn't be hard to fix. And perhaps neither is wrong, if the universal installer knew exactly how to handle your unusual installation setup.

Do you remember what you chose for the media when you reached the dialog window shown in Image-20 of CatDude's guide?

Anyway, the fact that the laptop begins to boot and look for the Puppy .sfs file indicates that at some point you managed to install some sort of bootloader, and probably initrd.gz. I cannot explain how you did that if the Universal Installer didn't get beyond the first few dialog windows. Perhaps you are seeing something remaining from a previous installation.
Back to top
View user's profile Send_private_message 
Karl Godt

Joined: 20 Jun 2010
Posts: 4026
Location: Kiel,Germany

PostPosted: Wed 20 Mar 2013, 18:52    Post_subject:  

latest macpup running, but I got a PAE error.

Here is a logical error in the beginning. Puppy is small but it does not mean that any multicoreSMP-2.6.30.x or later kernel might work on that machine. Firefox is heavy and likely would fill your RAM and SWAP soon and causing freezes due too little RAM and HDD speed.

On the other hand the newest initrd.gz might work better for your setup to search for the puppy files, but is not compatible with the old naming convention ( today puppy_precise_5x.sfs, old pup-400.sfs ) .

According to rcrsn51, normally an incorrect cheat parameter at bootup ie puppy pmedia=usbcd might work. Press F2 when the boot logo shows for more help information or open the help.msg file in a texteditor.

There are different older versions of puppy to try out : http://ftp.nluug.nl/ibiblio/distributions/puppylinux/ has Puppy from 2.x up to 4.x
and http://ftp.nluug.nl/ibiblio/distributions/quirky/test/wary-070-mix-n-match/ might be an alternative too.
Back to top
View user's profile Send_private_message 

Joined: 02 Jan 2009
Posts: 128

PostPosted: Sun 24 Mar 2013, 04:36    Post_subject:  

I concur with the previous comment, go for an older version of puppy. Don't give up, as the benfits will make the extra effort worthwhile.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0671s ][ Queries: 12 (0.0035s) ][ GZIP on ]