Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 05:47
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
GIT-1.7.9.6 with TIG-0.18 (Lucid 528-004)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Wed 04 Apr 2012, 08:54    Post subject:  GIT-1.7.9.6 with TIG-0.18 (Lucid 528-004)
Subject description: Every Git clone is a full-fledged repository + Text interface for Git
 

Homepage for GIT:

http://git-scm.com/

Homepage for TIG:

http://jonas.nitro.dk/tig/

Download:

Approx 6mb - GIT:

http://www.datafilehost.com/download-953dfcd2.html

To use GIT, open up 'terminal' and enter the details eg

Quote:


git clone git://github.com/xbmc/xbmc.git



The contents will end up in your Home/Root folder
tig-0.18-i686.pet
Description 
pet

 Download 
Filename  tig-0.18-i686.pet 
Filesize  61.19 KB 
Downloaded  760 Time(s) 
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4379
Location: Southeast Georgia, USA

PostPosted: Thu 17 May 2012, 18:58    Post subject:  

Will this work with dpup Exprimo 5x14, please?

I need to get git running here and the Puppy Manager git package list is confusing and intimidating ... too many dubiously-linked dependencies as always plagues everything-Debian.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Mon 21 May 2012, 05:25    Post subject:  

Hi there

Not sure as I only compiled it using Lucid 528.

However if you download it, extract it ( not install )and take a look at the contents, it might just be a binary and some documentation. If so, I'm guessing it should work.
Back to top
View user's profile Send private message 
estuardolh

Joined: 20 Jul 2012
Posts: 6
Location: Guatemala.

PostPosted: Sun 03 Mar 2013, 03:44    Post subject: error
Subject description: error while loading shared libraries
 

Hi
i just installed git-1.7.9.6-i686.pet && tig-0.18-i686.pet and i got a error.

I attach a screenshot of the terminal with the error message.

I am using Lucid Puppy linux 528 with OpenBox
The files that i installed i downloaded from your link and the attached file.

There is a way to solve this?

Thanks in advance.
image-3.png
 Description   Screenshot of terminal trying to run git.
 Filesize   5.87 KB
 Viewed   1005 Time(s)

image-3.png

Back to top
View user's profile Send private message 
estuardolh

Joined: 20 Jul 2012
Posts: 6
Location: Guatemala.

PostPosted: Sun 03 Mar 2013, 04:51    Post subject: i solved it  

Hi again

Searching for the library libcrypto.so.1.0.0 i found that this is on the openssl package.
And i using the command
Code:
openssl

and then
Code:
version


I found that my version was a 0.9.x and guessing that there is not the library i need... I updated to the openssl version 1.0.1a from the pet file available here http://mail.murga-projects.com/puppy/viewtopic.php?t=77805&sid=f16058dac6622eb7514e68790b75cfb1 (another post of you).


And finally git works fine Very Happy

Thanks Chrome307.
regards
image-4.png
 Description   
 Filesize   11.24 KB
 Viewed   951 Time(s)

image-4.png

Back to top
View user's profile Send private message 
snayak

Joined: 14 Sep 2011
Posts: 231

PostPosted: Thu 28 Mar 2013, 17:12    Post subject:  

Hi,

This package doesn't work for command

git fetch origin

Please help.

Sincerely,
Srinivas Nayak

_________________
Machine: Wary 530, AMD Athlon 2000+, ASUS A7N266-VM board, 512MB DDR RAM, 40GB HDD, 52xCDRW, PS/2 Mouse/Keyboard, USB 2.0.
Home: http://www.mathmeth.com/sn/
Blog: http://srinivas-nayak.blogspot.com/
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0535s ][ Queries: 13 (0.0049s) ][ GZIP on ]