Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 31 Aug 2014, 00:43
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Gtkdialog Development
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 50 of 55 Posts_count   Goto page: Previous 1, 2, 3, ..., 48, 49, 50, 51, 52, 53, 54, 55 Next
Author Message
zigbert


Joined: 29 Mar 2006
Posts: 5693
Location: Valåmoen, Norway

PostPosted: Sun 31 Mar 2013, 05:05    Post_subject:  

A brief look into the gtk3 transition: - This won't be too hard....

The only issue I see is that table-widget doesn't auto-resize column-width as the tree-widget does.
Auto-resizing will make a mess in pMusic's sourcelist, where ie. urls may be long and auto-moves all other columns out in the blue (read: to the right).
Looking at the docs tells that this should be possible to override. But I can't figure out how ... Embarassed


Thanks for any suggestions.
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
thunor


Joined: 14 Oct 2010
Posts: 350
Location: Minas Tirith, in the Pelennor Fields fighting the Easterlings

PostPosted: Sun 31 Mar 2013, 06:59    Post_subject:  

zigbert wrote:
...
Puppy apps will make it into the future.

It had to be done didn't it. The gates to gtk3 are now open for Puppy apps and Puppy itself although it may yet be discovered that gtk2 is worth staying with Razz

zigbert wrote:
...
The only issue I see is that table-widget doesn't auto-resize column-width as the tree-widget does.
...

Resizeable tree columns was forced to TRUE in code because there was no developer interface to that property. What I shall do is make a custom tag attribute and you can set it with column-resizeable="true|false|true|false".

There will likely be some tweaking involved.
Back to top
View user's profile Send_private_message Visit_website 
thunor


Joined: 14 Oct 2010
Posts: 350
Location: Minas Tirith, in the Pelennor Fields fighting the Easterlings

PostPosted: Sun 31 Mar 2013, 07:37    Post_subject:  

simargl wrote:
...
My package manager is working with this version - screenshot bellow, grub4dos also seems to work, sfs_load and pwireless2 don't
...

I've updated the build scripts so that the next time you checkout gtkdialog you should find that ./autogen.sh works. Thanks for the assistance with that.

If the developers of sfs_load and Pwireless2 choose to support gtk3 then they will need to change the combobox, list and table widgets to comboboxtext and tree widgets.

Important Disclaimer
If somebody wants to create a gtk3 Puppy then they need to talk to the developers of those applications that require updating. I want to make it clear from the outset that I'm not pushing Puppy towards gtk3 or forcing developers to update their applications -- it's not mandatory and it's not my business, I'm just supporting another library Smile

Regards,
Thunor
Back to top
View user's profile Send_private_message Visit_website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9061
Location: Stratford, Ontario

PostPosted: Sun 31 Mar 2013, 11:07    Post_subject:  

thunor wrote:
If the developers of sfs_load and Pwireless2 choose to support gtk3 then they will need to change the combobox, list and table widgets to comboboxtext and tree widgets.

Could you please explain that some more? Does that mean that gtkdialog4 would be fixed at gtk-2 and gtkdialog5 would become the gtk-3 version?

So would Puppy builders need to include both versions of gtk? For example, alphaOS has both.
Back to top
View user's profile Send_private_message 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Sun 31 Mar 2013, 11:15    Post_subject:  

rcrsn51 wrote:
thunor wrote:
If the developers of sfs_load and Pwireless2 choose to support gtk3 then they will need to change the combobox, list and table widgets to comboboxtext and tree widgets.

Could you please explain that some more? Does that mean that gtkdialog4 would be fixed at gtk-2 and gtkdialog5 would become the gtk-3 version?

So would Puppy builders need to include both versions of gtk? For example, alphaOS has both.


It makes more sense to just use the respective names to maintain backwards compatibility.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9061
Location: Stratford, Ontario

PostPosted: Sun 31 Mar 2013, 11:20    Post_subject:  

Regarding the combobox vs comboboxtext widgets:

IIRC, I once looked at comboboxtext in an older gtkdialog and it worked differently from combobox.

But I checked in Slacko and they now appear to be identical. Is comboboxtext now a plug-and-play replacement for combobox?
Back to top
View user's profile Send_private_message 
thunor


Joined: 14 Oct 2010
Posts: 350
Location: Minas Tirith, in the Pelennor Fields fighting the Easterlings

PostPosted: Sun 31 Mar 2013, 13:35    Post_subject:  

Uh oh, the mob's assembled with its truck-load of rocks Laughing

Important Disclaimer Two
In gtk2, the combobox (GtkCombo), list (GtkList) and table (GtkCList) widgets were deprecated (I think they were remnants of gtk1) and the gtk3 developers have expunged these old deprecated widgets from gtk3. It's very sad and if you're not happy about it then find out where they live and pooh on their lawns.

I'm adding additional support for the gtk3 library -- it's optional -- so if you want your application to work with this additional optional gtk3 library then you'll have to accept the features that the gtk3 developers have offered you.

jpeps wrote:
It makes more sense to just use the respective names to maintain backwards compatibility.

It doesn't make sense to do that. If I substitute a comboboxentry instead of a combobox, a tree instead of a list, a tree instead of a table then they'll behave in the same way and support the same properties? Of course they won't, but an application developer can additionally make their applications work with the optional gtk3 library by upgrading a few widgets if necessary.

rcrsn51 wrote:
Could you please explain that some more? Does that mean that gtkdialog4 would be fixed at gtk-2 and gtkdialog5 would become the gtk-3 version?

So would Puppy builders need to include both versions of gtk? For example, alphaOS has both.

That is absolutely none of my business in any possible way.

rcrsn51 wrote:
Regarding the combobox vs comboboxtext widgets:

IIRC, I once looked at comboboxtext in an older gtkdialog and it worked differently from combobox.

But I checked in Slacko and they now appear to be identical. Is comboboxtext now a plug-and-play replacement for combobox?

The combobox has an entry and is a very limited widget, so a comboboxentry would supplant it very easily.

Regards,
Thunor
Back to top
View user's profile Send_private_message Visit_website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9061
Location: Stratford, Ontario

PostPosted: Sun 31 Mar 2013, 13:56    Post_subject:  

thunor wrote:
That is absolutely none of my business in any possible way.

I apologize. I should have directed the question towards the Puppy developers. I was just trying to get a general sense of where this was heading.
Back to top
View user's profile Send_private_message 
thunor


Joined: 14 Oct 2010
Posts: 350
Location: Minas Tirith, in the Pelennor Fields fighting the Easterlings

PostPosted: Sun 31 Mar 2013, 14:16    Post_subject:  

Regarding the gtk3 support in combination with Slacko 5.5 and the audacious sfs -- there's no default theme engine or theme so I've compiled the 3.4 branch of gnome-themes-standard (33MB) and got rid of everything except the default Adwaita engine and theme resulting in a 92KB pet, so if you want it then it's attached to this post.

You'll need to create ~/.config/gtk-3.0/ and add two files:
settings.ini
Code:
[Settings]
gtk-theme-name = Adwaita
gtk-fallback-icon-theme = gnome

and gtk.css which will be empty.

gtk3 doesn't support ~/gtkrc-2.0 and GTK2_RC_FILES. The gtk.css file above is explained here.

There is a gtk3 function to load a style sheet so it might be that I'll have to add support for loading a custom gtk.css file.

Regards,
Thunor
gtk3-adwaita-theme.png
 Description   Default gtk3 Adwaita theme applied to a gtkdialog example built supporting gtk3
 Filesize   5.49 KB
 Viewed   504 Time(s)

gtk3-adwaita-theme.png

gnome-themes-standard-3.4.2-i686.pet
Description  Slacko 5.5 i686 gtk3 default Adwaita theme engine and theme
pet

 Download 
Filename  gnome-themes-standard-3.4.2-i686.pet 
Filesize  92.08 KB 
Downloaded  180 Time(s) 
Back to top
View user's profile Send_private_message Visit_website 
matiasbatero


Joined: 11 Oct 2012
Posts: 58
Location: Mar del Plata, Argentina

PostPosted: Sun 31 Mar 2013, 14:49    Post_subject: Can't compile gtkdialog.gtk rev 505  

Thank you so much Thunor for you effort!!! Smile

I can't compile gtkdialog.gtk3 rev 505 yet.

I do the next steps:

Code:
svn checkout http://gtkdialog.googlecode.com/svn/trunk/ gtkdialog
cd gtkdialog
./autogen.sh --enable-gtk3=yes
make


All works fine, but "make" gives me this error

Code:
collect2: error: ld returned 1 exit status
make[3]: *** [gtkdialog] Error 1
make[3]: Leaving directory `/home/matt/gtkdialog/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/matt/gtkdialog/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/matt/gtkdialog'
make: *** [all] Error 2


Compiling with gtk2 works perfectly. But with ./autogen.sh --enable-gtk3=yes no.

I don't know how to solve this.
PD: i'm using archlinux

Regards!!
Matt
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Sun 31 Mar 2013, 16:22    Post_subject:  

thunor wrote:
rcrsn51 wrote:

Could you please explain that some more? Does that mean that gtkdialog4 would be fixed at gtk-2 and gtkdialog5 would become the gtk-3 version?

So would Puppy builders need to include both versions of gtk? For example, alphaOS has both.

That is absolutely none of my business in any possible way.

*I don't think* (spec, at least as far as puppy is concerned) that gtk2 is going anywhere immediately soon. So, for now gtk3 is an option for puplet builders. The whole gtkdialog2, gtkdialog3, gtkdialog4 mess is a bit unfortunate. As most know Slacko ships with 1 and only 1 gtkdialog executable, the backward compatibility is restored with links. This will not change.

I like thunor's suggestion to use gtk3dialog for the executable for now, at least until gtk2 is completely gone. I also, as far as Slacko is concerned, will be using the usual PREFIX path for distro packaged packages, which is /usr, so therefore the exec will go to /usr/bin. Those who compile themselves for their own use should leave the PREFIX paths as default, /usr/local. Of course Barry may completely disagree with what I do (often does).

-

Thanks thunor for the theme! I have another called "Kunitwo" (found on gnome-look.org) which supports gtk2/3 that I am using right now. It's pretty similar to "Adwaita" which is lurking in the Salix repo in disguise.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
thunor


Joined: 14 Oct 2010
Posts: 350
Location: Minas Tirith, in the Pelennor Fields fighting the Easterlings

PostPosted: Sun 31 Mar 2013, 17:34    Post_subject: Re: Can't compile gtkdialog.gtk rev 505  

matiasbatero wrote:
...
I can't compile gtkdialog.gtk3 rev 505 yet.
...

Hi Matt

Do this:
Code:
make clean
 (./autogen.sh --enable-gtk3=yes && make) | tee output.txt

and either dump the lot in a post or "tar -czvf output.tar.gz output.txt" and attach it.

@Mick

I don't see why gtk2 needs to disappear either. I like it and newer widget libraries look a bit dumbed down to me and I'm not interested in that. Have a look at the colorbutton in gtk3 although the fontbutton looks good.
Code:
echo '<vbox><colorbutton></colorbutton><fontbutton></fontbutton></vbox>' | ./src/gtkdialog -s

I'm using "gtk3dialog" which seems pretty workable.

Apart from using the audacious sfs to give me the gtk3 library, I haven't installed anything else apart from the missing default Adwaita engine and theme and everything I've looked at on gnome-look.org is giving me errors so I expect I'm missing something important. I read something about it here -- "a wild guess is that I don’t have some sort of GNOME resource broker running" -- but I'm fine with Adwaita anwyay.

Regards,
Thunor
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Sun 31 Mar 2013, 18:32    Post_subject:  

Hi thunor,

A bit OT, but regarding the theme I couldn't get your way to work (PHATSlacko, pretty similar to Slacko) so I copied /usr/share/themes/Adwaita/gtk-3.0/settings.ini to ~/.config/gtk-3.0, also created a blank gtk.css.

Also, to keep your desktop in harmony (and as a side effect mine Razz ) I found an Adwaita gtk2 theme, but it requires the murrine engine which I compiled, see attached.

Cheers.
adwaita-gtk2-0.1.pet
Description 
pet

 Download 
Filename  adwaita-gtk2-0.1.pet 
Filesize  14.9 KB 
Downloaded  146 Time(s) 
murine-0.98-i486-s.pet
Description 
pet

 Download 
Filename  murine-0.98-i486-s.pet 
Filesize  80.96 KB 
Downloaded  142 Time(s) 
capture1146.png
 Description   
 Filesize   97.49 KB
 Viewed   485 Time(s)

capture1146.png


_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
matiasbatero


Joined: 11 Oct 2012
Posts: 58
Location: Mar del Plata, Argentina

PostPosted: Sun 31 Mar 2013, 21:03    Post_subject: Now it works!!!  

Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5693
Location: Valåmoen, Norway

PostPosted: Mon 01 Apr 2013, 02:21    Post_subject:  

thunor wrote:
What I shall do is make a custom tag attribute and you can set it with column-resizeable="true|false|true|false".

There will likely be some tweaking involved.
Yeeees Very Happy


I am very thankful
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 50 of 55 Posts_count   Goto page: Previous 1, 2, 3, ..., 48, 49, 50, 51, 52, 53, 54, 55 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1260s ][ Queries: 13 (0.0222s) ][ GZIP on ]