Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 06:14
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to install Torchat?
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Sun 31 Mar 2013, 17:05    Post_subject:  How to install Torchat?  

Okay, starting with python-2.7.3 installed, and torchat-source-0.9.9.553.zip extracted to /opt/torchat, here's what I get:

Code:
# cd /opt/torchat/src
# ./torchat.py
(0) [config,477,main] python version 2.7.3 (default, Jul  3 2012, 21:16:07) [GCC 4.7.1]
(0) [config,484,main] script directory is /opt/torchat/src
(0) [config,485,main] data directory is /root/.torchat
(0) Traceback (most recent call last):
(0)   File "./torchat.py", line 20, in <module>
(0) import wxversion
(0) ImportError
(0) :
(0) No module named wxversion
#


What do I need to do to get Torchat up and running?

_________________
Version 27. Dotpet. Click here.
(SFS available too!)

Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4050
Location: World_Hub

PostPosted: Sun 31 Mar 2013, 17:21    Post_subject:  

What's in the Precise repo's no good >> torchat_0.9.9.550-2~build0.12.04.1_all.deb?

Shouldn't require more than these:
  • python (>= 2.7.1-0ubuntu2)
  • python-socksipy
  • python-wxgtk2.8
  • tor (>= 0.2.1.30-1)
Back to top
View user's profile Send_private_message 
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Sun 31 Mar 2013, 17:37    Post_subject:  

I'm running Slacko 5.5, and the debian package also returns "No module named wxversion".

I couldn't manage to find the python-wxgtk package in Launchpad. The site isn't organized very intuitively... If you could give me links to what I need to download, that would be very appreciated.

_________________
Version 27. Dotpet. Click here.
(SFS available too!)

Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4050
Location: World_Hub

PostPosted: Sun 31 Mar 2013, 18:21    Post_subject:  

James- without an ldd, these perhaps. You may need one or both wx pkgs- I'm unsure.

http://repository.slacky.eu/slackware-14.0/libraries/wxPython/2.8.12.1/

http://repository.slacky.eu/slackware-14.0/libraries/wxGTK/2.8.12/

http://socksipy.sourceforge.net/
Back to top
View user's profile Send_private_message 
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Mon 01 Apr 2013, 00:43    Post_subject:  

Thanks for those!

Unfortunately, now it says libmspack is missing, and I can't seem to fid anything in PPM...

_________________
Version 27. Dotpet. Click here.
(SFS available too!)

Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4050
Location: World_Hub

PostPosted: Mon 01 Apr 2013, 08:00    Post_subject:  

Repo problem? >> http://slackware.org.uk/slacky/slackware-14.0/libraries/libmspack/0.3alpha/
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0505s ][ Queries: 12 (0.0068s) ][ GZIP on ]