Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Jul 2014, 08:15
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Unable to set time/clock (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
Freedom


Joined: 17 Jul 2005
Posts: 30

PostPosted: Wed 20 Jul 2005, 19:35    Post subject:  Unable to set time/clock (Solved)  

In Puppy 1.03 my clock is 1 hour slow. I have tried to change time zones but it does not make any changes to the time no matter what zone I select.

And Xclock just seems to be an anolog type display which is also 1 hour slow.
Is there a way to correct this?

_________________
www.gnu.org
www.PCCleanUp.US
Back to top
View user's profile Send private message 
rarsa


Joined: 29 May 2005
Posts: 3053
Location: Kitchener, Ontario, Canada

PostPosted: Wed 20 Jul 2005, 19:55    Post subject:  

The standard linux way of changing the date is through the console.

Open a command console (rxvt) and type the following command
Code:
date MMDDhhmmYYYY.s

# for example to set the time to 8:15:20 PM on July 20, 2005 type the command as follows

date 072020152005.20


Alternatively you could install an application to keep your time syncronized. I am sure that I saw that someone posted a DotPup for such application. I will have a look.
Back to top
View user's profile Send private message Visit poster's website 
Freedom


Joined: 17 Jul 2005
Posts: 30

PostPosted: Wed 20 Jul 2005, 20:49    Post subject:  

Well rarsa.
I tried to use the clock from net program and it gave the same thing the other did. 1 hour behind.

I looked over your instructions and it took a min for me to figure out what you were saying with the time and date and all but once I figured it out. I changed the time so that it is correct with out problems. Thank you for your help. Very Happy

_________________
www.gnu.org
www.PCCleanUp.US
Back to top
View user's profile Send private message 
Ian
Official Dog Handler


Joined: 04 May 2005
Posts: 1237
Location: Queensland

PostPosted: Wed 20 Jul 2005, 20:54    Post subject:  

Did you try using the Set time/date in Control panel after you set the timezone.
Back to top
View user's profile Send private message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Wed 20 Jul 2005, 21:04    Post subject:  

also, the time may not adjust automatically for daylight-savings-time, which could make it an hour off (you would have to reset the clock time yourself)
Back to top
View user's profile Send private message 
rarsa


Joined: 29 May 2005
Posts: 3053
Location: Kitchener, Ontario, Canada

PostPosted: Wed 20 Jul 2005, 22:21    Post subject:  

Actually after I suggested looking at the 'internet time' DotPup I tried it myself.

Apparently it requires that the system date is UTF. My system clock has the local time (GMT -5) so when I set the time with the Internet time utility it set it 5 hours slow.

Oh, another thing for GuestToo: The 'Internet time' utility shows that you should set your timezone first, and it gives as an example New York +5, actually New York is -5 meaning that when it is 7 GMT it is 2 EST.
Back to top
View user's profile Send private message Visit poster's website 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Wed 20 Jul 2005, 22:37    Post subject:  

my /etc/TZ is EST5EDT
which means Eastern Standard Time (offset = +5) and automatically use Eastern DaylightSavings Time

as far as i know, the offset for EST is +5 ... not -5

Quote:
The offset string immediately follows std and specifies the time value to be added to the local time to get Coordinated Universal Time (UTC). The offset is positive if the local time zone is west of the Prime Meridian and negative if it is east.

see: http://www.die.net/doc/linux/man/man8/hwclock.8.html
and: http://www.die.net/doc/linux/man/man3/tzset.3.html
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10927
Location: Arizona USA

PostPosted: Wed 20 Jul 2005, 22:56    Post subject:  

Can anyone say why the acronym for Coordinated Universal Time is UTC? Confused
Back to top
View user's profile Send private message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Wed 20 Jul 2005, 23:15    Post subject:  

http://en.wikipedia.org/wiki/UTC
http://en.wikipedia.org/wiki/Universal_Time
Quote:
"UTC" is not a true abbreviation; it is a variant of Universal Time, abbreviated UT, and has a modifier C (for "coordinated") appended to it just like other variants of UT

Quote:
Universal Time (UT) is a timescale based on the rotation of the Earth.
Back to top
View user's profile Send private message 
rarsa


Joined: 29 May 2005
Posts: 3053
Location: Kitchener, Ontario, Canada

PostPosted: Wed 20 Jul 2005, 23:48    Post subject:  

Well, those utilities have it backwards as it is normally accepted in timezone maps (and Other linux tools and other OS's tools)

http://www.worldtimezone.com/
http://aa.usno.navy.mil/faq/docs/us_tzones.html

It is normally accepted that -5 is EST.
Back to top
View user's profile Send private message Visit poster's website 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10927
Location: Arizona USA

PostPosted: Thu 21 Jul 2005, 00:40    Post subject:  

Thanks for the explanation. It explains why several Linux distros I tried would get the time way off, and then when I'd get it set right in Linux and boot back into Windows it would be way off in the other direction.

The wonderful thing about standards is there are so many to choose from. Crying or Very sad
Back to top
View user's profile Send private message 
peppyy


Joined: 27 Jun 2005
Posts: 429
Location: VT USA

PostPosted: Thu 21 Jul 2005, 09:48    Post subject:  

I had no luck at all setting the time until I went to the bios and first set the correct time there. The problem is that this bios does not support time zones so when ever I set the system time from the internet it sets to utc in the bios. I really should update my bios but I don't trust my floppy drive or my cdrom.

I named it well-enough and left it alone.

Very Happy

_________________
Questions? Search Puppy Linux Answers with Google
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger 
Freedom


Joined: 17 Jul 2005
Posts: 30

PostPosted: Thu 21 Jul 2005, 18:59    Post subject:  

Ian wrote:
Did you try using the Set time/date in Control panel after you set the timezone.


I do not have a set date time in my control panel.

There is a set time zone.
Or Xclock.

Neither of which correct the problem.

The other thing is that the command line solution only stays correct as long as I do not restart the PC. If I do it goes back to the online sync time which is several (5 or 6) hours earlier than my time.

Now I just booted back in to Puppy from the other OS and the time is correct in it.
Wonder what happened there? Cause it was WAY OFF this morning.

Dorothy and Toto must have stopped by and fixed the problem.

_________________
www.gnu.org
www.PCCleanUp.US
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0775s ][ Queries: 12 (0.0051s) ][ GZIP on ]