Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 00:23
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
pup-volume-monitor-0.1.15 and desktop-drive-icons-0.0.6
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 7 of 11 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 Next
Author Message
mavrothal


Joined: 24 Aug 2009
Posts: 1802

PostPosted: Mon 01 Apr 2013, 11:11    Post_subject:  

peebee wrote:
Is there a typo at line 14 in pinstall.sh ? - fasle - should be false ??

Corrected in version 0.1.10-2. Thanks

peebee wrote:
Also the puninstall.sh looks for file /etc/.eventmanager_ORIG but this file is not created by the pinstall.sh - should it be??

but it does. Line 3 has
Code:
cp /etc/eventmanager /etc/.eventmanager_ORIG

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send_private_message 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Wed 03 Apr 2013, 12:39    Post_subject:  

Very sorry for replying late. I had been preparing for my board exams, performance in which can form (or deform) my future.

I still have engineering entrances left, but since I have already went through syllabus I decide to resume the development.

I may not be quick to respond now, as I have to study as well.
Back to top
View user's profile Send_private_message 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Wed 03 Apr 2013, 12:58    Post_subject:  

pup-volume-monitor updated to version 0.1.11

Changes:
  • Mounting and unmounting made more flexible using scripts at /usr/libexec/pup-volume-monitor/
  • Several multithreading bugs fixed
  • Some more GIO functions implemented


desktop-drive-icons updated to version 0.0.3

Changes:

  • New container written from scratch permitting icon arrangement in multiple rows
  • More advanced positioning options
  • New label widget written from scratch that allows controlling no. of lines to be displayed.
  • Performance improvements at several places
  • Extra workarounds added for openbox window manager
Back to top
View user's profile Send_private_message 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Wed 03 Apr 2013, 13:09    Post_subject:  

sc0ttman wrote:
I tried to compile , and I get this:

Code:
  CCLD   pup-volume-monitor
pup_volume_monitor-drive-probes.o: In function `pup_volume_assert':
/root/Downloads/pup-volume-monitor-0.1.10/daemon/drive-probes.c:172: undefined reference to `blkid_new_probe_from_filename'
collect2: ld returned 1 exit status
make[2]: *** [pup-volume-monitor] Error 1
make[2]: Leaving directory `/root/Downloads/pup-volume-monitor-0.1.10/daemon'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/Downloads/pup-volume-monitor-0.1.10'
make: *** [all] Error 2


I'm using glib-2.30 if that makes a difference, not patched... Is that my problem? Will it be a problem if I get past this one above?

I'm using blkid 1.0.0 (12-Feb-2003)... I assume it's too old, or needs re-compilng etc... If so... Where are the sources? Do I need specially patched puppy sources for blkid? Is ther ea pet for blkid or do I need to update the whole e2fsprogs pkg (if that is where blkid comes from)..?


blkid is too old. That must be the problem.

The lowest puppy version I tested, lucid puppy 511, has blkid 2.17.0.

blkid is in util-linux package, https://www.kernel.org/pub/linux/utils/util-linux/
Back to top
View user's profile Send_private_message 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Wed 03 Apr 2013, 13:12    Post_subject:  

okokoook wrote:
i just have little concern about the pup-volume-monitor. as instructed, i created those two scripts and left them in their corresponding directories respectively. but when i reboot, i got "not syncing, attempting to kill init" message. could anyone give me a hint on this? thank you

regards

michael


At which state does it happen exactly? And which puppy?
Back to top
View user's profile Send_private_message 
mavrothal


Joined: 24 Aug 2009
Posts: 1802

PostPosted: Wed 03 Apr 2013, 14:20    Post_subject:  

Hi Akash
nice to have you back.

Tries your pup-volume-monitor-0.1.11-i686-precise.pet/desktop_drive_icons-0.0.3-0-i686-precise5.4.0.90.pet in Precise-5.5 and Upup Precise 3.8.3.1

On Pecise-5.5 desktop_drive_icons fails with GLib-GObject-WARNINGs and segfault. Does it still needs the patched glib?
On Upup works fine but fails to update icons when a new removable is inserted. I remember this was also a problem in (the now removed) ArchPup. You need to restart pup-volume-monitor and desktop_drive_icons to see the new drives.
Talking about restart, /etc/init.d/start-pup-volume-monitor has a typo on line 15. It should be: pup-volume-monitor-starter

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send_private_message 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Wed 03 Apr 2013, 15:00    Post_subject:  

mavrothal wrote:

On Pecise-5.5 desktop_drive_icons fails with GLib-GObject-WARNINGs and segfault. Does it still needs the patched glib?

It's not exactly patched glib you need. The original glib source code doesn't have that bug. It has nothing to do with Jemimah's patch.

The guys who compile glib package are using some modified source on which I couldn't yet get my hands on.

mavrothal wrote:

On Upup works fine but fails to update icons when a new removable is inserted. I remember this was also a problem in (the now removed) ArchPup. You need to restart pup-volume-monitor and desktop_drive_icons to see the new drives.

udev events aren't reaching pup-volume-monitor. Check whether
udev is running, and udev rules file (/etc/udev/rules.d/50-pup-volume-monitor.rules) is actually used.

mavrothal wrote:

Talking about restart, /etc/init.d/start-pup-volume-monitor has a typo on line 15. It should be: pup-volume-monitor-starter

Oh yes it is.

I have fixed the precise pet.
Back to top
View user's profile Send_private_message 
mavrothal


Joined: 24 Aug 2009
Posts: 1802

PostPosted: Thu 04 Apr 2013, 00:38    Post_subject:  

akash_rawal wrote:

mavrothal wrote:

On Upup works fine but fails to update icons when a new removable is inserted. I remember this was also a problem in (the now removed) ArchPup. You need to restart pup-volume-monitor and desktop_drive_icons to see the new drives.

udev events aren't reaching pup-volume-monitor. Check whether
udev is running, and udev rules file (/etc/udev/rules.d/50-pup-volume-monitor.rules) is actually used.


Right.
Trying to get rid of the last pup_even drive icon, I had actually inactivated hotplug support in eventmanager, that also kills udevd Embarassed

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send_private_message 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Tue 16 Apr 2013, 13:10    Post_subject:  

pup-volume-monitor updated to 0.1.12
Changes:
  • Fixed persisting drive icons in gtk filechooser when daemon crashes
  • Fixed incorrect signal emissions when a mounted drive is removed
  • Removed the starter script pup-volume-monitor-starter. Now pup-volume-monitor-admin --start is used to start the daemon.
  • Fixed event logging to log files.
  • Now registers as a native volume monitor, fixes conflicts with Jemimah's glib patch. Export PUP_VOLUME_MONITOR_NO_NATIVE=1 to revert to original behavior.


desktop-drive-icons updated to 0.0.4
Changes:
  • Fixed 'division by 0' error when no drives are connected

Edited_time_total
Back to top
View user's profile Send_private_message 
mavrothal


Joined: 24 Aug 2009
Posts: 1802

PostPosted: Tue 16 Apr 2013, 15:05    Post_subject: Re: Desktop-drive-icons  

akash_rawal wrote:

Source package: desktop_drive_icons-0.0.4.tar.gz

Older versions: http://www.dropbox.com/sh/k1hn0un11p395k2/h-Qrv-1wgk/desktop-drive-icons


The desktop_drive_icons-0.0.4 link point to desktop_drive_icons-0.0.3.tar.gz.
desktop_drive_icons-0.0.4.tar.gz can be found in the "older versions" Smile

However, after getting it and compiling it still fails to run in Precise. Any hope there?

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send_private_message 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Tue 16 Apr 2013, 16:06    Post_subject: Re: Desktop-drive-icons  

mavrothal wrote:

The desktop_drive_icons-0.0.4 link point to desktop_drive_icons-0.0.3.tar.gz.
desktop_drive_icons-0.0.4.tar.gz can be found in the "older versions" Smile

Thanks to catch the mistake. Had been in hurry.

The link has been corrected.
mavrothal wrote:

However, after getting it and compiling it still fails to run in Precise. Any hope there?

If you are referring to the same 'two different plugins' problem you need the original glib. Compile and install an appropriate version from http://ftp.gnome.org/pub/GNOME/sources/glib/

You can use pkg-config --modversion glib-2.0 to find correct version of glib to download.
Back to top
View user's profile Send_private_message 
mavrothal


Joined: 24 Aug 2009
Posts: 1802

PostPosted: Wed 17 Apr 2013, 12:52    Post_subject: Re: Desktop-drive-icons  

akash_rawal wrote:

If you are referring to the same 'two different plugins' problem you need the original glib. Compile and install an appropriate version from http://ftp.gnome.org/pub/GNOME/sources/glib/


Actually installing BK's z_glib_fix-2.32.3-orig-precise540-i686.pet and you slacko pets in Precise-5.5, works just fine Very Happy

The only problem I have is that Y offset "-40" appears to be hard coded somewhere and even if /root/.config/desktop_drive_icons/config.ini has a different value (other settings in config.ini are "respected"). It can be changed and will adjust the position of the drivers but on re-launch will be -40 again Confused

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send_private_message 
peebee


Joined: 21 Sep 2008
Posts: 1518
Location: Worcestershire, UK

PostPosted: Fri 19 Apr 2013, 15:18    Post_subject: Difference 0.1.11 versus 0.1.12  

Hi

I am using p-v-m very succesfully with lxde/pcmanfm on top of slacko5.5 and other puppies....

However I have found a difference in behaviour between version 0.1.11 and the latest 0.1.12

The difference occurs when mounting a Samba network share with Yassm.

With 0.1.11 the share appears in the bookmark area of pcmanfm on mount - see screenie attached

With 0.1.12 the mount occurs and can be accessed from pcmanfm but no bookmark appears so the share cannot be unmounted from pcmanfm

Is this a deliberate change in behaviour? Hope not.

Cheers
peebee
capture14815.png
 Description   
 Filesize   39.46 KB
 Viewed   520 Time(s)

capture14815.png


_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Sat 20 Apr 2013, 00:26    Post_subject:  

mavrothal wrote:
The only problem I have is that Y offset "-40" appears to be hard coded somewhere and even if /root/.config/desktop_drive_icons/config.ini has a different value (other settings in config.ini are "respected"). It can be changed and will adjust the position of the drivers but on re-launch will be -40 again Confused


desktop-drive-icons updated to version 0.0.5
Changes:
  • Fixed a typo in src/settings.c, affecting saving of X and Y offsets in config file.(Thanks mavrothal)

Edited_time_total
Back to top
View user's profile Send_private_message 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Sat 20 Apr 2013, 00:44    Post_subject: Re: Difference 0.1.11 versus 0.1.12  

peebee wrote:
Hi

I am using p-v-m very succesfully with lxde/pcmanfm on top of slacko5.5 and other puppies....

However I have found a difference in behaviour between version 0.1.11 and the latest 0.1.12

The difference occurs when mounting a Samba network share with Yassm.

With 0.1.11 the share appears in the bookmark area of pcmanfm on mount - see screenie attached

With 0.1.12 the mount occurs and can be accessed from pcmanfm but no bookmark appears so the share cannot be unmounted from pcmanfm

Is this a deliberate change in behaviour? Hope not.

Cheers
peebee

Looks like I didn't know GLib's default mount monitor that pup-volume-monitor-0.1.12 overrides, shows samba shares also.

Just for confirmation, does the problem disappear when you start pcmanfm with environment variable PUP_VOLUME_MONITOR_NO_NATIVE=1, like:
Code:

killall pcmanfm
export PUP_VOLUME_MONITOR_NO_NATIVE=1
pcmanfm -p LXDE --desktop &
disown


If it does I'll invert environment variable control in next version.

I had done that because I noticed that with Jemimah's patch mounted drives are shown twice in file manager.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 7 of 11 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1038s ][ Queries: 13 (0.0068s) ][ GZIP on ]