Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 16:41
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Q Light Controller on Puppy.....
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
kjacobs

Joined: 20 Nov 2008
Posts: 45

PostPosted: Tue 09 Apr 2013, 10:43    Post_subject:  Q Light Controller on Puppy.....  

I am trying to get the Q Light Controller software running on Puppy Precise 5.4.3 and having no luck. It is available in a .deb file for ubuntu, appears to install just fine....but does not run at all.

Curious what I am missing here???? Or has anyone else had luck with this.....I am finding quite a few ubuntu programs that do not run on precise or require a lot of tweaking to get going. Thanks.....
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3972
Location: World_Hub

PostPosted: Tue 09 Apr 2013, 18:30    Post_subject:  

KJacobs- which interface are you using? Run this from a console and dump the output:
Code:
ldd /usr/bin/qlc
Back to top
View user's profile Send_private_message 
kjacobs

Joined: 20 Nov 2008
Posts: 45

PostPosted: Wed 10 Apr 2013, 00:19    Post_subject:  

I am using a Entec Open interface, however I cannot even get QLC to start. Here is the dump.....does this look like QT is missing????

ldd /usr/bin/qlc
linux-gate.so.1 => (0xffffe000)
libqlcengine.so.1 => /usr/lib/libqlcengine.so.1 (0xb76d0000)
libqlcui.so.1 => /usr/lib/libqlcui.so.1 (0xb751d000)
libQtXml.so.4 => not found
libQtGui.so.4 => not found
libQtCore.so.4 => not found
libpthread.so.0 => /lib/libpthread.so.0 (0xb74f2000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb740d000)
libm.so.6 => /lib/libm.so.6 (0xb73e0000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb73c2000)
libc.so.6 => /lib/libc.so.6 (0xb7218000)
libQtXml.so.4 => not found
libQtCore.so.4 => not found
libX11.so.6 => /usr/lib/libX11.so.6 (0xb70e3000)
/lib/ld-linux.so.2 (0xb7772000)
libQtXml.so.4 => not found
libQtGui.so.4 => not found
libQtCore.so.4 => not found
libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb70c2000)
libdl.so.2 => /lib/libdl.so.2 (0xb70bc000)
libXau.so.6 => /usr/lib/libXau.so.6 (0xb70b8000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb70b1000)
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3972
Location: World_Hub

PostPosted: Wed 10 Apr 2013, 06:19    Post_subject:  

Installing libqt4-core should take care and handle those loose ends. DO install..

If you manage, there's a note about Enttec widgets here under tips & tricks.
Back to top
View user's profile Send_private_message 
kjacobs

Joined: 20 Nov 2008
Posts: 45

PostPosted: Wed 10 Apr 2013, 10:44    Post_subject:  

OK....i installed the libqt4-core and then tried to run QLC again......still no luck. Here is the new dump.....something is still missing, but its getting closer.

ldd /usr/bin/qlc
linux-gate.so.1 => (0xffffe000)
libqlcengine.so.1 => /usr/lib/libqlcengine.so.1 (0xb766e000)
libqlcui.so.1 => /usr/lib/libqlcui.so.1 (0xb74bb000)
libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0xb747a000)
libQtGui.so.4 => not found
libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0xb718e000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb7173000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb708e000)
libm.so.6 => /lib/libm.so.6 (0xb7061000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7043000)
libc.so.6 => /lib/libc.so.6 (0xb6e99000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb6d65000)
libQtGui.so.4 => not found
libz.so.1 => /lib/libz.so.1 (0xb6d4e000)
libdl.so.2 => /lib/libdl.so.2 (0xb6d49000)
librt.so.1 => /lib/librt.so.1 (0xb6d40000)
libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0xb6c47000)
/lib/ld-linux.so.2 (0xb7710000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6c26000)
libpcre.so.3 => /lib/libpcre.so.3 (0xb6be9000)
libXau.so.6 => /usr/lib/libXau.so.6 (0xb6be5000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6bde000)
Back to top
View user's profile Send_private_message 
kjacobs

Joined: 20 Nov 2008
Posts: 45

PostPosted: Wed 10 Apr 2013, 10:52    Post_subject:  

AHA! Now its working.....I installed the libqt4-gui and it came right up once everything was done. Thanks for the help getting this rolling. Now to see how it runs in puppy.........

Ken
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0908s ][ Queries: 12 (0.0461s) ][ GZIP on ]