Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 28 Jul 2014, 04:57
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Business
Bitcoin client
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Sun 31 Mar 2013, 23:16    Post subject:  Bitcoin client
Subject description: The "original" bitcoin client, now in Dotpet form.
 

Okay, here it is, Bitcoin-QT, packaged into a nice, neat Dotpet for your convenience.

I'll probably add a description later, but, for now, you can just read up on it from the Bitcoin wiki page on it: https://en.bitcoin.it/wiki/Bitcoin-Qt

Download version 0.8.1

_________________
Version 27. Dotpet. Click here.
(SFS available too!)

Back to top
View user's profile Send private message 
fefifofum

Joined: 06 Apr 2013
Posts: 6

PostPosted: Sat 06 Apr 2013, 23:52    Post subject: Bitcoin
Subject description: Bitcoin will not launch on Puppy Linux 5.2.8 Lucid
 

Im a newbie and I just installed the .pet and the program will not launch. I went to identify any missing dependencies and this is what I got:

" Bitcoin-qt: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: no such file or directory. "

Your help would be appreciated.
Back to top
View user's profile Send private message 
Dromeno

Joined: 12 Sep 2008
Posts: 534

PostPosted: Fri 12 Apr 2013, 06:39    Post subject: working -thanks  

Still working in Lucid Puppy 528 005. It seems to install fine. Menu entry is in Utilities but I think Business, Calculate or Personal would be a better place.

Hopefully Bitcoin wallet can be merged with Homebank at some time!

Test results: at first I got a message that disk space was insufficient but after moving the ~/.bitcoin directory to somewhere else and replacing it with a symlink it was all fine. I can imagine that placing the actual .bitcoin directory in a truecrypt vault would be a good idea but I am not sure yet if that enhances protection against e-robbers.

then I watched
https://www.youtube.com/watch?v=ejiqbzqmxSE to learn what it was all about. Interesting! I realized what I was missing: a simple GPL template to setup a webshop which accepts bitcoins.

I hope wordpress offers something like that, I am going to look for it, but suggestions are welcome!
Back to top
View user's profile Send private message 
Dromeno

Joined: 12 Sep 2008
Posts: 534

PostPosted: Fri 03 May 2013, 07:28    Post subject: Litecoin, Opencoin and Ripple  

Bitcoin is not the ony digital money option anymore:

https://www.computerworld.com/s/article/9238328/Bitcoin_rival_Ripple_looks_to_make_waves

Opencoin/ripple seems to be a java app but litecoin isn't. So a litecoin wallet pet might be useful. Anyone?

http://litecoin.org/
Back to top
View user's profile Send private message 
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Fri 10 May 2013, 04:51    Post subject:  

is it possible to upgrade from v..0.7.1 to 0.8.1? I'm getting a message that I need to do this but I don't know how to, without losing the blockchain which took me ages to download.
_________________
Buy silver, crash JPMorgan
Back to top
View user's profile Send private message 
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Sun 19 May 2013, 00:54    Post subject:  

failed to install 081, received error message after downloading.
_________________
Buy silver, crash JPMorgan
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2434
Location: near here

PostPosted: Wed 25 Sep 2013, 10:19    Post subject:  

added to wiki
http://puppylinux.org/wikka/bitcoin-qt

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
ringo

Joined: 10 Sep 2011
Posts: 11

PostPosted: Tue 26 Nov 2013, 15:25    Post subject:  

Any updates available?
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3578
Location: World_Hub

PostPosted: Tue 26 Nov 2013, 20:55    Post subject:  

Search Launchpad- they have the latest Precise binaries.
Back to top
View user's profile Send private message 
KentC


Joined: 16 Sep 2012
Posts: 56

PostPosted: Fri 29 Nov 2013, 14:50    Post subject:  

Hello Fellow Puppy431 users

I'm using that version currently, was able to get "qt4" with DEV installed, and ended up with dep check saying there wasn't any missing lib files or dependencies.

Unless someone knows a better way, I want to say you can't run this on Puppy 4.3.1

EDIT:Ok, after a second look, now the puppy manager says qt4 is missing when it's installed. I will say this isn't going to work for sure even though I have the needed requirements.

I grabbed such from here:
http://puppylinux.org/wikka/Qt
*I used qt-4.8.0.pet and qt-DEV-4.8.0.pet for Saluki which installed fine*

Kent C.
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Thu 19 Dec 2013, 06:24    Post subject:  

I'm more interested in mining.. anyone can help me install miner in puppy ?
_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Business
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0619s ][ Queries: 12 (0.0044s) ][ GZIP on ]