Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 16 Sep 2014, 15:34
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
LibreOffice 4.x + language packs (latest: 4.3.1)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 9 [132 Posts]   Goto page: 1, 2, 3, ..., 7, 8, 9 Next
Author Message
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Sun 28 Apr 2013, 13:04    Post subject:  LibreOffice 4.x + language packs (latest: 4.3.1)
Subject description: with optional Java and Asian fonts
 

This LibreOffice packages were compiled or generated by forum members using the get-libreoffice utility by 01micko and the sfs2pet-20121001 tool by TheAsterisk! (unless specified), and put here for reference. The packages should work for most Puppy Linux versions. Some packages include a second language, for example French (fr) or Spanish (es). However, LibreOffice will set to the system language or the language you choose at Tools > Options > Languages, so you can perfectly use any of these LibreOffice packages in English, or in any other language by installing a langpack, see the language packs section at the end of the post.

LibreOffice install packages

LibreOffice PET & SFS packages (no extra languages, thanks to Puppus Dogfellow):

LibreOffice 4.3.1 (PET) - LibreOffice 4.3.1 (SFS)
LibreOffice 4.3.0 (PET) - LibreOffice 4.3.0 (SFS)
LibreOffice 4.2.5 (PET) - LibreOffice 4.2.5 (SFS)
LibreOffice 4.1.5 (PET) - LibreOffice 4.1.5 (SFS)

LibreOffice English + Spanish translation and help files:

LibreOffice 4.3.0 (SFS)
LibreOffice 4.2.3 (SFS) - Mirror
LibreOffice 4.2.3 (PET)
LibreOffice 4.1.4 SFS

English plus French LibreOffice (v4.3.0 and older) maintained by Bruno from the ASRI Éducation forum:

http://forum.asri-education.org/viewtopic.php?f=29&t=216

LibreOffice from Slacko repository, works in other puppies as well:

LibreOffice 4.1.0 (SFS)

LibreOffice 4.0 series packaged for Puppy by members of the ASRI Éducation forum including support for French language:

LibreOffice 4.0.6 (PET, 173 MB)

LibreOffice 4.0.2 (SFS, 184 MB)

LibreOffice 4.0.2 (PET, 187 MB)

LibreOffice 4.0.3 (SFS, 184 MB)

LibreOffice 4.0.3 (PET, 187 MB)

LibreOffice 4.0.5 (PET, 182 MB)

Optional for those who want to install Java as well:
Here are SFS files of JRE 1.7u60 and JRE 1.8u05 made by Shinobar. (See this thread to check for updates), or this thread from the ASRI forum
PET version of JRE 1.7u60 and JRE 1.7u51 made by Bruno from the ASRI Éducation forum.
SFS and PET version of JRE 1.7u51 made by OscarTalks.
More information

Also optional: Extra fonts (2.7 MB, collection of free TTF fonts)

See also the languages section below for special fonts to display Chinese, Japanese, Korean, and Indic characters.

To play sound of PowerPoint presentations in LibreOffice Impress, you need GStreamer. There are packages available for Slacko, Wary / Lucid, and Precise.

Question What LibreOffice package should I choose, PET or SFS?
If you have a frugal install or live CD + session file, you can use SFS files so that they don't take space from your session file. If you want to make a remastered live CD that includes LibreOffice, use PET files. You can use both for full installs. You can add SFS files from the Menu > System > Bootmanager, or from the Menu > Setup > SFS Load (you can also right-click the SFS file and select "sfs_load"). Make sure the SFS files are in the root directory of the partition where your session file is stored.

Question Do I need Java?
Basically, if you don't do anything complex then you can do without Java. Java is required for certain functions, and in particular for LibreOffice Base.

Compatible Puppy versions

This packages should work in most modern versions of Puppy Linux, for older ones it is recommended to use v4.0 series or v3.5 series. If a package doesn't work in the Puppy you're using, please post a message saying both the LibreOffice and Puppy version.

Idea You may get an error message saying the file 'modelle.ott' doesn't exist, this happens when you run LibreOffice in French. In that case just type in a terminal:

Code:
touch /root/.config/modelle.ott


Then you will be able to run LibreOffice.

Languages, Asian fonts

Built-in support for English and French (français) is included for v4.0.x packages thanks to the members of the ASRI Éducation community. Some packages (when indicated) include Spanish (español) help and translation files.

You can download langpack PETs (with spellcheck if available) from the list at the end of this post, they are convenient so that you can install the eight DEB packages of the .tar.gz in one click.

To view the LibreOffice GUI in Chinese, Japanese and Korean you may need this font package. Install it only if you don't have a Puppy langpack of your language installed, as the latter should already include appropiate fonts.

To view the LibreOffice GUI in languages spoken in India, Nepal, Bangladesh and Sri Lanka, here is a font package. Install it only if you don't have a Puppy langpack of your language installed, as the latter should already include appropiate fonts. At the moment there is only Hindi available as PET package in the v4.1 list below, but you can request a PET for your language, or make one yourself (read below).

If there isn't a PET for your language, the following instructions explain how to make one, or if you don't mind to install the eight DEBs separately, simply follow step 2:

Idea How to build a libreoffice_langpack.pet:
1. Download the utilities attached at the end of this post (extract-makepet and extract-all-debs). Note that they are made for ROX-Filer, they will not work in other file managers.
2. Download your language package from the LibreOffice site for 4.3 series,v4.2 series, v4.1 series or v4.0 series (click your language and then click 'Translated user interface' to download).
3. Right-click the .tar.gz package and select 'extract-tgz', all the files will be extracted to 'extracted-tgz', click that folder and the one inside, you'll see a folder called 'DEBS'.
4. Right-click the 'DEBS' folder and select 'extract-all-debs', all DEBs will be extracted to a folder named 'extracted-debs' inside the 'DEBS' folder.
5. Rename the 'extracted-debs' folder as 'libreoffice_langpack_LANG-4.0' where LANG is your language code, for example 'uk' for Ukrainian or 'tr' for Turkish, then right-click that folder and select 'makepet'.
6. On the 'makepet' window, choose 'Document' in the Category field, and in the Description field write 'LANG langpack for LibreOffice 4.0.x' where LANG is your language, then click 'Generate package database entry' button at the end of the window and wait.
7. Upload the PET to an online storage service like Dropbox or Yandex.Disk (use a service that doesn't require username-password, doesn't have download limits, doesn't require users to pay, and doesn't abuse of flash animations or ads, so that users can download your file easily), then share the link in this thread.


Language packs

Download LibreOffice 4.3.x language pack (PET) for:
Chinese (Simplified) - 中文 (简体)
Chinese (Traditional) - 中文 (正體)
English (United Kingdom)
French (Français)
German (Deutsch)
Italian (Italiano)
Japanese (日本語)
Polish (Polsky)
Portuguese (Portugal) - Português europeu
Portuguese (Brazil) - Português do Brasil
Russian (Русский)
Spanish already included in SFS above

Download LibreOffice 4.2.x language pack (PET) for:
Afrikaans
Albanian (shqip)
Arabic (العربية)
Basque (euskara)
Bulgarian (български)
Catalan (Català)
Chinese (Simplified) - 中文 (简体)
Chinese (Traditional) - 中文 (正體)
Czech (čeština)
Danish (Dansk)
Dutch (Nederlands)
English (United Kingdom)
Finnish (Suomi)
French (Français) already included in packages with file name containing 'fr'
Galician (Galego)
German (Deutsch)
Greek (Ελληνικά)
Hebrew (עברית)
Hungarian (Magyar)
Hindi (हिन्दी)
Icelandic (Íslenska)
Indonesian (Bahasa Indonesia)
Italian (Italiano)
Japanese (日本語)
Korean (한국어 [韓國語])
Macedonian (македонски)
Norwegian Bokmål (Bokmål)
Norwegian Nynorsk (Nynorsk)
Polish (Polski)
Portuguese from Portugal (Português europeu)
Portuguese from Brazil (Português do Brasil)
Romanian (român)
Russian (Русский)
Serbian (српски)
Slovak (slovenčina)
Spanish (Español) already included in packages with file name containing 'es'
Swedish (Svenska)
Tamil (தமிழ்)
Turkish (Türkçe)
Ukrainian (Українська)
Vietnamese (tiếng việt)

Download LibreOffice 4.1.x langpack (PET) for:
Catalan (Català) - 1.1 MB
Chinese (Simplified) - 中文 (简体) - 614 KB
Chinese (Traditional) - 中文 (正體) - 610 KB
Danish (Dansk) 2.3 MB
Dutch (Nederlands) 1.4 MB
French (Français) 2.7 MB (already included in packages with file name containing 'fr')
Finnish (Suomi) 546 KB
German (Deutsch) 10.7 MB
Greek (Ελληνικά) 2.1 MB
Hindi (हिन्दी) 682 KB
Hungarian (Magyar) 2.6 MB
Italian (Italiano) 1.8 MB
Japanese (日本語) 633 KB
Korean (한국어 [韓國語]) 624 KB
Polish (Polski) 3.2 MB
Portuguese from Brazil (Português do Brasil) 2.3 MB
Portuguese from Portugal (Português europeu) 936 KB
Russian (Русский) 1.7 MB
Spanish (Español) 2 MB (already included in packages with file name containing 'es')

Download LibreOffice 4.0.x language pack (PET) for:
Chinese (Simplified) - 中文 (简体) - 688 KB
Chinese (Traditional) - 中文 (正體) - 685 KB
Danish (Dansk) 2.4 MB
Dutch (Nederlands) 1.3 MB
Finnish (Suomi) 701 KB
French already included in packages with file name containing 'fr'
German (Deutsch) 11 MB
Greek (Ελληνικά) 2.2 MB
Hungarian (Magyar) 2.7 MB
Italian (Italiano) 1.8 MB
Japanese (日本語) 710 KB
Korean (한국어 [韓國語]) 699 KB
Polish (Polski) 3.2 MB
Portuguese from Brazil (Português do Brasil) 2.3 MB
Portuguese from Portugal (Português europeu) 936 KB
Russian (Русский) 1.7 MB
Spanish (Español) 2 MB


Older LibreOffice 3.5 series:
http://murga-linux.com/puppy/viewtopic.php?t=79039
libreoffice.jpg
 Description   
 Filesize   37.5 KB
 Viewed   11250 Time(s)

libreoffice.jpg

libreofficelang.jpg
 Description   
 Filesize   100.4 KB
 Viewed   11168 Time(s)

libreofficelang.jpg

Extract-makepet-1.0.pet
Description  Extract packages / convert folder to PET (by shinobar)
pet

 Download 
Filename  Extract-makepet-1.0.pet 
Filesize  112.7 KB 
Downloaded  797 Time(s) 
extract_all_debs_1.0.pet
Description  Extract all DEBs inside a folder (by right-click, for ROX-Filer)
pet

 Download 
Filename  extract_all_debs_1.0.pet 
Filesize  1.16 KB 
Downloaded  730 Time(s) 

_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español

Last edited by vicmz on Fri 05 Sep 2014, 20:27; edited 79 times in total
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Sun 28 Apr 2013, 16:56    Post subject:  

Arrow Added langpacks for:

Chinese (Simplified) - 中文 (简体)
Chinese (Traditional) - 中文 (正體)
Finnish (Suomi)
Japanese (日本語)
Polish (Polski)
Russian (Русский)
Spanish (Español)

Arrow German speakers: the German langpack is ready to upload, but it's too big (11 MB) for my slow connection at home. I'll upload it later from a broadband source.

_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Mon 29 Apr 2013, 20:52    Post subject:  

Arrow German langpack ready to download
_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Wed 01 May 2013, 21:36    Post subject:  

Arrow Added:
Danish
Dutch
Greek
Hungarian
Italian
Korean
Portuguese from Brazil
Portuguese from Portugal

Also, HOWTO make a libreoffice_langpack.pet if there isn't one for your language, a collection of free TTF fonts, and special fonts to display text (as well as the LibreOffice GUI) in Chinese, Japanese, and Korean.

_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
boxR


Joined: 13 Aug 2011
Posts: 245
Location: France

PostPosted: Thu 09 May 2013, 14:47    Post subject: Re: LibreOffice 4.0.2 + language packs
Subject description: Should work in most Puppies
 

vicmz wrote:
These packages were compiled by members of the ASRI Éducation forum (nous vous remercions)

It is not exactly compiled by us. It's a package for puppy created from .deb packages.

To note that to update Java to 1.7, it may be necessary to erase /root/.config/libreoffice/4/user/config/javasettings_Linux_x86.xml
Back to top
View user's profile Send private message 
rameshiyer

Joined: 17 Sep 2009
Posts: 232
Location: Calicut, Kerala, India

PostPosted: Thu 06 Jun 2013, 04:44    Post subject: LibreOffice
Subject description: Text and spreadsheet only
 

Please provide cut down version of latest LibreOffice. Wants only Text writer.
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger 
darry1966

Joined: 26 Feb 2012
Posts: 425
Location: New Zealand

PostPosted: Fri 07 Jun 2013, 07:12    Post subject: A Big Thankyou  

I am using this on my Puppy 4.12 Barebones based OS and it works great thank you so much.
Back to top
View user's profile Send private message 
linuppy

Joined: 14 Jun 2013
Posts: 6
Location: Italy

PostPosted: Fri 14 Jun 2013, 05:06    Post subject: libreoffice 4.0.2 not working  

I can't get libreoffice 4.0.2 sfs working on precise puppy 5.6.1
Installation went fine but when I try to launch base or writer, splash screen stucks on Enabling: ...

Any help appreciated

PS JRE installed
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Fri 14 Jun 2013, 16:50    Post subject: Re: libreoffice 4.0.2 not working  

linuppy wrote:
I can't get libreoffice 4.0.2 sfs working on precise puppy 5.6.1
Installation went fine but when I try to launch base or writer, splash screen stucks on Enabling: ...

Any help appreciated

PS JRE installed


Sorry, I was unable to reproduce your bug, it works for me even without Java. I'll tell later if I find out anything. Maybe you don't have enough RAM space, or the space in your save-file is too small (in that case you should run Menu > Utilities > Resize Personal Storage File and add at least 256 MB to your save-file).

_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
boxR


Joined: 13 Aug 2011
Posts: 245
Location: France

PostPosted: Sat 15 Jun 2013, 04:07    Post subject: Re: libreoffice 4.0.2 not working  

linuppy wrote:
I can't get libreoffice 4.0.2 sfs working on precise puppy 5.6.1
Installation went fine but when I try to launch base or writer, splash screen stucks on Enabling: ...

Any help appreciated

PS JRE installed

Try in terminal to give us error message.
Back to top
View user's profile Send private message 
linuppy

Joined: 14 Jun 2013
Posts: 6
Location: Italy

PostPosted: Sat 15 Jun 2013, 17:11    Post subject: Re: libreoffice 4.0.2 not working  

Any help appreciated

PS JRE installed[/quote]
Try in terminal to give us error message.[/quote]

I am a newbie. Which command have I to type?
@vicmz
I have 512 MB RAM and 2 GB swap file enabled.
Back to top
View user's profile Send private message 
boxR


Joined: 13 Aug 2011
Posts: 245
Location: France

PostPosted: Sun 16 Jun 2013, 14:24    Post subject: Re: libreoffice 4.0.2 not working  

linuppy wrote:
Which command have I to type?

Just type libreoffice in terminal.
Back to top
View user's profile Send private message 
boxR


Joined: 13 Aug 2011
Posts: 245
Location: France

PostPosted: Sun 16 Jun 2013, 14:46    Post subject:  

The 4.0.3 version is now available.
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Sun 16 Jun 2013, 19:26    Post subject: Re: libreoffice 4.0.2 not working  

LibreOffice 4.0.3 packages added, see first post. Thank you boxR.

linuppy wrote:

I am a newbie. Which command have I to type?


Clic the 'console' icon on the desktop or Menu > Utilities > Urxvt Terminal Emulator. In the window that appears type libreoffice then press ENTER in the keyboard. If there is a problem, the terminal window will show more text. Copy that text, or make a screenshot (Menu > Graphics > Screeny) and post it here.

_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
linuppy

Joined: 14 Jun 2013
Posts: 6
Location: Italy

PostPosted: Mon 17 Jun 2013, 05:33    Post subject:  

My screen capture is... black.
Maybe I make some mistake when installing the sfs file.
I click on the package then I read: pupmode=2 is experimental... Click Ok to install. Have I to use "Sfs on the fly" to install? Rolling Eyes
Thanks
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 9 [132 Posts]   Goto page: 1, 2, 3, ..., 7, 8, 9 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1163s ][ Queries: 13 (0.0047s) ][ GZIP on ]