Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 18:29
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Chromium browser version 27 - Feb 12, 2013
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 4 [58 Posts]   Goto page: Previous 1, 2, 3, 4
Author Message
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Tue 12 Mar 2013, 12:23    Post subject:  256 Downloads!
Subject description: Thank you all for helping me reach this milestone!
 

Well, as March 12th, I've reached 256 downloads for the Dotpet version! (that doesn't even include the SFS downloads!)

Also, version 27 appears to be more popular than the original v26 release, about 33% more for the Dotpet, and 400% more for the SFS. Very Happy

_________________
Version 27. Dotpet. Click here.
(SFS available too!)

Back to top
View user's profile Send private message 
HiDeHo

Joined: 16 Mar 2011
Posts: 286

PostPosted: Wed 13 Mar 2013, 05:08    Post subject: Re: Chromium browser *UP TO DATE* (version 27)
Subject description: That's right, I'm coming out with a standalone, up-to-date Chromium Dotpet. :D
 

JamesTheAwesomeDude wrote:
Okay, because of my amazing awesomeness, I've decided to come out with an up-to-date, standalone, fully functional Chromium Dotpet. (Not Google Chrome.)

It should be compatible with all Puppy Linux distros. It has some very mild testing on Lucid, works out-of-the-box on Precise, and it works on Slacko. On Slacko, you need to install GConf, but that's available from the Puppy Package Manager (just search for "gconf". Installs in under 2 minutes, including startup time for PPM.)

Anyway, I need feedback. Do you like it? Should I make more dotpets? I'm open to requests. I remember being a n00b and wishing that all software was easily available in Dotpet form, so now I'm helping provide that.

Download:
Chromium Version 27.0.1421.0

(http://dl.dropbox.com/u/98745514/Dotpets/Chromium/chromium-27.0.1421.0.pet)

SFS download here.


sorry to say that this chromium pet does not work with saluki. and as saluki is built or wary/racy it will not work on wary and racy as well.

wary and racy builds dont have the needed dependancies built into the bass even though i added the mozilla-libs.pet from the ppm in saluki I got this error.
Code:
 /opt/chromium/chrome: /lib/libc.so.6 version 'GLIBC_2.11' not found (required by /opt/chromium/chrome)
/opt/chromium/chrome: /usr/lib/libstdc++.so.6: version 'GLIBCXX_3.4.11' Not found (required by /opt/chromium/chrome)


if it is at all possible for somebody to wright s pet for wary / racy / saluki that has the needed dependencies it would be great. chrome 12 seems to work but nothing newer.

thanks for the help I appreciate it in advance.

this would greatly improve puppy for all if this can be sorted. [/code]

_________________
HiDeHo is an ideas man. loves to come up with ideas that others think are good and can use
if you are a sneeky computer geek check out sneekygeekers click here
Back to top
View user's profile Send private message 
JamesTheAwesomeDude


Joined: 29 Jan 2013
Posts: 99
Location: Classified

PostPosted: Wed 13 Mar 2013, 10:16    Post subject: Re: Chromium browser *UP TO DATE* (version 27)
Subject description: That's right, I'm coming out with a standalone, up-to-date Chromium Dotpet. :D
 

HiDeHo wrote:
sorry to say that this chromium pet does not work with saluki. and as saluki is built or wary/racy it will not work on wary and racy as well.

wary and racy builds dont have the needed dependancies built into the bass even though i added the mozilla-libs.pet from the ppm in saluki I got this error.
Code:
 /opt/chromium/chrome: /lib/libc.so.6 version 'GLIBC_2.11' not found (required by /opt/chromium/chrome)
/opt/chromium/chrome: /usr/lib/libstdc++.so.6: version 'GLIBCXX_3.4.11' Not found (required by /opt/chromium/chrome)


if it is at all possible for somebody to wright s pet for wary / racy / saluki that has the needed dependencies it would be great. chrome 12 seems to work but nothing newer.

thanks for the help I appreciate it in advance.

this would greatly improve puppy for all if this can be sorted. [/code]


Here, extract this file to /root/my-applications/lib. I just pulled the libs off my system, let me know if they work.

https://dl.dropbox.com/u/98745514/Bologna/TheMissingLibs.tar.xz (File is .81 MB, contains 2.58 MB of libs - only the ones you listed as missing/outdated.)

If it's not recognizing the libraries' existence, then extract libc* to /lib, and libstdc* to /usr/lib.

_________________
Version 27. Dotpet. Click here.
(SFS available too!)

Back to top
View user's profile Send private message 
HiDeHo

Joined: 16 Mar 2011
Posts: 286

PostPosted: Mon 18 Mar 2013, 03:30    Post subject: Re: Chromium browser *UP TO DATE* (version 27)
Subject description: That's right, I'm coming out with a standalone, up-to-date Chromium Dotpet. :D
 

JamesTheAwesomeDude wrote:

Here, extract this file to /root/my-applications/lib. I just pulled the libs off my system, let me know if they work.

https://dl.dropbox.com/u/98745514/Bologna/TheMissingLibs.tar.xz (File is .81 MB, contains 2.58 MB of libs - only the ones you listed as missing/outdated.)

If it's not recognizing the libraries' existence, then extract libc* to /lib, and libstdc* to /usr/lib.
first in saluki pup i booted into ram without save file. i intalled chromium 27.pet I ran from terminal and got this
Code:
# chromium
/opt/chromium/chrome: error while loading shared libraries: libnss3.so: cannot open shared object file: No such file or directory
i then downloaded your File and extracted the libs to /root/my-applications/lib nothing worked.

i then moved the files as you suggested to the places. there was already some there but i replaced them with your new ones then i ran chromium from terminal and got this
Code:
# chromium
/opt/chromium/chrome-wrapper: line 90: 28920 Segmentation fault      which xdg-settings >&/dev/null
/opt/chromium/chrome-wrapper: line 97: 28940 Segmentation fault      uname -m
     28941                       | grep -qs x86_64
/opt/chromium/chrome-wrapper: line 104: 28942 Broken pipe             echo $MISSING_LIBS
     28943 Segmentation fault      | grep -qs libbz2.so.1.0
/opt/chromium/chrome-wrapper: line 118: 28944 Broken pipe             echo $MISSING_LIBS
     28945 Segmentation fault      | grep -qs $lib
/opt/chromium/chrome-wrapper: line 118: 28946 Broken pipe             echo $MISSING_LIBS
     28947 Segmentation fault      | grep -qs $lib
/opt/chromium/chrome-wrapper: line 118: 28949 Broken pipe             echo $MISSING_LIBS
     28950 Segmentation fault      | grep -qs $lib
/opt/chromium/chrome-wrapper: line 118: 28955 Broken pipe             echo $MISSING_LIBS
     28956 Segmentation fault      | grep -qs $lib
/opt/chromium/chrome-wrapper: line 118: 28957 Broken pipe             echo $MISSING_LIBS
     28958 Segmentation fault      | grep -qs $lib
/opt/chromium/chrome-wrapper: line 118: 28959 Done                    echo $MISSING_LIBS
     28960 Segmentation fault      | grep -qs $lib
/opt/chromium/chrome-wrapper: line 118: 28961 Broken pipe             echo $MISSING_LIBS
     28962 Segmentation fault      | grep -qs $lib
/opt/chromium/chrome-wrapper: line 163: /chrome: No such file or directory
/opt/chromium/chrome-wrapper: line 163: exec: /chrome: cannot execute: No such file or directory
it appears that it is not as easy to install chrome chromium etc in saluki and other wary/racy build puppies.

could you install saluki etc and try to sort it out so your chromium27.pet works. thanks. when you have worked it out can you make a pet to install them automatically would be great.

thanks in advance for any work you do for the community.

_________________
HiDeHo is an ideas man. loves to come up with ideas that others think are good and can use
if you are a sneeky computer geek check out sneekygeekers click here
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Mon 18 Mar 2013, 06:21    Post subject: Re: Chromium browser *UP TO DATE* (version 27)
Subject description: That's right, I'm coming out with a standalone, up-to-date Chromium Dotpet. :D
 

HiDeHo wrote:
it appears that it is not as easy to install chrome chromium etc in saluki and other wary/racy build puppies.


Don't waste your time. Chromium later than version 12 will not work in Racy, Wary and derivatives (Saluki). A later version of glibc compiled in Wary/Racy is required and BK does not seem interested in doing what is necessary.

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
HiDeHo

Joined: 16 Mar 2011
Posts: 286

PostPosted: Mon 18 Mar 2013, 21:36    Post subject:  Re: Chromium browser *UP TO DATE* (version 27)
Subject description: That's right, I'm coming out with a standalone, up-to-date Chromium Dotpet. :D
 

Terryphi wrote:
Don't waste your time. Chromium later than version 12 will not work in Racy, Wary and derivatives (Saluki). A later version of glibc compiled in Wary/Racy is required and BK does not seem interested in doing what is necessary.
there are many others in the puppy community that are skilled and could do it. I cant work out why chromium etc wont run i thought most of teh major browsers used the same libraries anyway. it is getting hard to use chrome 12 as allot of the extensions will no longer work with it. unless someone can find a hack.

if chromium etc dont work in wary/racy builds then a new pupy with xfce dektop and easy apps to build your own puppy version. could be made i guess. sigh. i have found with pupoy that when you find a version you love eventually you will not be able to use it.

for me first it was lighthouse then that stopped being worked on. then saluki came along great now chrome browser etc does not work ridicules.

when can i find a puppy with the features I like that is maintained and working. if wary/racy could run chrome then it would be the best.

_________________
HiDeHo is an ideas man. loves to come up with ideas that others think are good and can use
if you are a sneeky computer geek check out sneekygeekers click here
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Tue 19 Mar 2013, 02:45    Post subject:  

HiDeHo,

Have you tried Precise 5.5? The latest Chromium can be made to run on it.

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
rameshiyer

Joined: 17 Sep 2009
Posts: 232
Location: Calicut, Kerala, India

PostPosted: Tue 19 Mar 2013, 10:53    Post subject: Chromium
Subject description: Wary/Racy
 

I am posting from Chromium 27 installed in Precise Puppy 5.5. I fined problem only in Racy/Wary. In Lupu, or Upup, there won't be any problem for working Chromium, Google chrome. Iron browser also will work without any problem. I have been using chrome variant in Puppy, Upup etc. Even I have installed .deb file. It is working !!

Earlier one of our forum member used to release chromium, Google-chrome for Warry etc. However, he is retired from making pet for google-chrome due to his ill health.

I have asked several time for chromium project for Wary or Racy. However, nobody provided the same till date. I would like to have latest release. I don't know why people are not providing chrome compatible for wary/racy
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Tue 19 Mar 2013, 12:43    Post subject: Re: Chromium
Subject description: Wary/Racy
 

rameshiyer wrote:
I don't know why people are not providing chrome compatible for wary/racy

:sigh: This has been explained many times. Racy and Wary do not have libraries compatible with the latest versions of Chromium. Barry Kauler is not updating Racy and Wary libraries because he has turned his attention to Precise Puppy.

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
carenrose

Joined: 10 Dec 2012
Posts: 28

PostPosted: Tue 02 Apr 2013, 17:58    Post subject:  

peebee wrote:
Try:
http://smokey01.com/saluki/sfs/google-chrome-stable_12.0.742.112-r90304_i386.sfs

this is the latest version that will run on Wary / Racy / Saluki / Carolina as they do not contain new enough libraries and are unlikely to be updated in this respect.

If you need the latested Chromium browsers you will have to move to Precise or Slacko or Upup-Precise....


Thank you Very Happy Finally got it downloaded and working.

Oddly enough, the md5sum was different than that listed on the site, no matter how many times or what connection I downloaded it from ... and it wouldn't work. So I converted it to a pet (have plenty of space in my savefile, although it's not ideal) and it worked fine ... hmm ...

Yay for Chrome, even though it's an old version.
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 907
Location: London, England

PostPosted: Thu 11 Apr 2013, 10:44    Post subject:  

If you install and run this package it creates an extra .desktop file in /root/.local/share/applications

Next time you run fixmenus or install anything you may find that you have an additional chromium entry in your menu and the second one just brings up the "can't run as root" message anyway.

The fix for this is to remove the block of code (which is quite clearly marked with comment) and delete the line "exists_desktop_file | | generate_desktop_file" (towards the end) from the chrome-wrapper script file in the program folder.

______


I was tinkering with Chromium yesterday, downloaded the program folder package from the website mentioned and it gave me a newer version ( 28.0.1474.0 ) which I have stripped and used to make a .sfs and .pet (posting from it now) but it seems to have been built against a newer glibc ( 2.15 ) so although it is still OK in Precise 5.5 and Slacko 5.5 (with 1 extra lib) it won't work in some other Puppies including Slacko 5.3.3 (Version 27 works if you add 2 libs) and Wheezy (Version 27 works).

_________________
Oscar in England

Back to top
View user's profile Send private message 
HiDeHo

Joined: 16 Mar 2011
Posts: 286

PostPosted: Tue 16 Apr 2013, 22:07    Post subject:  

Terryphi wrote:
HiDeHo,

Have you tried Precise 5.5? The latest Chromium can be made to run on it.


Yes i have and its ok but it does not have xfce setup, or some of the build tools that are in saluki.

I remember that most puppies used to be able to run both .deb and .rpm files by default with compiling etc. well in puppy 4.3.1 it was more like that.

now with the new woof build its hard.
at least firefox can run independent from any os, outside the save file, from a standalone folder in its own directory. i just wish chromium/chrome browser would run like that.
it would solve the dependancy issues.

I wish I had the skills and was able to compile chromium libs etc that are missing in wary/racy etc. then it would be awesome.
is there anyone able to help with this. it would be great to be able to do.

_________________
HiDeHo is an ideas man. loves to come up with ideas that others think are good and can use
if you are a sneeky computer geek check out sneekygeekers click here
Back to top
View user's profile Send private message 
game sfs


Joined: 01 Oct 2012
Posts: 47

PostPosted: Fri 03 May 2013, 14:21    Post subject:  

with flash version 11.7.700.169 ?
http://www.adobe.com/software/flash/about/

_________________

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 4 [58 Posts]   Goto page: Previous 1, 2, 3, 4
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1046s ][ Queries: 12 (0.0061s) ][ GZIP on ]