Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Aug 2014, 07:50
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
alphaOS [closed]
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 25 of 47 [697 Posts]   Goto page: Previous 1, 2, 3, ..., 23, 24, 25, 26, 27, ..., 45, 46, 47 Next
Author Message
mike delaw

Joined: 17 Jan 2013
Posts: 13

PostPosted: Mon 06 May 2013, 06:14    Post subject:  

Bad news: Grub4DOS doesn't work well with the new release. After search only in this device is clicked, it doesn't detect those 4 files for frugal install - only Windows.

God news: LinuxLive USB Creator doesn't recognize AlphaOS, but it installs it without problems.
Back to top
View user's profile Send private message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Mon 06 May 2013, 06:53    Post subject:  

Hi mike

did you put those files inside folder alphaos, because I tried installation that way to usb drive and it works.
Back to top
View user's profile Send private message Visit poster's website 
smil99

Joined: 18 Aug 2007
Posts: 174

PostPosted: Mon 06 May 2013, 17:45    Post subject:  

Quote:
Added packages:
plank-bzr-817-1.spkg
sylpheed-3.3.0-1.spkg .....

Thanks simargl Smile
Cheers.

_________________
Success is never ending. ... Failure is never final!
(Used with kind permission from jejy69)
Back to top
View user's profile Send private message 
mike delaw

Joined: 17 Jan 2013
Posts: 13

PostPosted: Tue 07 May 2013, 03:14    Post subject:  

simargl wrote:
Hi mike

did you put those files inside folder alphaos, because I tried installation that way to usb drive and it works.


I installed alphaos with Lili on USB and booted it. Then I put alphaos file on another USB. Then I opened Grub4DOS, found the second USB and clicked search only in this device. Alphaos is not found ...

Nevermind. I will use Lili to use alphaos.
Back to top
View user's profile Send private message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Wed 08 May 2013, 05:59    Post subject:  

SpaceFM mounting script modified to support notifications using notify-osd program, same as used in Ubuntu. Deadbeef, gnome-mplayer and volumeicon are recompiled to work with libnotify and show notifications like this on song change or volume up/down.
3.jpg
 Description   
 Filesize   8.38 KB
 Viewed   720 Time(s)

3.jpg

2.jpg
 Description   
 Filesize   8.17 KB
 Viewed   722 Time(s)

2.jpg

1.jpg
 Description   
 Filesize   10.57 KB
 Viewed   721 Time(s)

1.jpg

Back to top
View user's profile Send private message Visit poster's website 
smil99

Joined: 18 Aug 2007
Posts: 174

PostPosted: Wed 08 May 2013, 06:19    Post subject:  

Hi simargl,
How does one take advantage of the various improvements/enhancements that you have been making lately? If my memory serves me right, I think I saw an improved ffmpeg and font rendering earlier in this thread and now the above on notifications. Do they automatically appear in spkg?

Cheers.

_________________
Success is never ending. ... Failure is never final!
(Used with kind permission from jejy69)
Back to top
View user's profile Send private message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Wed 08 May 2013, 07:24    Post subject:  

You can check if there is font improvement after reinstalling two packages from this thread http://alphaos.freeforums.org/ubuntu-s-lcd-rendering-patches-t86.html. That and other changes will be in next release, I'm just waiting for spacefm to update on next version which has some new desktop features
Back to top
View user's profile Send private message Visit poster's website 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 790
Location: USA

PostPosted: Wed 08 May 2013, 10:08    Post subject:  

...
37637661.jpg
 Description   
 Filesize   58.71 KB
 Viewed   658 Time(s)

37637661.jpg


_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 160GB WD HDD and 500GB WD HDD, Windows 7
I am looking for a working Atari ST that can be bought for less than $100.
Back to top
View user's profile Send private message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Wed 08 May 2013, 10:51    Post subject:  

simple-radio modified to show song title notification on radio startup. This does not work for all stations because they don't all provide that info. Also simple-radio now uses mplayer as backend not mpg123 as before.
4.jpg
 Description   
 Filesize   9.3 KB
 Viewed   638 Time(s)

4.jpg

Back to top
View user's profile Send private message Visit poster's website 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Thu 09 May 2013, 05:10    Post subject:  

I compiled lm_sensors package (it will be in main iso) and made service file which loads
needed module smsc47b397 for my computer on boot. For others it will be different module,
so you would need to run sensors-detect to find out what is needed module and manually
replace smsc47b397 in /etc/init.d/sensors. sensors-detect is perl script so make sure devel module is loaded...
Output:
Code:
[root@alphaos ~]# sensors
smsc47b397-isa-0480
Adapter: ISA adapter
fan1:        1317 RPM
fan2:           0 RPM
fan3:           0 RPM
fan4:         924 RPM
temp1:        +44.0 C 
temp2:         +0.0 C 
temp3:        +43.0 C 
temp4:         +0.0 C 

[root@alphaos ~]#
Back to top
View user's profile Send private message Visit poster's website 
smil99

Joined: 18 Aug 2007
Posts: 174

PostPosted: Thu 09 May 2013, 09:02    Post subject:  

simargl wrote:
Quote:
You can check if there is font improvement after reinstalling two packages from this thread http://alphaos.freeforums.org/ubuntu-s-lcd-rendering-patches-t86.html. That and other changes will be in next release, I'm just waiting for spacefm to update on next version which has some new desktop features

Thanks for the info. Anxiously awaiting the next release Smile .
Cheers.

_________________
Success is never ending. ... Failure is never final!
(Used with kind permission from jejy69)
Back to top
View user's profile Send private message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Fri 10 May 2013, 04:12    Post subject:  

If someone has any idea about the logo it would be very appreciated, also if you want to contribute good choice is to use svg format from inkscape.

Some minor changes:
* volumeicon recompiled without libnotify, when notifications are enabled it occasionally just freeze, stop responding Sad
* util-linux downgraded to 2.22.2; with version 2.23 sfs unloading is broken - it reports success but module is still loaded, and if I run sfs_load with -d option (debug) it shows something like "cannot disassociate /dev/loop6" Confused
Back to top
View user's profile Send private message Visit poster's website 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sat 11 May 2013, 12:29    Post subject:  

new package upgrade function, how does it work?
After you type spkg upgrade
first is executed function spkg update, to sync local repository data with mirror
then it goes through list of installed packages in /initrd/pup_rw/var/lib/spkg/installed (means only in save file)
if package with that name exists in repository script compares version-revision variables of installed package with that from mirror and if they are different execute command
spkg -r pkgname
spkg -gi pkgname
Back to top
View user's profile Send private message Visit poster's website 
imago

Joined: 08 Apr 2013
Posts: 10
Location: ukraine

PostPosted: Sun 12 May 2013, 12:36    Post subject:  

the system have boot in consol, It had window manager is not set, why so?
Back to top
View user's profile Send private message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sun 12 May 2013, 12:52    Post subject:  

imago wrote:
the system have boot in consol, It had window manager is not set, why so?

Hi imago
that means adrive which has openbox window manager and other programs is not recognized or not present on your usb or hard disk partition. What method did you use for installing, just check that you have both of two main sfs alpha.sfs and extra.sfs on target device.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 25 of 47 [697 Posts]   Goto page: Previous 1, 2, 3, ..., 23, 24, 25, 26, 27, ..., 45, 46, 47 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0929s ][ Queries: 13 (0.0211s) ][ GZIP on ]