Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 06:31
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Seamonkey download manager - open containing Folder (solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Sun 23 Oct 2011, 14:28    Post subject:  Seamonkey download manager - open containing Folder (solved)  

A small nuisance. Probably I am just dumb but:
if I download something and right click the downloaded file in the Download Manager (Ctrl+j) there is an option "Open containing Folder"

This could be handy because I always forget where I download stuff

But it is not working for me: first It said something like: don't know which Program to use and the file selector pops. I choose /usr/bin/rox and now it says

"File doesn't exist or coouldn't open"

I can't even find a setting in Properties where to change that again.

Help anyone?
thanks
emil

Last edited by emil on Sun 23 Oct 2011, 17:49; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Semme

Joined: 07 Aug 2011
Posts: 3969
Location: World_Hub

PostPosted: Sun 23 Oct 2011, 14:39    Post subject:  

How about here? Of course if you're referring to an addon, state which..
Back to top
View user's profile Send private message 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Sun 23 Oct 2011, 15:28    Post subject:  

Hi Semme, thanks for quick answer.
No I don't mean how to specify the download folder, I mean if you start the download manager (Ctrl+j or Tools/Download Manager from menu bar) you have a list of downloaded files.

Then right click on one of these files and you get the option Open Containing folder (this is greyed as long as the download isn't complete). But this option is not working for me (not in lupu 511 and not in the new slacko RC).

I think I miss something obvious Rolling Eyes
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 23 Oct 2011, 15:46    Post subject:  

I remember that Kirk posted something of that kind fix in Fat Dog thread some time ago. You could check if it works with Firefox in that distro. Then you know more.
I remember that there is script called rox-firefox in /usr/local/bin in Fat Dog. It might be related.

Also creating new handlers with about:config could solve the problem.

Try google with appropriate search terms.
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3969
Location: World_Hub

PostPosted: Sun 23 Oct 2011, 15:50    Post subject:  

Yes, I realized a bit late. I'm in agreement with pemasu that a script is what's required.
Back to top
View user's profile Send private message 
trapster


Joined: 28 Nov 2005
Posts: 2009
Location: Maine, USA

PostPosted: Sun 23 Oct 2011, 16:05    Post subject:  

Open geany (or your preferred text editor) and create a file called rox1 with the following:
Code:
#!/bin/sh
exec rox -U "$@"


Save the file in /usr/local/bin

Make it executable

In seamonky:
Edit > Preferences > Browser > Helper Applications:
add rox1 under the "Content Type > file" entry.

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Puppeee4.31 + 1.0, Puppy4.10 + Lupu52
Currently using Slacko AND lupu52 w/ fluxbox
Back to top
View user's profile Send private message Visit poster's website 
Semme

Joined: 07 Aug 2011
Posts: 3969
Location: World_Hub

PostPosted: Sun 23 Oct 2011, 16:39    Post subject:  

Say trapster- what's the $@ for?
Back to top
View user's profile Send private message 
trapster


Joined: 28 Nov 2005
Posts: 2009
Location: Maine, USA

PostPosted: Sun 23 Oct 2011, 17:15    Post subject:  

if [ trapster != google ];
then
google
fi

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Puppeee4.31 + 1.0, Puppy4.10 + Lupu52
Currently using Slacko AND lupu52 w/ fluxbox
Back to top
View user's profile Send private message Visit poster's website 
Semme

Joined: 07 Aug 2011
Posts: 3969
Location: World_Hub

PostPosted: Sun 23 Oct 2011, 17:34    Post subject:  

Yes, brilliant. While I was hoping for a quick once over as to how it was being applied here, I'll persist with your link.
Last edited by Semme on Sun 23 Oct 2011, 17:37; edited 1 time in total
Back to top
View user's profile Send private message 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Sun 23 Oct 2011, 17:35    Post subject: Thanks  

Works like a charm,
thanks trapster!
Back to top
View user's profile Send private message Visit poster's website 
miriam


Joined: 06 Dec 2006
Posts: 281
Location: Queensland, Australia

PostPosted: Mon 27 May 2013, 07:00    Post subject:  

I had a similar problem as Emil, but choosing "Open Containing Folder" in the download manager opened a completely unrelated program (EasyMp3). Weird.

So I did a search on Google, and after a lot of useless pages I found this page:
https://bugzilla.mozilla.org/show_bug.cgi?id=266600
If you scroll down to comment 17 by Ahmad Samir he explains very clearly the problem and how to fix it. Just in case the page disappears in the future I'll quote that item here:
Quote:
Ahmad Samir 2009-01-30 04:52:06 PST

It seems that firefox (and most GTK apps running in kde3 and kde4, such as file-roller and catfish) don't respect kde's file type associations. Instead firefox looks at:
- /usr/share/applications/defaults.list : this is, AFAICT, a static file created when you first install the system

AND

- /usr/share/applications/mimeinfo.cache : this is a dynamically changing file, it's changed when you install a new programme. So for example it will change when you install nautilus or pcmanfm in kde.

Firefox will look first at defaults.list but will give preference to mimeinfo.cache. So if the same entry (e.g. inode/directory) exists in both defaults.list and mimeinfo.cache firefox will take whatever mimeinfo.cache says.

You can manually make "Open containing folder" use your favourite programme by editing /usr/share/applications/mimeinfo.cache . Basically you need to edit the "inode/directory=" entry and put the desired application's .desktop name up front, so to use dolphin, change it to:

inode/directory=kde4-dolphin.desktop;

Notice the extra kde4 in kde4-dolphin.desktop , this is necessary because dolphin.desktop is not in the same folder as mimeinfo.cache; mimeinfo.cache is in /usr/share/applications while dolphin.desktop is in /usr/share/applications/kde4 . If a .desktop file is going to be used and it exists in /usr/share/applications then use its plain name without a prefix.

To use konqueror instead of dolphin it should be:
inode/directory=kde4-kfmclient_dir.desktop;

Be aware though that /usr/share/applications/mimeinfo.cache will be changed automatically when you install a new *relevant* programme/file manager such as nautilus. However you can maintain a local copy that will not be changed when you install anything else, put a copy of defaults.list and mimeinfo.cache in your home folder in ~.local/share/applications.

The problem that existed with dolphin not using the right folder url has vanished in kde 4.2. The problem was that by default the command line in dolphin.desktop was "dolphin %i -caption "%c" %u" and that didn't work in kde 4.1.2 but it works OK with the same command line in KDE 4.2 (I wouldn't take that to the court, though Smile ) I know for sure that it's working OK in kde 4.2 .

My system specs:
KDE 4.2
Firefox 3.0.5

A wild guess is that in gnome there's gnome-settings-manager that makes whatever file associations you change in Gnome get applied when you log into Gnome, but gnome-settings-manager isn't run in KDE.

So, what I did was edited both /usr/share/applications/defaults.list and /usr/share/applications/mimeinfo.cache and finding that neither had an entry for inode, I added the line:
Code:
inode/directory=ROX-Filer-file-manager.desktop;
to each. Immediately those files are saved seamonkey works as it should -- no need to restart, even.

Yay!

_________________
A life! Cool! Where can I download one of those from?
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0749s ][ Queries: 12 (0.0065s) ][ GZIP on ]