Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 17:43
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Precise Puppy 5.6.1-final, May 29, 2013
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 15 of 19 [274 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, 18, 19 Next
Author Message
James C


Joined: 26 Mar 2009
Posts: 5896
Location: Kentucky

PostPosted: Thu 06 Jun 2013, 02:08    Post subject:  

Precise 5.6 live on an old P3 .......naturally too large to load into ram on a 256 mb box.
SeaMonkey would not launch....

Code:
# seamonkey
Bus error
#


Same cd with confirmed md5 and verified burn.

Copied all below info to a text file.....posting this from Wary 5.5.....running pfix=ram.


-Computer-
Processor : Pentium III (Coppermine)
Memory : 253MB (79MB used)
Machine Type : Physical machine
Operating System : Precise Puppy - 5.6
User Name : root (root)
Date/Time : Thu 06 Jun 2013 12:55:04 AM CDT
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Gallium 0.4 on softpipe
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : ICH - Intel 82801AA-ICH

-Version-
Kernel : Linux 3.2.44 (i686)
Version : #1 SMP Sun May 5 11:42:44 GMT-8 2013
C Library : GNU C Library version 2.15 (stable)
Distribution : Precise Puppy - 5.6


# report-video
VIDEO REPORT: Precise Puppy, version 5.6

Chip description:
Host bridge: Intel Corporation 82810E DC-133 (GMCH) Graphics Memory Controller Hub (rev 03)
VGA compatible controller: Intel Corporation 82810E DC-133 (CGC) Chipset Graphics Controller (rev 03)

Requested by /etc/X11/xorg.conf:
Resolution (widthxheight, in pixels): 1024x768
Depth (bits, or planes): 24
Modules requested to be loaded: dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
Driver loaded (and currently in use): intel
Loaded modules: dbe ddc dri dri2 extmod fb glx int10 kbd mouse ramdac record vbe vgahw xaa

Actual rendering on monitor:
Resolution: 1024x768 pixels (321x241 millimeters)
Depth: 24 planes

...the above also recorded in /tmp/report-video
#
Back to top
View user's profile Send private message 
dennis-slacko531


Joined: 18 Jan 2012
Posts: 103
Location: Oregon

PostPosted: Thu 06 Jun 2013, 02:10    Post subject: Precise 5.6.1 savefile shrinking --wtf?
Subject description: solved -- can you confirm Aqualung is problem?
 

This is very strange behavior, but apparently something is being downloaded continually. My savefile is 3GB and over the course of the day it's now down to 1.3GB remaining. Has anyone experienced this? It happened yesterday and the indicator turned red. I was about to reboot it (--to increase the size) but it suddenly cleared itself and was back at 3GB. Well, it's happening again now.

I'm using Firefox 21.0 (up to date). I know there's some debate about savefile sizes, but this falls into the weird category IMO.

BTW, my site mirrors Precise & PHATSlacko (you're welcome) Smile
www.beok.com/lnux

* * EDIT : After a four hour cat nap the savefile shrunk by an extra 300MB. My modem indicates activity but I can't see any specific file getting bigger... Mad

*** EDIT : 15 hours later and I'm on RED with 407MB remaining. Losing about 100MB per hour. The Firefox green arrow shows only correct/recent activity.

* * PARTIALLY SOLVED : It somehow restored itself. Now it shows 2.4GB of 3GB. I'll close Firefox for awhile.

*** SOLVED : Aqualung R-1261 ---- Can someone confirm this is a bad program? As soon as it runs, you'll notice it starts some crazy downloading forever.

Last edited by dennis-slacko531 on Thu 06 Jun 2013, 23:11; edited 6 times in total
Back to top
View user's profile Send private message Visit poster's website 
Sylvander

Joined: 15 Dec 2008
Posts: 3478
Location: West Lothian, Scotland, UK

PostPosted: Thu 06 Jun 2013, 02:26    Post subject:  

@npierce
1. "So your hardware clock (a.k.a. "rtc", "real time clock") is set to UTC. That's fine, and I'll assume that is how you want it."
Actually, I don't want it set to UTC, and I believe I set it to "localtime".

2. "check the box labeled Hardware clock set to UTC, then click OK"
The UTC box is NOT checked, which is just as I want it to be.

3. "2. Psync isn't automatically correcting it soon after booting."
True.

4. "A report on the output of the following two commands would be helpful to see why Psync isn't automatically setting the time soon after booting:"
Code:
# ls -l /root/Startup/timesync.sh
-rwxr-xr-x 1 root root 587 Jun  5 21:05 /root/Startup/timesync.sh
# iwconfig 2> /dev/null | grep IEEE
#


5. "Did you happen to notice if Precise 5.6 or other Puppies gave the wrong time for a few (perhaps 15) seconds after booting, before Psync automatically corrected it?"
At this boot, Psync has NOT auto-sync-ed at all.
I have seen it auto-sync at previous boots, so I'll check that and report back.
-------------------------------
Edit:
OK, I Psync'd, clicked autostart", clicked "Save" on the desktop, and rebooted...
And the time was successfully Psync'd once the Puppy got to the desktop. Very Happy
-------------------------------

6. "did you not run Psync "autostart" on previous Puppies?"
Correct, on previous Puppies I normally didn't use "autostart", but was forced to begin using it on this Puppy.
Back to top
View user's profile Send private message 
npierce

Joined: 28 Dec 2009
Posts: 858

PostPosted: Thu 06 Jun 2013, 10:16    Post subject:  

Sylvander wrote:
Actually, I don't want it set to UTC . . .

OK, in that case this command should correct your hardware clock, so that the time will be right after booting without the need to run Psync. This sets the hardware clock to match the system clock, so be sure that you have already corrected the time on your system clock before running it.
Code:
hwclock -w --localtime

And I think I see what caused Puppy to set the hardware clock incorrectly. But I'll need a little more time to write-up a fix to prevent that, so I thought I'd post this now so you can get your Puppy back on time sooner rather than later.

I am hoping that the above command will fix the clock and survive a reboot, so that the time is correct even before Psync fixes it. Please let me know if that is not the case.


As for Psync "autostart" working sometimes and not others, I am not sure why that happens. Is your PC connected to the network with a physical cable, or are you using wireless?
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3478
Location: West Lothian, Scotland, UK

PostPosted: Thu 06 Jun 2013, 11:02    Post subject:  

@npierce
1. "be sure that you have already corrected the time on your system clock before running it"
Oops! DID use Psync to correct the system clock, but didn't then click "Save" prior to using your command.
Is that OK? Or not?
Is "Save" of failure to save significant in this situation?

2. "I am hoping that the above command will fix the clock and survive a reboot, so that the time is correct even before Psync fixes it. Please let me know if that is not the case."
I'll reboot and report back on the outcome ASAP.
---------------------------
Edit:
On reboot...
Not easy to tell, but...
My system clock displays seconds, and I was watching those carefully...
And I saw the seconds jump by 2 [a 2-second jump forward].
Hence the clock was 2-seconds behind, even though it had been Psync'd right before the reboot.
----------------------------

3. " Is your PC connected to the network with a physical cable, or are you using wireless?"
Connected by cable to the router, which is right beside the keyboard+mouse+screen+PC.
Back to top
View user's profile Send private message 
npierce

Joined: 28 Dec 2009
Posts: 858

PostPosted: Thu 06 Jun 2013, 14:28    Post subject: Re: Time settings not saved  

Sylvander wrote:
Oops! DID use Psync to correct the system clock, but didn't then click "Save" prior to using your command.
Is that OK? Or not?

That's OK. Either way is fine. The important thing is that your system clock was correct when you executed the command.


Sylvander wrote:
Hence the clock was 2-seconds behind, even though it had been Psync'd right before the reboot.

Well, we have made good progress then. Smile Being two seconds behind instead of an hour behind is improvement by a factor of 1800. Smile

Actually, the two second jump could just be a matter of the clock display update being delayed slightly because the processor was momentarily busy doing something of a higher priority. See how it does over the course of a day.


Sylvander wrote:
Connected by cable to the router . . .

Possibly the network connection isn't always fully up before the Psync "autostart" script tries to contact a time server. That would explain why it sometimes works, and sometimes doesn't. For PCs that use wireless, that script has a 15-second delay before it tries to use the network (because wireless connections generally take longer to come up than cabled connections). Perhaps a small delay is needed for cabled connections as well.

If Psync continues to give you trouble, I'd say file a new bug report for Psync, since I don't think that problem would be specific to Precise.
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3478
Location: West Lothian, Scotland, UK

PostPosted: Thu 06 Jun 2013, 15:06    Post subject:  

@npierce
1. "Actually, the two second jump could just be a matter of the clock display update being delayed slightly"
Yes, it occurred to me as I was reporting to you, that:
Perhaps Psync was taking a second or so to do the necessary, so that instead of the regular moving forward 1-second at a time, the time remained frozen at its second setting, then jumped forward 2-seconds instead of 1.
Back to top
View user's profile Send private message 
rameshiyer

Joined: 17 Sep 2009
Posts: 232
Location: Calicut, Kerala, India

PostPosted: Fri 07 Jun 2013, 04:14    Post subject: Time
Subject description: Internet time Synchronization
 

Psync time Server isn't automatically correcting it soon after booting. No auto start even if the same enabled.
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Fri 07 Jun 2013, 05:33    Post subject:  

Most likely it is me being too nooby.
I did not like the pmusic I use mplayer in Lupu
so wanted to use it in Precise too. Thought it where included
should have looked first so I wrote mplayer in start with
and it do start something not sure what but show no gui
so can not shut it down.

Most likely one need to use PPM to install mplayer first?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3478
Location: West Lothian, Scotland, UK

PostPosted: Fri 07 Jun 2013, 06:19    Post subject:  

"Menu->Multimedia->GNOME-Mplayer" is natively included in my "Precise-5.6.1", and runs the GUI OK. Very Happy

Haven't yet tried playing anything with it.
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Fri 07 Jun 2013, 08:11    Post subject:  

Thanks Sylvander, I updatet 5.6.1
but one need to write gnome-mplayer in set run action
in Lupu it is only mplayer so I had no clue Smile
Thanks for caring about me.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sun 09 Jun 2013, 15:10    Post subject:  

5.6.1 menu>system>boot manager configure bootup> choose SFS file, and nothing happens. Surprised this has not been mentioned.
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Brown Mouse


Joined: 09 Jun 2009
Posts: 449
Location: Tenerife Canary Islands

PostPosted: Sun 09 Jun 2013, 17:46    Post subject:  

DaveS wrote:
5.6.1 menu>system>boot manager configure bootup> choose SFS file, and nothing happens. Surprised this has not been mentioned.


All seems to work as it should here.
Back to top
View user's profile Send private message 
ckl8r

Joined: 02 Jun 2012
Posts: 6

PostPosted: Sun 09 Jun 2013, 18:42    Post subject:
Subject description: 5.6.1 ppm not downloading
 

bark_bark_bark wrote:
just like 5.6, 5.6.1's ppm refuses to update the ubuntu repos.

the connection stops here:


That has happened to me before.
The way I got it to work was to use your browser to navigate to the parent web page that wget is trying to download from. Do this before you try to update. I don't know why it works. I may have a strange setup. (had to do this for Precise55 and previuos).

Hope it works for you.
Back to top
View user's profile Send private message 
npierce

Joined: 28 Dec 2009
Posts: 858

PostPosted: Tue 11 Jun 2013, 12:35    Post subject: Recent versions of hwclock are incompatible with Psync 2.8  

npierce wrote:
And I think I see what caused Puppy to set the hardware clock incorrectly. But I'll need a little more time to write-up a fix to prevent that . . .

OK, I'm back on this.

The problem was caused by a change in the hwclock utility.

That utility (a part of the util-linux package), when passed either the -w or --systohc option, reads the system clock and writes it to the hardware clock (a.k.a. RTC). You can choose to have it set the hardware clock to local time or to UTC by using the --localtime or --utc options, and the utility will convert the system time accordingly, if necessary, before writing it to the hardware clock.

When hwclock sets the hardware clock, it also writes some data to the /etc/adjtime file, which includes the string "LOCAL" or "UTC" to indicate which time that clock is being set to. If the utility is run with either the -w or --systohc option, but no --localtime or --utc option, it looks at its adjtime file to see what was last used, and uses that again.

But if the adjtime file does not exist, such as when a new distro has just been installed, the utility can't look at the file so uses a default value that is hard-coded in the utility. Previously that default was local time. But since util-linux v2.20 (released 2011-Aug-29), the default is UTC.

The following two excerpts from a bash session will demonstrate.

First on an older Puppy from 2011, which has an older hwclock utility:
Code:
# grep -E "DISTRO_NAME|DISTRO_VERSION" /etc/DISTRO_SPECS
DISTRO_NAME='Racy Puppy'
DISTRO_VERSION=5.2.2
# cat /etc/adjtime
cat: /etc/adjtime: No such file or directory
# hwclock --version
hwclock from util-linux-ng 2.18
# hwclock -w
# cat /etc/adjtime
0.000000 1370595842 0.000000
1370595842
LOCAL
#


And now on a recent Puppy from May 2013, which has a newer hwclock utility:
Code:
# grep -E "DISTRO_NAME|DISTRO_VERSION" /etc/DISTRO_SPECS
DISTRO_NAME='Precise Puppy'
DISTRO_VERSION=5.6
# cat /etc/adjtime
cat: /etc/adjtime: No such file or directory
# hwclock --version
hwclock from util-linux 2.21.2
# hwclock -w
# cat /etc/adjtime
0.000000 1370616415 0.000000
1370616415
UTC
#


When tasmod wrote Psync Time Server Synchroniser, the default was local time.

Psync uses hwclock to set the hardware clock to either local time or UTC, depending upon whether or not the box for "Hardware clock set to UTC" was checked at first boot, or whenever quicksetup, quickcountry, countrywizard, or timezone-set was last run. When setting it to UTC, Psync passes the --utc option to hwclock. But when setting it to local time, Psync doesn't pass an option, allowing hwclock to use the default, which had always been local time, if there was no /etc/adjtime file.

The end result is that after installing a Puppy with the new version of hwclock, if the user runs Psync before any other utility that sets the hardware clock (like set-time-for-puppy, set_hwclock_type, or the hwclock utility itself), the hardware clock will always be set to UTC, even if that wasn't the user's choice. And once set to UTC, subsequent runs of Psync will also set it to UTC because it will now default to the value that hwclock stored in the adjtime file, "UTC".

Since this problem only happens when there is no adjtime file, running any utility that properly creates the adjtime file (like set-time-for-puppy, set_hwclock_type, or the hwclock utility itself) before running Psync, will eliminate the problem. There is only a problem when that file doesn't yet exist.

Of course, that also means that if a user boots a live CD or fugal installation with "pfix=ram", preventing the save file from being used, running Psync would then cause this problem, since there would be no adjtime file. But if the user didn't then create a new save file, the good adjtime file would still be in the old save file (if the hwclock was ever set with this Puppy), and available at next boot, at which time the user could run Psync again to correct the hardware clock.


Anyway, I have discussed this with Rob (tasmod), who has his hands full with other things at the moment, and has kindly agreed to let me poke around in his code.

Attached is a .pet that I hope will make Psync compatible with both the old and new versions of hwclock. I have bumped the version from 2.8 to 2.9.

Reference:
The commit for the change to hwclock:hwclock: make RTC default to UTC time

(Amusingly, the person who made the change to hwclock had this to say about it:
Quote:
The user impact of this change should be minimal, as anyone who has run "hwclock --systohc" before will have their UTC/LOCAL choice already recorded in /etc/adjtime.

That is true, assuming that the the user never installs new distros. Smile )
psync-2.9.pet
Description  Added support for hwclock >= 2.20
pet

 Download 
Filename  psync-2.9.pet 
Filesize  6.25 KB 
Downloaded  180 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 15 of 19 [274 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, 18, 19 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1215s ][ Queries: 13 (0.0093s) ][ GZIP on ]