Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 01 Aug 2014, 18:35
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking
networking with lenovo X230i & puppy lucid 528 [HALF SOLVED]
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
alaindu22

Joined: 29 Jul 2009
Posts: 145

PostPosted: Tue 11 Jun 2013, 09:45    Post subject:  networking with lenovo X230i & puppy lucid 528 [HALF SOLVED]  

Hello
I don't see eth0 and wlan 0 on this computer ... lenovo x230i

Only l0

With windows7 I see intel (R)82579LM for eth0
and intel ( r ) centrino (r ) advanced -N 6205 for wlan0

What have I to do for detecting the interfaces with puppy ?

whan I put a usb wifi dongle I see its and I can connect with its but after a few seconds I lose the connexion and it is not possible to see the interface after ...
Why ?

Thanks for your help .
Alain

Last edited by alaindu22 on Mon 24 Jun 2013, 03:15; edited 2 times in total
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 3399
Location: Sydney Australia

PostPosted: Sat 22 Jun 2013, 03:36    Post subject:  

Specs: 3 models

http://shop.lenovo.com/us/en/laptops/thinkpad/x-series/x230/

Integrated WiFi Wireless LAN Adapters

ThinkPad 1x1 b/g/n

Intel Centrino Advanced-N 6205 AGN

:::::::::::

" The short answer is that the Intel Centrino Advanced-N 6205 AGN

does work "out of the box" under Linux,

at least with Ubuntu 12.04 LTS where it was tested.

After installing the PCI-E x1 WiFi card and attaching the antenna,

Ubuntu 12.04 LTS with the Linux 3.2 kernel was booted.

To some surprise, everything worked just fine, including WPA/WEP!

There was not any dealing with out-of-tree wireless driver, no ndiswrapper, no fiddling with firmware, or any other headaches. It just worked!"

http://www.phoronix.com/scan.php?page=article&item=intel_6205_wlan&num=1

""""

So you need a later Puppy version...>>> Networks

""""""""""
15 November 2011

http://fosiao.com/node/18

" Intel 82579LM Linux Driver under Ubuntu Lucid "

The driver code is not in Linux kernel yet.

Instructions for our gurus there though.

:::::::

http://askubuntu.com/questions/151324/how-do-i-install-intel-ethernet-drivers

Says it works Ootb.

And again

" Intel Centrino Advanced-N 6205

This is a Mini-PCI Express WiFi Adapter, supported by the iwlagn driver
Linux support

This card is supported out of the box on kernel 2.6.37 and newer. "

http://www.thinkwiki.org/wiki/Intel_Centrino_Advanced-N_6205

::::::::

Chris.
Back to top
View user's profile Send private message 
alaindu22

Joined: 29 Jul 2009
Posts: 145

PostPosted: Mon 24 Jun 2013, 03:13    Post subject:  

Quote:
So you need a later Puppy version...>>> Networks


Thanks

So I have tried with Puppy precise and it's ok

I write half solved for this post because this answer is only an alternative but it is not a good new for pupplet like french asri300 which is based on lucid.

Alain
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Sun 24 Nov 2013, 03:09    Post subject:  

alaindu22 wrote:
With windows7 I see ...
Intel (R) Centrino (R) Advanced-N 6205 for wlan0

The kernel in Puppy Lucid (and presumably also its derivatives) is too old to support the Intel 6205 wifi chipset.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 835
Location: lincoln

PostPosted: Sun 24 Nov 2013, 05:47    Post subject:  

maybe try rerwin's updated lupu

http://archive.org/details/Puppy_Linux_Lupu_5.2.8.6

Smile
Back to top
View user's profile Send private message Visit poster's website 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Sun 24 Nov 2013, 06:15    Post subject:  

No no no .. sigh.
Rerwin's updated Lucid variants still have the same 2.6.33.2 kernel.

The only Puppy Lucid 5.2.x derivative with a more modern kernel is 5.2.9 "Three Headed Dog" ...
but I think some people here are missing the point - the original poster is wanting to get their Intel 6205 wifi device working under the "Asri 300" French derivative based on Lucid 5.2.8.
Any driver which might work with a different kernel is (obviously) non-applicable to Asri 300.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 835
Location: lincoln

PostPosted: Sun 24 Nov 2013, 06:26    Post subject:  

sorry.......my bad.......

Smile
Back to top
View user's profile Send private message Visit poster's website 
jrb


Joined: 11 Dec 2007
Posts: 1030
Location: Smithers, BC, Canada

PostPosted: Sun 24 Nov 2013, 20:48    Post subject:  

You should download Three-Headed Dog 5.2.8.005 Updated APR 25 2012 and boot with it to make sure it finds your networking adapters. If it does and you post a download link for ASRI300 I will be happy to switch kernels for you. Or you can do it yourself as outlined here How to switch kernels between Puppy versions . It has kernel 2.6.37.6 which sounds like it should work.

Cheers, J
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Mon 25 Nov 2013, 09:56    Post subject:  

jrb wrote:
You should download Three-Headed Dog 5.2.8.005 ...
... I will be happy to switch kernels for you.

Yep, that will work ... but once you make the effort to do a kernel transplant, it's feasible to go all the way -
why not the 3.10.5 kernel from Slacko-5.6?

But if alaindu22 (who has been oddly silent through all of this) chooses to try Three-Headed Dog, there's still the issue of compatible firmware - the Intel 6205 requires firmware: iwlwifi-6000g2a-5.ucode
I just booted to my Three-Headed Dog CD now, and I can confirm that its version of the Intel iwlagn driver definitely supports this firmware, as confirmed by the output of -
Code:
modinfo iwlagn

... and guess what, Three-Headed Dog is missing this firmware!
Get it here -
http://wireless.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=iwlwifi-6000g2a-ucode-17.168.5.3.tgz
Once uncompressed, it needs to be located in /lib/firmware
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Mon 25 Nov 2013, 10:32    Post subject:  

Edit: DEC 01 2013
The original poster is long gone.
Dotpet attachment removed.

Last edited by tempestuous on Sat 30 Nov 2013, 23:27; edited 1 time in total
Back to top
View user's profile Send private message 
jrb


Joined: 11 Dec 2007
Posts: 1030
Location: Smithers, BC, Canada

PostPosted: Mon 25 Nov 2013, 13:26    Post subject:  

tempestuous wrote:
why not the 3.10.5 kernel from Slacko-5.6?

As I recall there were problems in lupu528 upgrading to kernel3xxx. Seems some of the scripts wouldn't work. Didn't try it myself but others did.
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 2930
Location: Mer méditerrannée (1 kms°)

PostPosted: Sat 19 Apr 2014, 04:08    Post subject: kernel 3.0.25 is perfect for all Puppy Lucid  

kernel 3.0.25 is perfect for all Puppy Lucid (iwlagn as wifi driver).
... for my Medion P7624.
PupKview.jpg
 Description   
 Filesize   46.98 KB
 Viewed   105 Time(s)

PupKview.jpg


_________________
Puppy, il ne lui manque que la parole !
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0775s ][ Queries: 13 (0.0097s) ][ GZIP on ]