Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 13:27
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Is there a Gambas 3.x .pet or sfs?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
der-schutzhund

Joined: 26 Nov 2007
Posts: 786
Location: Blomberg / Germany

PostPosted: Sun 12 May 2013, 05:03    Post_subject:  Is there a Gambas 3.x .pet or sfs?  

Where is a current Gambas.pet or sfs?
Or maybe someone can create a pet or sfs?

greetings

Wolfgang
Back to top
View user's profile Send_private_message 
HoerMirAuf


Joined: 22 Jan 2008
Posts: 89
Location: Würzburg

PostPosted: Sun 16 Jun 2013, 05:48    Post_subject:  

Here it is:

Ported from ubuntu ... works on slacko. Required libs are incuded.
(haven't tested all functions but all should work)

Quote:
https://www.box.com/s/m2e3e03q2h7awjvfo1hh
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 786
Location: Blomberg / Germany

PostPosted: Sun 16 Jun 2013, 06:37    Post_subject:  

Hi,

error: "gbr3: /lib/libc.so.6: version 'GLIBC_2.15' not found"
Were can i get this lib?

Arbeite mit Lucid 5.28 -> Lazy und da fehlt wohl GLIBC_2.15
Wo gibt es das Teil?

Wolfgang
Back to top
View user's profile Send_private_message 
HoerMirAuf


Joined: 22 Jan 2008
Posts: 89
Location: Würzburg

PostPosted: Sun 16 Jun 2013, 07:15    Post_subject:  

Hmmm lucid works with another libc version. I think that isn't compatible. Im not so experienced but i guess you can' t change the libc to another version without stall your puppy.

Will to try to make a package working in lucid!
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 786
Location: Blomberg / Germany

PostPosted: Fri 21 Jun 2013, 15:10    Post_subject:  

HoerMirAuf wrote:
Hmmm lucid works with another libc version. I think that isn't compatible. Im not so experienced but i guess you can' t change the libc to another version without stall your puppy.

Will to try to make a package working in lucid!


Hattest du schon Erfolg? Bin immer noch sehr stark an einem Gambas 3.x interessiert. Von der gesamten Oberfläche und der Philisophie komme ich damit am besten zureckt.
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1962
Location: wales

PostPosted: Sat 06 Jul 2013, 09:31    Post_subject:  

hi der-schutzhund,

i decided to have a go at making a gambas 3.4.1 sfs for lucid puppy. It was quite a challenge!! Smile so many dependencies!

the only thing that i couldn't get to compile was the jit (just in time) compiler support

everything else seems to work pretty much, although i can't guarantee that.
and you'll need to install your graphic drivers for the opengl stuff

download here... for lucid puppy only
http://www.wuala.com/666philb/Documents/gambas-3.4.1_lucid.sfs/ 105mb
MD5 2bc9fd406225b5f00ef485f8501743b1

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 786
Location: Blomberg / Germany

PostPosted: Sat 06 Jul 2013, 16:44    Post_subject:  

Hi 666philb,
Thank you for your great work! Very Happy
I had not expected that someone created an actual Gambas.sfs!
Then you must be a real specialist in terms of compile!
Meanwhile, I am busy with PureBasic and i also created a purebasic.sfs.
The Puppy community now has three great programming Lazarus, Gambas and PureBasic!
I have tested your Gambas.sfs and it works! Very Happy
Thanks a lot!

regards

Wolfgang
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4465
Location: Gatineau (Qc), Canada

PostPosted: Wed 26 Nov 2014, 22:59    Post_subject:  

@666philb:

Would it be long and complicated for you to compile gambas version 3.6.2 ?
Or explain how you did it ? (I have the source.)

I am asking because Laurux3, http://www.laurux.fr/, a new French software for
business management, is just out, and it insists on running on gambas 3.6.2.

Laurux3 Is made for Linux and has a GPL licence, so it could be very interesting to get
it to work, to promote Puppy as a serious alternative system for free lancers and small
business people.

Thanks in advance for even a negative reply.

Best regards.

musher0

~~~~~~~~~~~
P.S. Here are some screenshots from Laurux3:


musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
musher0


Joined: 04 Jan 2009
Posts: 4465
Location: Gatineau (Qc), Canada

PostPosted: Thu 27 Nov 2014, 21:47    Post_subject:  

@666philb :

Please disregard my previous request. Inspired by a note from fellow
member augras, I managed to put together a runtime of gambas-3.6.2
from the binaries for ubuntu 12.04 provided by the gambas-team.

Please see here :
http://murga-linux.com/puppy/viewtopic.php?p=811223&sort=lastpost#811223

There is still some fine-tuning to do, but I think mostly to the Laurux3
business application (its mysql access and stuff) rather than to the
version of gambas per se.

Please accept my apologies if you spent any time on a compile of this
gambas version. However, if you or other readers of this thread have the
time, a try-out with some other gambas apps would be much appreciated.

Best regards.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
666philb


Joined: 07 Feb 2010
Posts: 1962
Location: wales

PostPosted: Fri 28 Nov 2014, 18:14    Post_subject:  

i put one together anyway Smile
http://ftp.nluug.nl/ibiblio/distributions/puppylinux/pet_packages-tahr/gambas3-3.6.2_tahr.sfs

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
augras

Joined: 11 Nov 2013
Posts: 695
Location: france

PostPosted: Sat 29 Nov 2014, 10:24    Post_subject:  

Hi,
Thanks a lot 666philb, gambas works fine.
Philippe
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4465
Location: Gatineau (Qc), Canada

PostPosted: Sat 29 Nov 2014, 13:09    Post_subject:  

666philb wrote:
i put one together anyway Smile
http://ftp.nluug.nl/ibiblio/distributions/puppylinux/pet_packages-tahr/gambas3-3.6.2_tahr.sfs


Many thanks!

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0644s ][ Queries: 12 (0.0040s) ][ GZIP on ]