Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 27 Aug 2014, 19:18
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Can't get fofix working in Puppy Precise 5.5
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
davec60

Joined: 14 Sep 2012
Posts: 22

PostPosted: Tue 18 Jun 2013, 02:47    Post subject:  Can't get fofix working in Puppy Precise 5.5  

Hi,
I have recently downloaded and installed 'Fofix' into Linux Puppy Precise 5.5. The installation appeared to be successful with 'no missing libraries' and 'no missing dependencies' reported by the Package Manager. However, when I click on the 'Fofix' menu item nothing happens. When I run /usr/games/fofix in the terminal it produces the following output:
# /usr/games/fofix
Traceback (most recent call last):
File "FoFiX.py", line 108, in <module>
from GameEngine import GameEngine
File "/usr/share/fofix/src/GameEngine.py", line 32, in <module>
from numpy import array, float32
File "/usr/lib/python2.7/dist-packages/numpy/__init__.py", line 137, in <module>
import add_newdocs
File "/usr/lib/python2.7/dist-packages/numpy/add_newdocs.py", line 9, in <module>
from numpy.lib import add_newdoc
File "/usr/lib/python2.7/dist-packages/numpy/lib/__init__.py", line 13, in <module>
from polynomial import *
File "/usr/lib/python2.7/dist-packages/numpy/lib/polynomial.py", line 11, in <module>
import numpy.core.numeric as NX
AttributeError: 'module' object has no attribute 'core'

Clearly, it seems to be something to do with a 'module object having no attribute core' but I don't really understand what this means. If anyone is able to recognise from the terminal output what the problem actually is and can translate in simple terms what I need to do now in order to fix it, it would be good to hear from you. Thanks
dave
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1660
Location: wales

PostPosted: Tue 18 Jun 2013, 11:41    Post subject:  

hi davec60,

apparently it's caused by 'numpy' not creating some symlinks on install

navigate to the folder /usr/lib/libblas and copy both 'libblas.so.3gf' & 'libblas.so.3gf.0' to /usr/lib

do the same for /usr/lib/liblapack, copy both the files in that folder to /usr/lib

fofix should now work Smile

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0399s ][ Queries: 12 (0.0036s) ][ GZIP on ]