Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 21 Apr 2014, 10:57
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
Puppy strange behaviour with latin1 keyboard (SOLVED)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
vito49


Joined: 18 Jun 2013
Posts: 5

PostPosted: Tue 18 Jun 2013, 03:42    Post subject:  Puppy strange behaviour with latin1 keyboard (SOLVED)
Subject description: wrong characters are shown
 

Hello all,

Sorry if I'm using the wrong place to ask this question and please be aware I'm completely new to Puppy Linux, not to Linux, I use it for many years ... But i now tested PL on my desktop PC (that is running LMDE normally) and it works great on it, in fact I'm composing this post with Puppy Linux, but when I try to use PL on my wife's laptop the keyboard goes crazy.

Half of the keyboard can't be used and I just found out that all keys with a "blue" character on it (normally to be used with the Fn key) are set, NOT the normal character. As an example, when I type shift + O to get a "zero" it doesn't shows a zero but an asterisk "*", the character that is located on the same key, but in blue. ALL keys with a blue character on it behave the same way .... Installing the "azerty" option in PL doesn't solve the problem.
The keyboard is not broken, there is windows Xp on it for now and the keyboard works the way it has to do with Windows.

Sorry if this is confusing or not good explained, I'm not English ... Embarassed

Acer Aspire 3100 with Azerty keyboard
be-latin1 keyboard (set in PL) = Azerty
Puppy Linux Precise 5.6.1

Again, on my desktop everything goes well, no problems with the usb-keybord.

It would be great to solve this problem because one of the coming days my wife is going to buy a new laptop (sorry, with Windows 8, she followed computer lessons and in that class they never heard about Linux) and I'm going to claim her old Acer for Linux. With Puppy, of course.

Many thanks for any suggestions how to solve this and to get a normal Azerty latin 1 keyboard on the Acer.

Greetings from Aarschot in Belgium/Europe

Vito49

Last edited by vito49 on Tue 18 Jun 2013, 14:51; edited 1 time in total
Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 915

PostPosted: Tue 18 Jun 2013, 08:34    Post subject:  

Hi vito49 and welcome here!

I live in Belgium too and never had this keyboard problem.
Be-latin1 has always worked directly and faultless.

Are you sure it is a standard azerty keyboard? I'm asking because there shouldn't be an asterisk on the '0' key. Under the '0' there should be 'à' and '}'

Maybe you can try the input wizard: (menu>setup>mouse/ keyboard wizard>Advanced Xorg Keyboard Configuration and choose "keyboard variants".
Hopefully one of those will get your keyboard going.

If not, I think this is a good article on azerty and Belgian azerty.

Good luck!

_________________


Back to top
View user's profile Send private message 
vito49


Joined: 18 Jun 2013
Posts: 5

PostPosted: Tue 18 Jun 2013, 11:18    Post subject:  

Bert wrote:
Hi vito49 and welcome here!

I live in Belgium too and never had this keyboard problem.
Be-latin1 has always worked directly and faultless.

Are you sure it is a standard azerty keyboard? I'm asking because there shouldn't be an asterisk on the '0' key. Under the '0' there should be 'à' and '}'



Hello Bert, it works with my desktop azerty keyboard, without any problems. But not with the laptop.
The laptop (Acer) has an azerty keyboard but there are many keys on it containing other characters than my "normal" azerty desktop keyboard. Don't get me wrong, on the 0 key there are "à" and "}" but also "*", but this one has a blue colour and is in the upper right corner of the key. Whatever I do, hitting the 0 key produces an asterisk. All keys containing these blue characters (almost half of the keyboard) produce these blue characters ans no other ....

Another weird thing is that the laptop works as a normal azerty keyboard under Windows XP ....

I shall try it the way you suggested later this evening and let you know.

Vito49
Back to top
View user's profile Send private message 
vito49


Joined: 18 Jun 2013
Posts: 5

PostPosted: Tue 18 Jun 2013, 14:50    Post subject:  

Hello, my problem is solved.

Let me try to explain Very Happy

I did my first-run setup on my desktop PC, everything was OK, but I also set the numlock because my desktop keyboard has a numeric keypad.
Now, when I use the same settings on the laptop (saved on an USB stick),which is normal for a system like Puppy, the numlock is set too, but ... the laptop doesn't have a numeric keypad. It does has a key to toggle between numlock on and numlock off, and that is done with "Fn + F11", Fn being the special key for special characters, On key F11 there is a very small "numlock" sign.
This is very confusing because toggling the numlock doesn't do anything to numbers but it toggles the Fn key. With other words, from the moment Puppy is loaded ALL keys containing an additional character (in blue) are ready to react as if the Fn key was pressed too.
If you ask me, it would have been more normal if F11 didn't contain the text "numlock" but "FnLock" ...

I now only have to switch numlock off when I'm using the laptop and everything is Okay. Between us, it took me several hours to find out, I'm not that proud of myself Embarassed

Sorry for my bad English ....

Vito49
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 3804
Location: Gatineau (Qc), Canada

PostPosted: Tue 18 Jun 2013, 15:24    Post subject:  

Hello.

I was going to tell you that solution but you found out by yourself!

And don't feel too "un-proud": the solution is not well advertised, so I too also had to spend many hours researching it, when I accepted to repair a friend's portable with cf keyboard.

But you had the intelligence of sharing the solution! Smile

Bye for now!

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
Bert


Joined: 30 Jun 2006
Posts: 915

PostPosted: Tue 18 Jun 2013, 15:40    Post subject:  

vito49 wrote:
.

I now only have to switch numlock off when I'm using the laptop and everything is Okay. Between us, it took me several hours to find out, I'm not that proud of myself Embarassed

Vito49


Hello vito49,

Glad it is solved Cool
It would probably have taken several days for me to see the solution to this unusual problem...

Have fun!

_________________


Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0521s ][ Queries: 12 (0.0036s) ][ GZIP on ]