Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 01:51
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Internet problems at dhcpcd with lupu 5.2.8 [Solved]
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
sholum

Joined: 21 Nov 2011
Posts: 2

PostPosted: Mon 21 Nov 2011, 13:36    Post_subject:  Internet problems at dhcpcd with lupu 5.2.8 [Solved]  

I am using lupu 5.2.8 which uses the new Simple Network Setup (sns) by default and, as far as I can tell, has no option to use the older network setup, I don't remember its name, but it was still available on 5.2 as an option.

Anyway, whenever I try to connect to the internet on sns I get:
"DHCP client failed to negotiate with wireless network '(my wireless network)'"

On the old one I got something along the lines of:
"Failed to connect to a wireless network" or maybe "You are not connected to a wireless network"

The difference between the two is that on the old one I just had to click the 'Auto DHCP' button and it would work. On sns I can't do anything after it runs its automatic connection.

Notes and answering important questions before hand:
Yes, I am connecting to the right network. Yes, I am entering the correct security key. Yes, both my wireless antenna and my router are on. And yes, both are broadcasting.
(Possibly important) I am using WEP and not WPA, in case it makes a difference.

So, there are two possible answers here:
1.) Tell me what I am doing wrong
2.) Tell me an alternative for connecting to a wireless internet connection.
If the second one, I would prefer being able to save connection information (Remember, I am using WEP. Further more it is a randomly generated 128 bit encryption. Kinda hard to remember off the top of my head.)

If more information is needed, just say so. If I knew what information you needed I probably wouldn't need help. Thanks!

Edited_time_total
Back to top
View user's profile Send_private_message 
cthisbear

Joined: 29 Jan 2006
Posts: 3442
Location: Sydney Australia

PostPosted: Mon 21 Nov 2011, 21:13    Post_subject:  

Lucid 5.28 has an inbuilt pet of Pwireless 2.

Might be under Network.

Or try this.
My latest April 2011 technique


http://www.murga-linux.com/puppy/viewtopic.php?t=66936

Welcome to Puppy.

Chris.
Back to top
View user's profile Send_private_message 
sholum

Joined: 21 Nov 2011
Posts: 2

PostPosted: Mon 21 Nov 2011, 23:42    Post_subject: Found it!  

I couldn't find the thing you suggested. However, I did find the program I needed while digging around, I don't know why I didn't think of looking in the context menu (a.k.a. right click. Do y'all still call it that?) I found the network menu in there and it still contained Dougal's Network Wizard (the thing I used before) and just like before when it attempts to connect it says "Unable to connect to wireless network" but clicking the 'Auto DHCP' button fixes it, just like before. So I still don't know why it does that, which will be a bother if I ever try another distro.

Thanks for the information! I don't think it is a firmware issue, though. From what I understood, the network was returning something that caused the connection attempt to fail toward the end. Even though puppy knew the network I was targeting, it wasn't fully connected. I just don't understand why pressing a button that does the same thing would work.

Anyway, solved.
Back to top
View user's profile Send_private_message 
Kharl

Joined: 13 Jun 2010
Posts: 34

PostPosted: Tue 09 Jul 2013, 13:55    Post_subject:  

ahhh.. here we go again... the linux ill

why, why...

why something that was working FINE AND GOOD has to be changed?

unnecessary complications LIMITS the progress, there is not necesity or any justification to the way puppy 528 connects to internet wireless, it just DOES NOT WORK

it has a loss of focus and vision what puppy linux is intended to. TO BE SIMPLE ROCK SOLID AND RELIABLE FOR NOVICE USERS!!!

and just that tinny issue with the wirless setting throw all that to the toilet.

and the worse thing is that almost all linux fan agree that there is no other way and that it must be that way.

just couple of words guys... simplicity and logical and common sense....

just ask to mac or win what did they do wth those words and how did they toke advantage of that... is not casuality.

to learn how things should work need a very sensitive sense of perception and judgment to analize whats wrong and what whould not be that (any) way...


i finished


resume:

puppy linux 5, 520 525 all them the internet worked flawesly (and safe)
then 528 does not.... any logical justification to that?

(i am a programmer, but i have the HUUUGE hability to see things throu the eyes of a novice.... )
Back to top
View user's profile Send_private_message 
cthisbear

Joined: 29 Jan 2006
Posts: 3442
Location: Sydney Australia

PostPosted: Tue 09 Jul 2013, 21:44    Post_subject:  

Kharl:

Putting yourself in a corner limits your vision.

" unnecessary complications " >> Frisbee generally just works.


"""""""""

And if there is a complication...try this.

Number one....could be up to 45 seconds to connect.

Lucid 5.28 v5 Frisbee to setup wireless...


The Frisbee Pet(installer) is not activated n Puppy Lucid
and is either under networks or Internet.

" When you boot a recent Puppy....install Frisbee.

Frisbee is either enabled automatically or is an option >> Pet
in Network or Internet >> in the Puppy menu.
Sometimes it is in the Connect menu on the screen.

In Lucid 5.28 it is in Network????????????

Run the pet

wait at least 10 - 45 seconds

Now try Connect...Frisbee should be a third option.

" If it won't play right...try this...

Change the >> Ap_scan Parameter

http://www.murga-linux.com/puppy/viewtopic.php?t=76279&start=435

::::::::

On some Puppies...if there is still no connection.

I exit to the prompt.

Then I type xwin >>>to return to desktop

and magic happens...I connect.

With the last Precise with my horrible Dell I had to do that.

Mind you Win7 often fails to connect as well on that Dell Studio XPS.

::::::::::

And try the battery trick.

Works for Windows as well.

Yeah! I know...you'll say BS.

Turn off your laptop

Pull out AC power lead

and the battery

Hold down the Power Button for 30 seconds.

Re-assemble and boot up.

Try to connect now.

""""

Also...Linux didn't make the shitty hardware..

Here is a sample...this is the worthless crap you have to deal with.

Qualcomm Atheros AR8161/8165 Lan driver


http://murga-linux.com/puppy/viewtopic.php?p=712192#712192

Chris
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0809s ][ Queries: 12 (0.0288s) ][ GZIP on ]